This Kodak camera model was released in August 2009. It comes in a variety of colors, and the device allows you to view your photos on a three inch color LCD.

Preguntas 4 Ver todo

Camera thinks plugging in means turn on?

(My camera's actually an M552 but that wasn't an option on here)

Every time I plug in my camera, the light between the power and photo buttons blinks once or twice like it's supposed to; after a second it stays on, then the backlight on the screen turns on. After a few more seconds the camera just turns on and there's no "plugged in" indicator on the display.

If I turn it off when this happens, it turns off and acts like it isn't plugged in to the charger at all. Sometimes moving around the cord will make it all happen again, as if the cord were out of alignment.

When it's plugged in the battery seems to be full, but unplugging it reveals it to be critically low.

I've tried it with at least four different charging cords, outlets all over my house, and I've tried just leaving it plugged in. It simply will not charge like it's supposed to. I've tried cleaning the battery and the battery socket as well as the micro-USB port.

Does it just need a new battery?

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 0
Agregar un comentario
Reparte el espíritu de reparación esta Navidad
Obtén $12 de descuento en tu compra de $50 o más con el código FIXMAS12
Reparte el espíritu de reparación esta Navidad
Obtén $12 de descuento en tu compra de $50 o más con el código FIXMAS12

1 Respuesta

Solución Elegida

Hi @jackurbs ,

As you have inspected the USB port and ensured that all the pins are there, that they are straight and parallel with each other and that there is no lint or debris trapped in the port enclosure, (use a strong light and a magnifying glass), then it sounds as though the USB port may be loose on the systemboard.

Try inserting the USB cord into the camera only and then, whilst firmly holding onto the camera , gently, stress very gently grab hold of the USB plug and try to move it side to side and up and down to check if there is any movement at all in the USB socket.

If it feels like there is then perhaps there is a problem with the USB port board connection.

Unfortunately, I've been unable to find a video or manual which details the procedure to open the camera to inspect the port. You may have better luck.

Fue útil esta respuesta?

Calificación 2
Agregar un comentario

Añadir tu respuesta

Jack Urbs estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 0

Últimos 7 Días: 0

Últimos 30 Días: 0

Todo El Tiempo: 32