Saltar al contenido principal

Repara tus cosas

Derecho a reparar

Tienda

A very unique freezer problem

I recently picked up a freight damaged saturn commercial freezer. It was dropped by the Looks of it and the heat exchanger had broken free of the Compressor. After changing the oil (polyoster 32) replacing the dryer, and reattaching all connections, I evacuated the system and recharged it with r404a. It now cools down to 18 but it Should get down to -10. Evaporator is functioning Fine and It's a new unit so all coils are clean. Not Sure Where to go from here. Any help would be appreciated.

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 0

Comentarios:

Hi @yaslana ,

What is the model number?

Check if it has a thermistor or thermostat type sensor that "tells' the control board to stop the compressor as the temp has been reached. Perhaps it is faulty.

If you look up 'Saturn (insert model number) parts' it should tell you what is there in the way of thermistors etc.

- de

It's a saturn stm23f. The Compressor runs constantly but will Not reach proper temp. Everything seems to be functioning as it should.

- de

Refrigerant is charged at 50psi On the suction side.

- de

Hi @yaslana ,

Just verifying that the evap fan is working OK?

How 'cold' does the evap unit feel?

Be careful as you could literally stick to it with bare skin if it is OK. It should be icy cold. Use cotton gloves.

How long has it been running?

Sometimes it can take 12-24 hours to get to correct temp when starting from ambient.

Try placing a thermometer inside to verify that the display temp is correct.

Are the door seals OK and sealing tightly that there is no cold air escaping?

Just some thoughts.

- de

Evap fan is Working. Digital temp verified with thermoelectric probe. I relieve some of the refrigerant and temp dropped to 14 at last check.

- de

Mostrar 4 comentarios más

Agregar un comentario

ABRIR TODAS LAS PESTAÑAS

Kits de actualización de RAM para Mac

Compra kits

Suficiente RAM
para todas las pestañas

Compra kits

1 Respuesta

Solución Elegida

Problem fixed if Not solved. I recovered the 404a in the system. Drew a deep vacuum and gave a liquid recharge On the high side at 5.1 oz. Let it run for about 5 hours and found it at -10. Problem fixed but still Not Sure why temps Were off last time I charged it.

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

Añadir tu respuesta

Loren estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 0

Ultimos 30 días: 1

Todo El Tiempo: 105