Repair guides and support for Panasonic's Viera line of televisions.

Preguntas 140 Ver todo

TX-42ASX659 not turning on properly

Hey,

I asked this question before, but with the device "Televison". Idk why but you can't choose Panasonic Viera from the devices when changing it or opening a thread without any device selected in the first place. I didn't really get any help there so I figured I'd ask here since I made some progress and this is the right category.

My Panasonic TX-42ASX659 is not turning on properly.

As seen in this video, when turning on first the green light flashes then the screen turns on twice for a split second and then the light starts to flash once every three seconds.

I can't make out any pattern and I counted up to 30 until I gave up, so I assume it's error code one.

I tried every "reset" method I found on the internet.

- Holding down power button for 60 seconds with now power

- Holding down power button for 30 seconds with power

- Holding down power button and volume up/down for several seconds

I opened up the TV and checked for any blown capacitors etc. I'm not an expert, but everything looked ok, nothing out of the order. Here is a Imgur Album with some pictures of the insides.

Block Image

Block Image

Block Image

Block Image

I didn't really know what contacts to check so I checked all contacts labeled SRV - ?.? V. Those seem to be okay as long as the TV is on (Green light flashing), but some won't have any mensurable voltage when the red light blinks.

Like I said, at this point I am at my wit's end. I don't really know what to look for and what to check.

Thanks in advance!

Jonas

Update (01/11/2018)

Update:

I replaced the PSU, but sadly it doesn't work with this one either.

I checked the same TPs @oldturkey03 gave me in his comment and they have the correct value, so the new PSU itself seems to be working.

The error behavior is exactly the same as explained in the original post. Check out this Video

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 2
Agregar un comentario

3 Respuestas

Respuesta Más Útil

Hi @jonasschade, if possible open up the TV and check on the power board inside to inspect for any possible bad capacitor.

Fue útil esta respuesta?

Calificación 2
Agregar un comentario

@jonasschade looks like you are losing your backlight. You do want to go ahead and post some images of all of your boards with your question. Use this guide Adding images to an existing question for that. It will allow us to see what you see. Your model appears to be a European model so if you can, check for a chassis number on the back cover. Let us know what it shows. This could be a power board/LED driver issue as well as a T-con board issue.

Update (01/02/2018)

Here is the schematic for the power board. TNPA6011+Panasonic+LA51.pdf

Fue útil esta respuesta?

Calificación 2

Comentarios:

There is a link to a imgur album in the original post already, where pictures of all the boards can be found. https://imgur.com/a/zC7xa

por

The Serial Number is NP-4620820. I hope you meant that by chassis number, if not can you tell me where I can find it? This and the Model Number (which is the TX-...) are the only two I could find on the label on the back.

por

@jonasschade check the fuse on the T-con board (you identified this as your panel controller) for continuity first. Then (with your set turned on so be mindful of shortcircuiting) the voltage on it. Multimeter to VDC Black probe to ground and red probe to either contact of the fuse. What you getting?

por

@oldturkey03 just to make sure this is the fuse (see pic) correct? https://i.imgur.com/eSDVx0p.jpg

por

@jonasschade yes that is it. Sorry got busy:-)

por

Mostrar 10 comentarios más

Agregar un comentario

Block Image

Update (03/08/2018)

Block Image

This is problem ... I change one backlight panel and power on TV ..

All is OK :)

Fue útil esta respuesta?

Calificación 0

Comentarios:

I replaced the PSU which fixed the voltage values, but the TV still doesn't turn on, so I guess it's a Mainboard issue but I'm far from an expert...

I'm thinking about buying a new MB, but I haven't until know.

por

Problem is in the backlight. One led is death.

por

Agregar un comentario

Añadir tu respuesta

Jonas Schade estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 2

Últimos 7 Días: 18

Últimos 30 Días: 80

Todo El Tiempo: 693