Saltar al contenido principal

Support for gas-powered and electric golf carts, sometimes referred to as golf cars or club cars after the Club Car Golf Cart brand.

Preguntas 449 Ver todo

Fuel system flow problem. Engine will not start and run

My golf cart will not start this spring. It appears that it is starving for fuel. I have replaced the fuel filters, fuel pump, and checked the fuel lines. It still will not run. Do I need to prefill the gas lines and filters? Could the engine be shot and not creating enough compression to run the fuel pump?

Contestado! Ver respuesta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 4

Comentarios:

My 2006 Club Car fan out of fuel Sunday. I filled the tank, and now it won't fire. The fuel filter is empty. what should I do?

- de

I have the same problem, filter fills with air then motor runs out of gas. I use a hypodermic needle to fill filter and it runs for a day. Replaced filter and gas line to tank and dip tube and that did not fix it, sure would like to get it fixed.

Chuck

- de

New fuel line, new fuel pump, new carburetor, starving for gas. Fill the line from the pump to carburetor and runs great until it runs out. Vacuum lines working good. Any thoughts?

- de

I just had this problem when I went to take my Yamaha golf cart out of winter storage. After consulting owner manual and performing basic checks I happen to notice fuel filter was empty. Gas tank was also low. Added more gas to tank and tried to choke and start with no success. I eventually had to disconnect the fuel line from filter Disconnected the first gas line out of tank to filter and started siphoning with my mouth and then reattached line to filter. Had to choke hard and constant few secs before the filter filled and the line to the carburetor then it fired right up. Thankful that’s all it was. Also has anyone replaced tires or upgraded to a knobby off road style? I am on a farm and use it to get around quick and tow a small wagon. Happy riding

- de

Agregar un comentario

2 Respuestas

Solución Elegida

@t663s33, Fred Clevenger, You did not state your year/make/model/engine so I will post some what generic answer on fuel issue. Ensure you have good fresh gas and that there is fuel flow from the tank, as there may be an internal screen in the tank plugged. If the engine has a fuel pump, you should not have to prefill lines/filters. Now assuming the engine was running good right up to the end of last season, I would think the engine to be OK. There is a possibility that the carburetor could be dirty or the float stuck not allowing gas to engine. If you can remove the air filter from the engine and squirt about 1/2-1 ounce of fresh gas right into carb.. If engine starts/runs then quits when the added gas burns off, the problem will probably be dirty carb. since you have already addressed filter, fuel lines, pump. If problem persist after carburetor cleaned/rebuilt the new pump may be faulty, vacuum line to pump pinched or plugged. If all looks good and still no go, have the compression checked on the engine to see if rings/pistons worn or possibly valve sticking. Good luck. I hope this helped you out, if so let me know by pressing the helpful button.

Fue útil esta respuesta?

Puntuación 10

Comentarios:

I recently got delivery of a second hand Jaguar x type sedan from Japan. Cranked up well from the wharf and drove home without any problems and flew out for 3 weeks to work site. After returning back couldn't start the car. Ignition lights are on but engine not cranking. What would be the possible causes why the car is not even cranking? Checked for fuel flow and no indication of fuel flow coming out from the fuel nipples. If anyone has encountered similar problems with Jag please help me out. Thanks Issac from Papua New Guinea

- de

I have the same issue going on with my 89 marathon. New carb new fuel pump and new spark plug. Will only start and run for 10 seconds top

- de

If I spray a little starter fluid in the intake it runs for a couple min till it burns that off.

- de

I have the same problem with my 91 ez go marathon. Fuel filters and pump changed. No luck. Will run for a minute with starting fluid.

Sounds like the carburetor is next . Did you guys ever solve your problem?

- de

I got a 05 VW BEETLE. I changed the Fuel Filter, Fuel Pump x3, Fuel Pressure Regulator, Timing Belt, And Crankshaft Sensor.

Still I Only Get A Trickle From Fuel Pump (Straight Wired).

What could it Be, it won't crank

- de

Mostrar 2 comentarios más

Agregar un comentario

My boss has an old Columbia par car. There has been a new car curberator put on an the line from the oil talk has been clamped off so now the gas has to bee mixed in the gas tank. There is a hose that comes from the bottom of the motor to the fuel pump. When it's hooked up it makes fuel squirt out the side of the carburator an it doesn't want to run very good. If you diconnect this line it runs great until all the fuel in the filter is empty then you have to fill it back up to make it pump more fuel into filter. Also why would they clamp off the line from the oil tank that goes to the center of the motor. Is that another carb that has been disconnected or what. I haven't been able to find anything on it. Any help would be greatly appreciated. Also I think the belt that has been put on it isn't the right size cause it doesn't grab til you have it floored then it sounds the tires an takes off but boggs back for an also there is no reverse. It just sits an makes a weird noise I reverse. Tha ks for your time. Vet with to much time on his

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

Añadir tu respuesta

Fred Clevenger estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 41

Ultimos 7 días: 195

Ultimos 30 días: 966

Todo El Tiempo: 68,088