Saltar al contenido principal

Modelo A1311 / Finales de 2009 / Procesador Core 2 Duo de 3,06 o 3,33 GHz

Preguntas 310 Ver todo

CPU Fan no longer works.

Guys, I'm very frustrated, my iMac had a problem with the logic board and that's why the CPU fan wasn't working, at the time I thought the problem was with the CPU fan, so I threw it away and bought another one, which didn't work.

So I changed the board logic, and the cpu fan started to work, now the problem happened again, the cpu fan simply stopped working, there is no dirt, it is spinning freely but it doesn't work.

Is there any way to test the cpu fan connection so I know If the problem is in the fan or the logic board?

Please help me!!!

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 0
Agregar un comentario

1 Respuesta

What does the onboard diagnostics tell you? Restart your system and using a USB keyboard press the D key to enter just after the bong.

Fue útil esta respuesta?

Puntuación 0

6 comentarios:

No error appears, and the fan is not stuck.

Isn't there a way to connect the fan directly with 12v?

- de

@ramonferre18311 - Not really, there is a tach within the unit. That’s how the SMC is able to monitor the fan.


I don’t think your issue is the fan as diagnostics would have failed.


let’s dig in a bit more. Install this great App TG Pro it will allow you to see as well as push the fan. Run a heavy CPU task to force the fan take a snapshot of the TG Pro let’s see all of the thermal sensors (you may need to reshape the window to get it all visible in the pane. Then within TG Pro enable Turbo mode you should see the CPUs sensors temps drop. Post both snaps here so we can see them.

- de

@danj It's no use, it stays at 0 rpm, the fan itself doesn't spin, it doesn't even oscillate between 0 and 149 rpm, it's simply stopped.

One question: at full load the cpu reaches 86ºC but it doesn't go beyond that, can I leave it without the cpu fan? Or could the cpu burn out? At Idle it is around 50-60ºC

- de

@ramonferre18311 - Well the fans power control logic on the logic board is likely failed so the fan is not getting power. What gets me is you stated you replaced the logic board as well with the same result. Maybe we have a twofer! Thats when you have a second issue which is the root cause of this failure! So what is common here? While the power supply is one item the other is the AC line cord or in truth the power feeding it! I've often encounter strange failures do to mis-wired homes as well as bad grounding. I would get a cheap outlet checker to test the outlet your system is using to see if theres something there.


As far as fixing your logic board are you up to the task? This will need some soldering skills and access to the small SMD components. You'll also need the schematics and board views to reference to debug this at the deeper level with a DVM.


Lastly, I wouldn't press my luck here 86ºC is quite high even at idle at 50-60ºC is not good either! As an example my 27" iMac is running at 43ºC right now.

- de

@danj I don't want to invest any more money in this iMac, I also don't know how to do repairs at this level, so I'll use it while it's working, if one day it stops working, I'll turn it into an external monitor.

I really thought it was strange for this to happen again, but on the old logic board this problem occurred just 4 years after I moved to my current home. With the new logic board, just 20 days.

I rarely use the iMac at full load, it's a situation that doesn't match reality.

- de

Mostrar 1 comentario más

Agregar un comentario

Añadir tu respuesta

Ramon Ferreira estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 1

Ultimos 7 días: 1

Ultimos 30 días: 1

Todo El Tiempo: 28