Saltar al contenido principal

Modelo A1311 / Mediados de 2011 / Procesador Core i5 de 2.5 y 2.7 GHz o Core i7 de 2.8 GHz

Preguntas 429 Ver todo

La pantalla de mi mac no enciende backlight

Hola, desmonté un iMac para cambiar el disco duro y reprogramar el firmware de la bios y a la hora de volver a montarlo, la pantalla no enciende el backlight

  • La pantalla del MAC muestra imagen, si apuntas con una linterna se ve imagen
  • Si conectas una pantalla externa se ve imagen y todo bien
  • Los leds de la pantalla funcionan correctamente, aún así probé con 2 pantallas
  • Cambié la placa del inverter
  • Se iluminan toda la secuencia de leds incluido el Led4

Alguna pista?

Muchas gracias!

Actualización (12/03/23)

This would be the inverter, the negative one I am taking to the chassis and the positive one I attach to the third pin when I turn on the computer

--------------------------

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Contestado! Ver respuesta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 1
1 comentario

@miguelange57370 I am off tomorrow so we can start working on this earlier. It's almost morning where you are

- de

Agregar un comentario

1 Respuesta

Solución Elegida

@miguelange57370 how/why did you update the firmware? Did the backlight work before? Do both screens have known working backlights for sure?

Your logic board should be a 820-3126-A. Try this:

inspect and reseat the following cable connections:

  • Output cable between lower end of LED backlight board and lower end of LCD panel.
  • Vertical sync cable between upper end of LED backlight board and LCD panel.
  • DC power cable between upper right of LED backlight board and power supply.
  • Replace any damaged cable.
  • Reinstall LCD panel

Inspect and reseat DisplayPort cable between LCD panel and logic board.

Check the power to your inverter (4 pin or 6 pin connector?) to make sure that your inverter gets power. The left and right outside connectors are the power connectors.

There is a possibility that your back;light enable circuitry may have issues. Here is the schematic for that. See if all of those parts are functioning. Check for the 3.3V on your inverter as well. It is one of the inner contacts on the inverter connector

Translation

@miguelange57370 ¿cómo/por qué actualizaste el firmware? Funcionaba antes la retroiluminación? ¿Se sabe con certeza si ambas pantallas tienen retroiluminación que funcione?

Tu placa lógica debería ser una 820-3126-A. Intente esto:

inspeccione y vuelva a colocar las siguientes conexiones de cable:

  • Cable de salida entre el extremo inferior de la placa de retroiluminación LED y el extremo inferior del panel LCD.
  • Cable de sincronización vertical entre el extremo superior de la placa de retroiluminación LED y el panel LCD.
  • Cable de alimentación de CC entre la parte superior derecha de la placa de retroiluminación LED y la fuente de alimentación.
  • Sustituya cualquier cable dañado.
  • Vuelva a instalar el panel LCD
  • Inspeccione y vuelva a colocar el cable DisplayPort entre el panel LCD y la placa lógica.

Compruebe la alimentación del inversor (¿conector de 4 o 6 patillas?) para asegurarse de que el inversor recibe alimentación. Los conectores exteriores izquierdo y derecho son los conectores de alimentación.

Existe la posibilidad de que el circuito de habilitación de la luz trasera tenga problemas. Este es el esquema. Mira si todas esas partes funcionan. Compruebe los 3.3V en su inversor también. Es uno de los contactos internos en el conector del inversor

Block Image

Update (12/02/23)

@miguelange57370 Here is the connector for your inverter.

Let us know what voltages you get. those are DC voltages. If you do not get the BLO Backlight on Voltage, your inverter does not get the signal to turn the backlights on. In that case you would need to check the circuitry on the logicboard.

Translation

@miguelange57370 Aquí tienes el conector para tu inversor.

[imagen|3158319]

Haznos saber que voltajes obtienes, esos son voltajes DC. Si no obtienes el BLO Backlight on Voltage, tu inversor no recibe la señal para encender las luces de fondo. En ese caso tendrías que comprobar los circuitos de la placa lógica.

Update (12/03/23)

@miguelange57370 in your case it will not be 12V but 3V

[imagen|3161792]

Update (12/03/23)

@miguelange57370 LED driver board DC power connector

Block Image

Update (12/05/23)

PSU connector pinout

Block Image

Update (12/05/23)

@miguelange57370 try this now. Pin 1 is ground :-)

Block Image

Update (12/05/23)

@miguelange57370 trying to figure out which contact on the connector those two wires are. Can you see them going into the connector?

Block Image

Update (12/05/23)

@miguelange57370 one more close up. This time of the are i outlined.

(Pin 2 is GND pin 4 is BL enable)

Block Image

Update (12/05/23)

@miguelange57370 here is the schematic for J601

Block Image

Update (12/05/23)

@miguelange57370 okay so here is what the back connector looks like.

Block Image

Update (12/06/23)

@miguelange57370 continuity on J601

Block Image

Actualización (12/06/23)

@miguelange57370

Block Image

CN 1 from power board to LED driver

Actualización (12/06/23)

@miguelange57370 should look like this

Block Image

Actualización (12/06/23)

@miguelange57370 Connector A and connector B

Block Image

Actualización (12/07/23)

@miguelange57370 backlight connection

Block Image

Actualización (12/08/23)

@miguelange57370 disconnect the LCD backlight connector for the display

Block Image

Update (12/09/23)

@miguelange57370 J602 is the logicboard to backlight connector.

Block Image

Update (12/09/23)

@miguelange57370 DP connector circuitry

Block Image

Fue útil esta respuesta?

Puntuación 1

247 comentarios:

Thank you very much, I'll try it. Yes, before the screen worked 🥲 I updated it because I forgot the password and my system was corrupted, so to reinstall the system I had to remove the password

- de

@miguelange57370 :-) fair enough. Just wanted to make sure these two things were not connected. Let us know what you come up with. Good luck.

- de

Hello again @oldturkey03, I have tried what you told me, the panel is installed correctly, the cables seem to be fine at first glance, I have also tried others and nothing. I need to see the diagram because I don't really know what it refers to, the back of the motherboard? To test the 3.3V of the inverter where you would have to perform the test. Thank you a million, I'm at that point where one is blocked. The power cable that goes from the bottom left to the inverter board is 6 pin. And yes, my board is 820-3126-A

- de

Could you update the image of the inverter connector, I can't see it

[image|3158319]

- de

Mostrar 242 comentarios más

Agregar un comentario

Añadir tu respuesta

Miguel Ángel Martín estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 0

Ultimos 30 días: 9

Todo El Tiempo: 919