Saltar al contenido principal

2.26 o 2.4 GHz / Carcasa Unibody de plástico blanco

Preguntas 628 Ver todo

My headphone jack glows with a red light

After accidentally pulled my headphones out too fast and now the red optical out light is shining in my headphone jack.

Ive tried everything to try and fix it, like a tooth pick on the bottom of the optical switch but nothing happens.

Could there be a way of disengaging the head phone jack but fixing the built in speakers, because i never use the head phone jack.

Or a software that fixes the optical out light?

Contestado! Ver respuesta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 7

Comentarios:

I tried all these solutions, and nothing worked for me. I've looked with a magnifying glass and there's not much going on in there. Mine was strange too. The red light was on, but I was still able to switch between sound types, but the headphone sound was really scratchy.

In the end I just bought a USB audio interface for $10, which as a workaround, works just fine. I plug my speaker system into that.

Just want to put it out there, that there are also optical to analog converters for not too much money, so if you're really stuck, you can do that instead of forking over big cash.

- de

Agregar un comentario

8 Respuestas

Solución Elegida

Your digital audio out has switched on. You can insert a plastic toothpick in the hole and try and switch it off. The switch should be at the 3 o'clock position and go towards the 6 o'clock position. Some people also have had luck inserting their headphone jack and pulling out a few times. Another recent report was that inserting the headphone jack and turning it in the hole helped.

Fue útil esta respuesta?

Puntuación 18

Comentarios:

And if those solutions don't work, fear not ... all you have to do is replace the logic board!

- de

I've tried that but i read about a something with a software where you can choose different outputs. I think the switch in my headphone jack is broken because i excerpted a little bit of force last time i tried it.

- de

I don't know about a software fix. If you're frustrated with trying to fix it, get a new pair of eyes and hands to read how to fix it and give it a shot. I have never heard of anyone actually breaking this switch.

- de

Hey Mayer. Can you describe the shape of the switch more? I'm currently having the same problem, and none of the other solutions are working. Is the switch at the end of the hole near the LED, or is it on the side of the cylinder somewhere? If I knew what I was looking for, I'd surely be able to find it. Thanks.

- de

This worked first try. Thank you!

- de

Mostrar 3 comentarios más

Agregar un comentario
Respuesta Más Útil

put your mouth directly on the port and blow as hard as you can while the mac is on. Trust me it works. I struggled for hours before i knew it actually works. It is worth the few seconds. Cheers.

Fue útil esta respuesta?

Puntuación 49

Comentarios:

This worked perfect for me. I was struggling, trying to find a way to fix it, until i found this, thank you. Ignore other complicated solutions. No toothpick needed.

- de

thank you very much for this idea,worked perfectly.

- de

Blowing in it worked!!!!!

- de

Holy crap, I was an apple certified tech for half a decade, and I'd never heard of this. Totally worked on a Mid 2012 Unibody MBP.

- de

Boom! worked first try.

- de

Mostrar 41 comentarios más

Agregar un comentario

I just had this problem and I was completely flipping at having to replace it! But i just got a match, and moved it around a bit inside the jack then blew on it. I think blowing on the jack helped get something that was jamming the jack but i hope that helps!!! :)

Fue útil esta respuesta?

Puntuación 2

Comentarios:

I had to check that itś November and not April! I found this thing with the red LED in the 3.5mm output hole after rebooting for the first time after installing Mint, the solution was to change the sound settings from analogue 2.0 stereo to analogue 2.1 stereo. The reason for this was that the right channel had been using both its own speaker and the sub, whereas the left channel was only using its own speaker, this can be tested in sound settings but the case speakers are designed as a 2.1 setup and now that theyŕe running that way, there is no red glow from that socket. I tested with headphones in, but they work in exactly the same way regardless of whither you remember to enable 2.1. Possibly the red LED comes up regardless of the nature of the audio fault? Either way, check that your output is set to 2.1 as apart from anything else, onboard sound is less bad when all three drivers are working!

With the output set at digital, the red LED comes up but no sound is heard at all, the fact that the respondent above identified this as a cause of the trouble makes sense but why not simply switch to analogue - making sure to select 2.1 - in sound settings, which has had the exact same effect? ;-)

- de

Wow this worked first try!

- de

Yes, If you go to the 'preferences' menu, click on sounds. When the dialog box pops up, look just to the right of 'output profile' and you should find it. Worked for me after I blew in the port like a weirdo.

- de

Agregar un comentario

Just for the record, audio jacks seem to glitch a lot with Macbooks (I've seen happen with both my 13 and 15 inch) so I would highly advice to plug/unplug headphones as careful as possible, cheers

Fue útil esta respuesta?

Puntuación 1
Agregar un comentario

None of the above helped. I bent the tip of a safety pin 90 degrees then proceeded to jiggle gently with the faulty/stuck contact i was playing a yt video for sound check then ….few minutes later the sound one on from the speakers and light went off. Hope this helps.

Fue útil esta respuesta?

Puntuación 1
Agregar un comentario

Hi,

I had the same problem, My internal speakers were not showing in system preferences, but when you turn on the MacBook pro, you hear the gong, so I know my speakers was working ok

so I used compressed Air in the jack port...Nothing

tried to clean the jack port...Nothing

Poked things in the jack port...Nothing

reset the VRAM...Nothing

so I thought outside the box, So I squirted some good old WD40 into the jack port (the Macbook Pro was switched off) then I pushed in and out a 3.5" jack in the port a couple of times and then left the Macbook Pro powered off for about 40 mins, then when I powered the Macbook Pro back on

BINGO, my internal speakers are now working OK....YIPPEE

So I am guessing that the WD40 freed the stuck switch in the jack port.

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

Blowing helped for me. But every time when i closed of restarted my MBP the speakers stoped working.. so i sprayed WD40 in the audio port and a few weeks later still works great!

Fue útil esta respuesta?

Puntuación 0

Comentarios:

Please don't use any oil sprays like WD40 as they don't fix the issue. Your jack has a bunch of contacts that also act as switches. One or more are dirty or mis-aligned.

- de

Agregar un comentario

Stop giving your MacBooks those ‘Blow…..’ ; )

Though I do admit doing/trying this ‘Blow…..’ with industrial air compressor on a high pressure setting, which by far probably can do it better than all of us. It didn’t help! Ps…Hope no-one seen you doing that ; ))

Get hands dirty with replacing a spare working one from some donor board.

Block Image

Block Image

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

Añadir tu respuesta

alex von estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 2

Ultimos 7 días: 34

Ultimos 30 días: 131

Todo El Tiempo: 99,904