Saltar al contenido principal

Cuboid-shaped compressor-based dehumidifier

Preguntas 1 Ver todo

Dehumidifier stops after start-up, tank-full and defrost LEDs blinking

I can switch this dehumidifier on after turning it off & on again at the socket to allow the control board capacitors to drain, and the compressor does start up, but then after 10 seconds it stops, and both the indicator lights for tank-full status (red) and defrost cycle (orange/amber/yellow-ish) flash at the same time.

The operating manual does not mention this error.

I have checked that the bucket is properly seated and the fill-switch works - when the bucket is removed, only the red full status LED blinks, and the compressor will not start at all if I power up the device in that state. Removing or replacing the bucket while the device is on switches between the two aforementioned error states.

I have had this dehumidifier for just over 4 years now, running it for a few months each year, and it has been used in fairly cold conditions this winter, but never outside its rated operating range. I am currently testing it in a room at 18 degrees Celsius, where it has had over a day to warm up, so this makes no sense to me.

The normal behaviour was that in a cold room it would occasionally run a defrost cycle, with the amber LED lit up constantly while it warmed the coils, then continued working with that light off.

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 0

Comentarios:

When I contacted the manufacturer about this error, their response was:

"Thank you for your email. unfortunately, this fault has not been found in the database and therefore, the device will need to be inspected for a repair.

Please can you tell me your order number and I can then see if the device is still under warranty."

Obviously, it is well outside the warranty, and I suspect that this error was a planned failure programmed onto the control board for obsolescence of otherwise perfectly functional hardware. (I can hear the compressor starting to work for those few seconds before the error stops it.)

A friend of mine also has a Blyss WDH-1012EA, which is almost identical in design, displaying the exact same behaviour, blinking a red and yellow/orange-ish LED for full and defrost errors straight after starting up.

- Por

Agregar un comentario

1 Respuesta

Respuesta Más Útil

There'‘s no specific information on your machine out there so I’ll give you general fixes:

Remove and test the overflow cutoff switch. You can do this with a volt-ohm meter. Clip the leads to the terminals on the switch. Depress the bar or trip lever on the switch. If the meter’s needle does not show continuity and also no continuity as the switch is clicked back and forth, the switch is probably faulty and will need to be replaced.

Remove the humidistat and check it. You can test a dehumidifier humidistat fairly easily using a volt-ohm meter. Also using a volt-ohm meter, you can tell if the overflow switch works or not. Just set the meter to the RX1 scale and attach its leads to the humidistat’s terminals.

Rotate the humidistat’s knob as far as it will turn in both directions. If the volt-ohm meter registers zero ohms through only part of the humidistat dial’s range, the humidistat is working. If it registers zero through the entire range, it’s broken and must be replaced.

Fue útil esta respuesta?

Puntuación 1
Agregar un comentario

Añadir tu respuesta

Andrew Drummond estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 0

Ultimos 30 días: 0

Todo El Tiempo: 7