Saltar al contenido principal

Repara tus cosas

Derecho a reparar

Partes y herramientas

Lanzado en Septiembre 16, 2016. Modelos 1660, 1778. Disponible en GSM o CDMA / 32, 128, o 256 GB / Oro Rosa, Oro, Plata, Negro Mate y Negro Brillante.

Preguntas 946 Ver todo

No Cameras or flash

Iphone 7 Plus "Both" Cameras and Flash not working. Customer said that it had previous water damage, took it to a shop for ultrasonic cleaning and it has been good for months... no issues till he tried using camera the other day and discovered both were not working. No visible signs of why... FPC Diode readings okay... anyone else experience this and what you did to resolve? Thank you

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 1
Agregar un comentario

Kits de Reparación de Pantalla LCD de iPhone

La opción de presupuesto, cubierta por nuestra garantía de por vida.

Compra kits

Kits de Reparación de Pantalla LCD de iPhone

Reduce los costos de reparación, no la calidad.

Compra kits

1 Respuesta

Solución Elegida

Hey Michael, good to have you back!

Hmmm…water damage…you know what I say in regards to latent issues :>).

I once had a similar water damage situation on a 6S Plus where everything probed okay but still didn’t work, despite replacing the LDO’s etc. It drove me nuts until I realized that the the VCC_MAIN wasn’t fully connected between the RCAM LDO and the rest of the VCC_MAIN. When I probed it in diode mode, I got a similar reading (I didn’t notice the slight discrepancy at first) but what I was reading on the VCC_MAIN pin of the LDO was actually the other downstream FCAM LDO and the values were almost the same. When I finally realized this, I tested the continuity between the RCAM LDO VCC_MAIN pin and the rest of VCC_MAIN and sure enough, they weren’t connected. The inner trace had probably blown due to the water damage.

The circuitry is a little different on the 7 series so you’ll have to dig around but make sure that there is actual 4.2V at the input of the LDO.

Fue útil esta respuesta?

Puntuación 3

Comentarios:

Thank you for taking the time to provide a great answer to my question. I tested both cameras and both worked in test housing... I only had a few 7 plus housings with what I thought were good cameras, so I tested them and convinced me that they were good when tested good in test housings and did not work in repair phone. I didn't have new cameras so got them from one of my competitors shop and walla! cams came back to normal. I have just been puzzled by it all and gave up trying to make sense of it all because it made absolutely 0 since! So, after repair, it was rebooting and voice memo was not greyed out but had error "No audio device found", I reballed and ran C12 jumper and it fixed the voice memo but not the intermittent crashes every couple minutes. I replaced Tristar without testing just to save time and it worked! Everything is 100% I just got distracted by life, my new brick and mortar shop 100 miles south of home & haven't contributed much due to business picking up not leaving much time.

- Por

Great!! Congrats on the new B&M shop but 100 miles...ouch!

- Por

Actually, It was a pain but done purposely to get into a better market for my business. We live in a small country town of about 8,000 and moved to a larger Indiana University town downtown to capture a market nearly 10 to 20 fold

- Por

Best of luck!! I know you will do great!!!

- Por

Agregar un comentario

Añadir tu respuesta

Michael estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 0

Ultimos 30 días: 0

Todo El Tiempo: 141