Saltar al contenido principal

Repair guides for machines designed to move slowly and get big jobs done, including farm vehicles and construction vehicles designed for specialty tasks.

Preguntas 49 Ver todo

Manual PTO not engaging blades

Hello - I have a White Outdoor LT-1650 tractor. When the tractor has been running for 15 mins or longer, the manual PTO will not engage the blades. I replaced the belt and spring thinking they may have become stretched out. This didn’t solve the problem. The engine pulley is spinning fine. When I turn the PTO lever, the pulley pushed out fine. It just doesn’t seem to be putting enough pressure on the belt. I can’t find any other adjustments that would solve this issue. Any help would be great.

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 1
Agregar un comentario

2 Respuestas

Solución Elegida

@mjones21 besides checking the idler pulley you also need to check the routing of the belt, the connection of the springs, the engine pulley and the pulley's on the deck. Make sure that all of those are in working order, not seized etc.

Block Image

Fue útil esta respuesta?

Puntuación 2
Agregar un comentario
Respuesta Más Útil

You have an idler pulley that has moved out of place or is seperated/seperating. Very careful inspection will tell you. Look for NEW wear marks on pulleys. Check springs too. Good luck

Fue útil esta respuesta?

Puntuación 2
Agregar un comentario

Añadir tu respuesta

Mark Jone estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 1

Ultimos 30 días: 18

Todo El Tiempo: 565