Repair guides and support for the first generation of Sony's RX100 high-end compact camera. 20.2 MP sensor / June 2012

Preguntas 15 Ver todo

Can I replace a broken sensor in my Mk 1 with one from a Mk 2 or 3?

The sensor from the Mk 2 has lower noise because it is backside illuminated, so it would be awesome to use it for my repair.

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 3

Comentarios:

I have ordered a MK II sensor, I will report results soon.

por

Please do! as i want to try it too, mk 2 or 3 seems to be the same ribbon connection!

por

Agregar un comentario
Reparte el espíritu de reparación esta Navidad
Obtén $12 de descuento en tu compra de $50 o más con el código FIXMAS12
Reparte el espíritu de reparación esta Navidad
Obtén $12 de descuento en tu compra de $50 o más con el código FIXMAS12

5 Respuestas

Respuesta Más Útil

Daniel Jenkins just compared the sensors and it looks like they are physically the same so they should fit. I do not have the diagram for the MK2 ,MK3 so I can not verify if the connections will be the same. I would give it a try and purchase a replacement from a place that let's you return things if they do not fit. Let us know what you find out.

Fue útil esta respuesta?

Calificación 3
Agregar un comentario

Did it work? Currently having the same issues! Also seems hard to get a decent sensor for the MK1! Thx a lot

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

My issue is caused by the faulty ribbon cable of the sensor. I was able to fix the issue, at least temporarily, by prodding and wiggling the cable until it worked again. I will update this thread if I attempt another solution.

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Please also if anyone has tried one of the new lens assembly*as they have the same ribbon with a wider aperture, let the results be known!, also the rx100 mk3 sensor seems to be the same as the 1 and 2!

Actualización (04/05/18)

Block Image

Found this on the Rx100 Mk3 description, apparently they are the same sensor but backside illumination(?!

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Ok, significant update. I bought a MK II sensor and it was working partially, but not properly. I assumed the issue was the still the sensor, so I returned it and bought a MK I sensor, but now I am having some of the same problems. The attached pictures are from the MK I sensor at various exposures, the banding looked the same with both sensors. When I was using the MK II sensor I also had strange problems with the exposure, and the white balance was so biased towards green that the only way compensate was setting it custom with a grey card.

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

Daniel Jenkins estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 0

Últimos 7 Días: 7

Últimos 30 Días: 27

Todo El Tiempo: 480