Saltar al contenido principal

Modelo A1051 / 4 o 6 GB de disco duro

Preguntas 88 Ver todo

After replacing my Logic Board why does my Display not function?

Okay I'm looking for some help fixing my 1st Generation iPod Mini, I got it broken from a friend and when I first got it I plugged it into iTunes and got no response at all. I then brought a replacement battery from iFixit and installed that at which point the iPod did boot, I can only assume from some residual power left in the battery, and displayed the sad iPod icon and wouldn't go any further. I then took this to mean that the logic board was gone so I ordered and replaced the logic board but after I had put in the board and was connecting the display cable back to its relevant connector I noticed the connector on the new board was bigger than the old one but I simply reconnected the cable anyway and continued. Now when I connect the iPod to power I don't get any kind of screen response but I can hear the hard disk heads moving so there must be power in the board. I've begun to think that the display connector is the problem but does anyone have any insight with which they might be able to help?

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 0
Agregar un comentario

1 Respuesta

Respuesta Más Útil

You may have ordered a logicboard for a 2nd generation mini, which has a different LCD and connector. You'll have to now find an LCD for a 2nd gen mini, or find another 1st gen mini logicboard.

Fue útil esta respuesta?

Calificación 1
Agregar un comentario

Añadir tu respuesta

Zagreus estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 0

Últimos 7 Días: 0

Últimos 30 Días: 0

Todo El Tiempo: 1,161