Saltar al contenido principal

10.1" tablet released in February 2014, powered by a custom version of Android 4.4 KitKat, and identified by model number: SM-T520NZKAXAR

Preguntas 34 Ver todo

Won't turn on, won't charge battery

Hello! I open this topic becouse I think this is a diferent problem from the other topics.

I try to fix a SM-T 520 how won't turn on. I replace the USB charge flex cable but it Still not working. With multimeter it is possible mensure 5,4V in one diodo in motherboard when it plug to charger (the current arrives to motherboard) , but in the battery plug pin's arrives only 0,2V how it's not enought to charge battery. The battery shows 3,7V and I think it's not enought to turn on the device. Next week I will try to connect to a variable power supply to know if is a battery problem but I don't beleave. I try every possible reset solution but it don't turn on and it don't show's any led light when it plug to charge. Thank you

Update (10/04/2015)

Block Image

Picture from the motherboard

Update (10/05/2015)

Block Image

Another picture from the motherboard.

Contestado! Ver respuesta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 2

Comentarios:

Good picture but it shows only part of the board. For the charging circuit we need to see the rest of it as well.

- de

Its further to the left under an EMI shield :-)

- de

Agregar un comentario

1 Respuesta

Solución Elegida

rubenmplopes, just because you got some 5.4V on a random diode, does not mean that your charge connector is working. I would suggest that you measure on the connector itself. If you only got 0.2V on the battery connector and if your charging port shows the proper voltage on the pins, then you do want to check the power management IC as well as other components on your charging circuit.

Block Image

Update (10/04/2015)

Use this guide to add images.

Block Image

Fue útil esta respuesta?

Puntuación 1

Comentarios:

Thank you for your answer. I allready check the charger cable how plug to motherboard and somewhere in the ribbon cable I mensure 5.4V. Next step is find the power manager IC... I can't find any motherboard schematic on web... Another thing I forgot to tell is the tablet works fine untill battery drained. After it don't charge and don't shows any signal.

- de

"untill battery drained" sounds like either a bad battery or bad PMIC. Post some good pictures of your logicboard with your question, that way we can identify a few parts for you.

- de

You can see the picture from the motherboard

- de

I post another photo

- de

Hello oldturkey03 did you find any solution? Thank you

- de

Agregar un comentario

Añadir tu respuesta

Ruben Lopes estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 1

Ultimos 7 días: 1

Ultimos 30 días: 5

Todo El Tiempo: 2,330