Flickering every 30 sec and disconnecting external divices

After a few minuts the flicker increase and finaly it is going mad. The same thing happens if I connect it to the thunderbolt port on an other screen. I have seen desciption of a problem like this, here and on others sites, but never seen a solution. It seems that a lot is struggling with the same problem. Have any here in this forum changed the power supply or the logic board. I have seen answers like, change the thunderbolt cable, reset the nvram and smc, and I have tried that too. I have removed the external devices one by one but the problem still exist. I have now bought an Eizo display so I am able to work, but I would love to have the Thunderbolt display back and alive. It is connected to a Mac Mini 2,7 GHz mid 2011, and to check it I connected the display to both an iMac 27" and a Mac Pro. I would love to fix it myself, with help from IFIXIT I have installed an SSD harddrive in my Mini Mac and Mac Book Pro with succes.

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 0

Comentarios:

Sounds like a bad power supply. What happens if you let it cool down and then restart? Same situation, it always does it after a few minutes? What exactly do you mean by "going mad"?

por

After startup it will take from 5 to 20 min. before it starts to flicker. After it has started the time between each blackout is getting shorter and shorter, and finally it is black and whte lines running down the display. (50Hz?) I can't see a thing on the screen. I have to shut down with the power button. If I start up again it starts to flicker immidiately or within a minute. If I let it cool down it will take awhile before it starts to flicker again and finally "going mad".

por

Sure sounds like a bad PSU. I'd concentrate on that. It does sound like a cold solder connection or bad caps...

por

Agregar un comentario