Kenwood FM stereo receiver Model Eleven III. This stereo is from the 1970s.

Preguntas 6 Ver todo

Sound quits and it clicks

Great Kenwood Eleven III reciever works for a while then goes silent after a click sound is heard

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 2

Comentarios:

Thanks guys, sorry for the lag in replying to the posts. I have not been able to get to the unit so I will post my findings as soon as I get to it. I remember my dad used to spray that stuff on the components after a unit shut off to see if it would come back on, so I know what you are talking about. Also it typ takes about the same amount of time to shut off so it might very well be a heat related issue (breakdown of a component). I wish I lived closer to my dad(Knoxville), as he was a bench tech for many years. He became a preacher so gave it up after a while as he was pastoring. Now he is retired and could maybe do some more fixing. The 2 guys in Orlando retired a couple yrs ago so nobody here does vintage stuff.

por

I went to boot camp in Orlando, Chuck, in '71, and I'm a part time preacher. Tell your dad it's not the same, as today's electronics are throw-away. Resources aren't readily available to the public, so all the fun's in the older electronics.

por

I repaired stereo gear 1979-1985. The click is probably the speaker relay, which clicks off with DC to the speakers, or an overcurrent condition (shorted speaker wires). Typical cause of intermittent DC to the speakers is an intermittent transistor in the main amp. And yes, I suppose that if you play it loudly for long periods, perhaps it has a thermistor that might turn off the relay. If it can play soft all day long, it probably is temperature related.

por

Agregar un comentario

3 Respuestas

Solución Elegida

Here is my 2 cents worth on fixing Audio Amplifiers/Receivers:

Many use single sided PC boards for the analog sections.

Output transistors and connectors are mounted onto sub-assemblies (e.g. heat sinks) and the leads soldered into the PCBs. Over time, vibration and thermal expansion/contraction cause the leads to push the the solder joint and underlying PCB trace off the single sided board. The trace cracks and you get intermittent or no connections across the break.

I have had this issue with two Sony and one HK 5.1 receivers in just last the couple of months.

If you feel comfortable working around high voltages (120V DC is not unusual for high power amps)- take off the access panels and tap around the single sided boards with a NON-CONDUCTIVE probe. If you are lucky you will identify the broken joint. You can then power down, WAIT FOR THE SUPPLY CAPACITORS TO DISCHARGE (remember you can still get zapped even a long time after the power cord is disconnected!) then re-solder it.

I'm also an EE, but fixing audio is just a hobby ;-)

Fue útil esta respuesta?

Calificación 3

Comentarios:

I have a Sony STR-DE835 receiver. The right side speaker cuts out completely and the entire sound fades. I've had all the speakers checked out by an electronics guy and they are ok, but he couldn't find or fix the problem I'm having (charged me a bunch of money too!). This system has worked flawlessly for years and I would like to have this component repaired if possible. I reconnected the right side speaker to where the "rear" speakers connect and it works, but I still get the fade in and out.

I've fixed cracked solder connections and replaced transistors, etc. in the past and know how to check continuity and voltage. I work construction and have some experience with house electrical work, other than that I'm pretty limited on electronics.

Thanks, Richard

por

Agregar un comentario

It could be that it just overheated... Or the amp/preamplifier could be dying on you(happened to me). He long does it work before it goes silent?

Fue útil esta respuesta?

Calificación 2
Agregar un comentario

What other symptoms?

Power indicator on? If not, check things that affect power, like circuit breakers (things that reset, obviously not fuses).

Does it consistently take the same amount of time to shut down?

Can you affect the amount of time to shut down by removing heat (removing case, or routing an air source into the receiver)? If so, you can selectively spray a cold source (used to be trichlorotrifluoroethene - outlawed, so go to Radio Shack for current troubleshooting aid) on internal areas to see if the receiver will reactivate. If successful, start isolating to smaller and smaller areas, until offending component is found.

I'd have to look at it to provide help beyond this. Unless you have experience, your chances of success are small. A good technician is worth the money. I'm a EE, and been troubleshooting for nearly 40 years.

Fue útil esta respuesta?

Calificación 2
Agregar un comentario

Añadir tu respuesta

Chuck estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 10

Últimos 7 Días: 48

Últimos 30 Días: 253

Todo El Tiempo: 9,646