Repair guides and support for LED, LCD, HD and other Vizio TVs.

Preguntas 348 Ver todo

Backlight periodically goes out. What board should I try and replace?

I have a Vizio M502i-B1 with an LTYWRLAR serial number. Occasionally part of the the backlight will go off while the tv is on, leaving a section of the screen dark. If I turn the tv off when this happens and then immediately try turning it back on, the entire backlight stays off. There is still an image on the screen that can be seen if illuminated by a flashlight. At first this happened only rarely but it has become very frequent, often occurring when turning tv on.

Sometimes it can be fixed by unplugging the tv, holding the power button down for 20+ seconds, and plugging it back in. Lately however I have needed to leave it unplugged for 6-8 hours or even overnight.

At first I thought it might just be the LED driver, but after some research it looks like it could be the power board or the main board. The Amazon listing (which was 4 something stars when I got it) has a number of reviews citing a common failure of a fuse on the main board but this does not seem to be my problem.

Does anyone have a suggestion on how to confirm where the issue is and if it is worth trying to find the parts and repair?

Thanks!

Edit 12/13/2017

Adding Photos

I removed the back panel and check ed the connections for the LEDs. Nothing seemed lose, I wiggled and made sure all were firmly seated.

I did not notice any obviously swollen or damaged capacitors.

For kicks and giggles I disconnected the wifi card and removed/reseated the fuse. Its been a few days since I have done this and have not had any problems, though since I didn't really do anything this is likely a coincidence.

Block Image

Block Image

Block Image

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 1
Agregar un comentario
MacBook Battery Fix Kits
Fix Kits Starting at $69.99
MacBook Battery Fix Kits
Starting at $69.99

1 Respuesta

Respuesta Más Útil

Adam Cain since this turns off and on (even so infrequent etc. ) it is not a fuse situation. That would be a simple go -no go. It does sound like a bad LED array. Check all the connectors to the array and check the power board connector as well. Post some images of your boards etc. with your question. that way we can see what you see. Use this guide Adding images to an existing question for that

Fue útil esta respuesta?

Calificación 1
Agregar un comentario

Añadir tu respuesta

Adam Cain estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 7

Últimos 7 Días: 36

Últimos 30 Días: 124

Todo El Tiempo: 511