Released on September 19, 2014, this 5.5" screen iPhone is the larger version of the iPhone 6.

Preguntas 1220 Ver todo

No cellular reception, wifi just fine

Hi guys, i posted on this matter befor but im going to start an thread on my own for better visibillity.

I got an defective iPhone 6 Plus and want to try and repair it myself. The problem is that i cant get any GSM reception. Here is what works and what i tried to resolve the problem:

All wireless connections like wifi and bluetooth are working (except but cellular ofc).

Everything else also works just fine. When i take out the sim card, it immediatelly tells me "no sim". If there is a sim installed, it either searches for reception like forever or just says no service. I also can see the imei and baseband number in settings. There are no signs of waterdamage whatsoever.

Today i replaced the upper antenna (the one with the plastic housing), the dock connector and the antenna cable connecting the dock with the logic board.

None of that worked.

Im starting to get a little desperate here :(

Does anyone have another idea which part could be broken? Is it the logicboard itself? Is there any way to further run some tests to find the source of the problem?

Maybe the simcard reader itself is damaged?

I would really appreciate some help/suggestions what to do.

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 6

Comentarios:

Hi, have you tried a different SIM card? Also have you tried turning OFF Automatic network selection In Carrier settings? Phone should then search and tell if there are any networks in range. If there are networks available if you select one phone will tell you if you're allowed access.

por

Thanks for your answer. No i haven't tried a different SIM card, but the one i use is working in another iP6 just fine, so i guess thats not it right?

Im going to try the second suggestion asap. We'll see if that brings new information^^

Edit: I just tried to test, and for me there is no "Carrier" option (even with the sim installed, while its searching for reception). On the iPhone 6 the option only is available if the sim is installed.

por

Tried all the suggested "solutions" - none of that either worked or i tried doing already.

Its very strange that both tests regarding the software and the hardware were all fine - and still the problem exists. :/

Can i somehow get Tom Chai to read this post? He seems to know alot about the iPhone hardware.

por

I am having the same situation of not getting cellular data. I am not sure how many atennas there are? Can someone direct me to get the correct part? My wifi is working just fine. Thanks!

por

Good morning!

You verified that the phone is unlocked ?

por

Mostrar 5 comentarios más

Agregar un comentario

8 Respuestas

Respuesta Más Útil

Most likely motherboard issue at RF front end since it is unlikely for both cellular paths to fail at the same time.

Fue útil esta respuesta?

Calificación 3

Comentarios:

Okay, ty alot for your assessment!

por

Agregar un comentario

i had the same problem..i made following things, first i changed the antenna cable but with the end on the dock to the other side..

and then go to settings -> phone -> SIM-Pin and disable this function, then restart your Device, its works perfectly for me.

Fue útil esta respuesta?

Calificación 1

Comentarios:

Hi which antenna cable did you replace? I'm having the same problem with my phone. Thanks

por

Agregar un comentario

The antena what you plugged it's a 2g antena. All 3 antena have their own separated connection, for first try to reset phone (power button + home button, click it at one time and hold a few secs since you'll see the apple logo) if that won't help try then reset all settings and then restore the phone (if you have any problem with motherboard, then you could get a problem with a turn on a phone). Let us know how your situation will look after that

Cheers

Piter

Fue útil esta respuesta?

Calificación 0

Comentarios:

When i received the phone, first thing i did was update the OS (os 8.x->os9), which worked perfectly no problems. Also i didnt restore from Backup. Shutting down and starting the phone up again, also is no problem at all. To put it that way: If there wasnt the "no signal" message at the top, the phone would work perfectly ;)

por

Agregar un comentario

I'm having same problem but I replaced housing but everything worked so idk why this would just all of a sudden happen but I did restore iPhone and then it had that exact problem .

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

I disconnected the battery and reconnect it back, the phone got signal without fully assembled. However, I got half blue and half red screen and then Apple logo which happened every a couple of minutes.

I tried the same procedure and fully assembled the phone, it did not get the signal and showing searching....

Very strange... I saw there is a antenna coupler and tried to find replacement parts. Anyone know where to get it??

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Hy Guys,

I know it's a little bit late but I hope to can help someone the same..

In my experiences with iPhones and the "no signal" problem not always is a hardware problem.

Especially with updates it happen that the os do some mess..

In these cases (so not hardware problem), I have simply fixed the situation RESTORING iOS with iTunes.

Before restore, use iTunes for BACKUP your stuff and then proceed to restore iOS (iTunes will download from internet the ipw and then flash it again on your phone).

It's like format an hard drive of a computer and install again the os, like a new device.

I also advice to turn off iCLOUD before you proceed.

Then BEFORE put back your backup in your iPhone try the sim and check if it work!

If is fine then proceed with restore your backup..

I cross my finger for you.. ;)

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Are you aware there's a second antenna located on the back of the board? You will probably benefit best by going and either reviewing the tear down tutorial carefully, don't overlook any part of the tutorial, the answer might be there in the part you think you know. Also, the cables and ribbons are super delicate, they can break and separate inside the cable cover if you pinch, bend, or stretch any part of the ribbon cable

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

assuming the device is unlocked, Then you are looking at a board level IC failure.

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

LeStef estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 60

Últimos 7 Días: 302

Últimos 30 Días: 1,230

Todo El Tiempo: 15,054