Saltar al contenido principal

Repair guides and support for cars and trucks by Toyota Motor Corporation.

Preguntas 752 Ver todo

1994 Toyota PU speedometer not working

i changed the part on the transmission, took the dash off checked the speedometer, looks ok but speedometer still not working,

1994 Toyota pic-up

Contestado! Ver respuesta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 3

Comentarios:

Which Toyota P.U. is it? What engine size and what transmission do you have?

- de

This question was migrated from http://meta.ifixit.com/Answers.

- de

speedometer cable not working

- de

oscar figueroa, give us more information if you need help. what vehicle? What engine size, what transmission? what have you tried so far? The more information you can give us the better of an answer you can expect. A one sentence question will get you most likely no answer at all.

- de

I have same problem and i m sure the problem is the cluster speedometer. Do any one know what is the common fault or from where i could buy one

- de

Mostrar 3 comentarios más

Agregar un comentario

2 Respuestas

Solución Elegida

RUDY, the part in your transmission was hopefully the Vehicle speed sensor. From what I understand, most of the failure on the Toyota's is actually the instrument cluster itself. Do go ahead and check your connector. That way at lest you know that the sensor and the harness are okay.\:" INSPECT VEHICLE SPEED SENSOR

(a) Connect the positive (+) lead from battery to terminal 1 and

negative (–) lead to terminal 2.

(b) Connect the positive (+) lead from tester to terminal 3 and

negative (–) lead to terminal 2.

(c) Revolve shaft.

(d) Check that there is voltage change from approx. 0 V to 11 V

or more between terminal 3 and 2.

HINT: The voltage change should be 4 times per each revolution

of the speed sensor shaft.

Block Image

If operation is not as specified, replace the sensor.

If that should check out, you know it is not the sensor. then go ahead and check the connector to your instrument cluster

Block Image

or the harness, you can check the instrument cluster using the wiring diagram.

Block Image

If all those points check out okay, I definitely would repair or replace the instrument cluster. Hope this helps, good luck

Fue útil esta respuesta?

Puntuación 6

Comentarios:

I have the same issue, speedo and trip metre not working but everything else works fine. I have tried 2 second hand clusters and the fault still there. I have just tried another speed sensor in the box and from a cold start with original cluster in the speedo and trip metre worked for 2.5 km and then stopped again. Any idea’s ?

- de

Change out the resonator (blue piece behind the speedo). You'll have to bend it back and forth to break it loose. Soldier the new one in its place. Trip meter will start working. I had to do the same with mine. Speedometer is still down in mine. After testing the signal output (11v). I myself is looking at the cluster also.

- de

Agregar un comentario

Another solution to fixing a non-working speedometer in an older toyota (1992-1995) is here: https://www.toyotanation.com/threads/199...

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

Añadir tu respuesta

RUDY estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 5

Ultimos 7 días: 46

Ultimos 30 días: 230

Todo El Tiempo: 45,064