Saltar al contenido principal

Modelo A1312 / Mediados de 2011 / Procesador Core i5 de 2.7 & 3.1 GHz o Core i7 de 3.4 GHz

Preguntas 710 Ver todo

iMac mid 2011 27“ does not fully boot after logic board replacement

Hi everyone,

sooo a while ago my Mac died. I replaced the power supply unit which did not change anything. Then replaced the logic board. I get the apple symbol or windows symbol when trying to boot now (it did not turn on at all prior the logic board replacement) but then it stays white. I tried booting into recovery mode and replaced the ssd with the new one that has a working untouched macos on it.

Diagnostic LEDs are all lit.

Any ideas?

Update (05/12/24)

Soooo at least macOS el capitan does not boot from a usb. Took a while to make it. It also does not start up portable ubuntu from a usb. So weird.

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 0
Agregar un comentario

1 Respuesta

Respuesta Más Útil

You are likely hitting a firmware/macOS conflict. The replacement logic board likely had the older firmware from Sierra (HFS+) so newer loaded SSD had High Sierra or newer (APFS)

You can’t use Internet recovery to recover you need a bootable OS installer drive (USB thumb drive) with one of the newe macOS’s setup to format the drive and install a fresh OS.

Fue útil esta respuesta?

Puntuación 1

6 comentarios:

Thank you! Yes I used high sierra and there is no way to know which OS was used before. I never would have had that thought 😆 I’m pretty sure I have one somewhere because I once restored my iMac to factory setting and was stuck on lion with no way to log into the appstore to update again

- de

@qa1ysllewbt5zkq - How did you create the drive? You do need to build it from a Mac

- de

I used the original drive from before the mac broke (macos and windows 10) and a copy of a slightly older state with only macOS high sierra on it that I meant to replace it with but never did. I am currently trying to install a different version on it from my macbook that has sierra installed. But installing sierra on the drive on a sata to usb adapter somehow does not work it gets an error at the end, no idea why it just says install again

The only thing that runs on the imac is ubuntu from a usb in safe graphics mode. Not sure if that means that the gpu is broken or not.

The usb installer ones I created on my macbook that has sierra on it. Dl the dmg then used the terminal command on the apple website sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/MacOSEL/ --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app

- de

@qa1ysllewbt5zkq - Still a bit confused on what you are doing with all of these OS's. You point out Ubuntu works in Safe Mode, so that aims us to a failed AMD Radeon GPU as Safe mode is using the Intel graphics engine.

How about creating a fresh OS installer boot drive first grading the newer release of High Sierra from here How to download and install macOS as the certificate was refreshed within it. Then follow this guide Create a bootable installer for macOS as I'm not sure the method you used is correct.

- de

That is the exact guide I followed the commands for the terminal are further down. The mac would not boot El Capitan or high sierra installer usb 😅 installing el capitan from my macbook to the ssd worked but isse persists. So yeah if the ubuntu does not use the graphics card at all, that would explain it. I used cmd + v as well to see the boot process but I don’t really understand what most of it means😅

I can’t really find a fitting gpu right now that is not ebay and a bit fishy.

I‘ll try to add the pictures I got from the cmd+v startup to my initial question.

- de

Mostrar 1 comentario más

Agregar un comentario

Añadir tu respuesta

Myah estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 1

Ultimos 30 días: 2

Todo El Tiempo: 45