Installed new logic board powers up only a few seconds.

Here is an interesting one. I installed a working logic board into a new backplate assembly. I went by the book on the soldering using Kapton tape to cover any nearby circuitry - de-soldered the battery, de-soldered the flex cable, dropped in the logic board and soldered back everything into place (with a new flex cable). Also, I added a new screen & digitizer.

At first I would just the battery charge icon. Now when I power up the iPod I see the Apple Logo for about 6 seconds then it powers back off. I tried this with the AC connected and just with the battery, same issue. I also tried doing a reset using the home/power buttons.

I double checked, my solder work, then I popped in a different (used battery) with the same results. I also tested with a different screen.

I did notice with the battery disconnected, running only on AC, it runs quite cool, as with just on battery power, however, when the battery is soldered on and you plug it in with the AC cable, the board seems to heat up quite a bit. Note, I also added some artic fox to the top of the copper plate that the battery rests on.

I'm wondering if after removing a used battery it has to be discharged completely some way?

Any suggestions?

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 0


Anyone have any ideas?

- de

Agregar un comentario