Saltar al contenido principal

Repair information for Whirlpool dishwashers.

Preguntas 76 Ver todo

WDT750SAHZ0 Circulation pump isn’t running correctly

Have a WDT750SAHZ dishwasher. I’m getting a 4-3 diagnostic code. Initially the circulation pump would stop working, then it would start working again. Now the circulation pump turns on for 2 seconds and then back off (after the sump fills with water. I’ve replaced the board, it didn’t help. I put the old board back in, and replaced the pump. That didn’t help either. I took both ends of the cable off and measured resistance, it was an open circuit. I jumpered one end of the harness out and measured resistance on the other end and got less than one amp. I measured the fuses in the board the were ok. I don’t know what else to look at. Board, wires and pump, that’s everything, right?

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 0
Agregar un comentario

1 Respuesta

Respuesta Más Útil

Hi @msshel0

Bit confused by your terminology and what you measured.

"I took both ends of the cable off and measured resistance, it was an open circuit. I jumpered one end of the harness out and measured resistance on the other end and got less than one amp."

Did you mean less than 1 Ohm? Amps are a unit of current flow, not resistance.

What cable were you measuring? Was it the cable that went from the control board to the motor i.e. you were measuring the motor connection from the control board?

If you were then you should have measured 5 to 15 Ohms for the motor windings.

If you shorted out the two wires at the motor end then you would measure 0.00 Ohms at the control board end of the cable (or vise versa). Did you try flexing the harness cable at various places (door?) when you measured the short circuit to see if it went open circuit? It may be a fractured wire and vibrations/movement may make for intermittent contact.

According to this supplier the tech sheet for the dishwasher is W1094612, which is actually the assembly and the tech sheet is W1094613B (see info at top left of opening page of the tech sheet).

Here's an image taken from the tech sheet showing the motor circuit and also the door switch circuit as it provides the circuit for the L1 relay on the control board which is in the operate path for the wash motor (circulation pump).

Block Image

(click on image to enlarge)

If you disconnect the power from the dishwasher and then disconnect the wire harness from the control board and then measure between the harness wires that connect to control board connector pins P5-1 and P5-2 i.e. the wires going to the motor winding you should measure between 5 and 15 Ohms.

If it measures open circuit, since you have replaced the motor one of the wires is open circuit. Since it is intermittent it may be a fractured wire or a faulty wire crimp in the harness plug (at either end - control board or motor).

I don't know the model but I'm assuming that the harness has a plug at either end that plugs into the board and the motor. If this is the case try tugging very gently on the wire where it enters the plug and see if it can be pulled out of the plug. If it is crimped properly it won't come out. Do this for both wires at both ends of the harness.

If the motor consistently tests OK from the control board P5 harness cable plug (try bending the harness cable and see if the resistance value changes with movement), then it may be that the L1 relay is operating/releasing due to a faulty door switch contact.

Fue útil esta respuesta?

Puntuación 1
Agregar un comentario

Añadir tu respuesta

Matt shelton estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 0

Ultimos 30 días: 3

Todo El Tiempo: 32