Signal drop and keeps losing service "No Service"

I'm facing this signal problem similar to other users. It turns to "searching..." for reception and becomes "No Service" quite often under normal usage. It does re-gain full bar signal when the 3G mode is switched on, and then subsequently repeat the routine. If the 3G mode is switched off, when signal drops to "Searching..." and "No Service" status, the signal will not come back again at all, which means I have to switch the 3G back on in order to get the reception! I have asked other users on apple.com and I first thought there must something to do with the firmware version. It appears no improvement at all even after I updated the firmware version to 4.3.5 (since 4.3.4 was speculated having the key contribute to the signal problems). I'm confused whether it is firmware related problem or hardware faulty? HELP, PLS!

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 5

Comentarios:

if you have any warranty left I'd contact apple.

por

hello

i had the same problem. my phone is the 6 plus and i just need to push on the upper corner while it restart to have the reception back. I heard this is because the plus is slightly bending.

try this . it works for me even though i need to do this once in a while

por

Agregar un comentario

9 Respuestas

Respuesta Más Útil

FW was definitely not the issue. Have you ever taken the phone apart? Regardless I'm thinking that your lower antenna connector has come loose or is not fully seated. I would suggest completing STEPS 1-11 of the Logic Board Install.

iPhone 4 Logic Board Replacement

You can skip steps 6-10 and step 11 will show you the connector I'm talking about.

Fue útil esta respuesta?

Calificación 4

Comentarios:

tnQ so much... very very helpfull and fixed my problem.....

por

Agregar un comentario

you can replace it with a new blue iphone coil that will fix the problem

you can buy a new blue coil here for the repair

Block Image

Fue útil esta respuesta?

Calificación 2
Agregar un comentario

I fixed my problem by following this guide here http://www.unlockboot.com/2015/10/fix-si...

Fue útil esta respuesta?

Calificación 2
Agregar un comentario

I checked everything, but after changing the backplate to a transparent one, i have very low signal or nothing. I put back the original and still no improvements.

Thanks

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

http://www.myibroke.com/blue-inductor-mo... is a swervice that we offer to fix this problem. its an easy fix for us

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

I have the simplest solution here http://applenewsro.blogspot.ro/

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

I honestly can't find a way to fix my Unlocked iphone 4 (gsm) tmobile

From dropping signal I can't ever find a fix been looking for DAYS PLEASE HELP

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Try taking the SIM card out and putting it back in. Had a similar issue on an iPhone 5 and that fixed it right away.

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Let me help you. If you you some data plan from your carrier which assigns different n/w capability for different data type (2G/GPRS, 3G, LTE). So, once your 3G data pack is over, the network goes to 2G mode which the iPhone is not able to connect to. So Head to Settings>Mobile Data>Voice & Data>Change according to your situation

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

Kefu Pan estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 3

Últimos 7 Días: 29

Últimos 30 Días: 140

Todo El Tiempo: 59,551