Saltar al contenido principal

Lanzada el 3 de marzo de 2017, la Nintendo Switch es una consola de mano que se puede ver en la televisión o usarla tal cual.

Preguntas 441 Ver todo

Switch stuck at boot, but charges fine.

Hello everyone,

Essentially my switch is stuck at boot on the switch logo. This happened after it froze on a blank screen for the first time (white with a slight orangy tint) while waking it up from sleep while docked using the Joy-Cons.

I’ve never used any third-party dock or charger, no water, no falls.

Could this be a hardware issue?

Initially I thought so because of the similarity to the dock issues, but after running some tests (see below) I thought it might be software related. Fixing the software didn’t help either though, so I’m still not sure what the issue is.

Symptoms:

  • Switch is stuck on boot at switch logo.
  • Joy-Cons sync up immediately when powered on.
  • Charging via official charger works.
  • While docked the green light quickly flashes and then stays dark. No HDMI output, built-in screen remains on.
  • Screen, Joy-Cons, Touchscreen, Sound, USB-C port, SD-card reader, etc. all works.

What I've tried:

(Basic)
  • Hard reset via power button
  • Completely discharging and recharging it
  • Entering recovery mode -> not possible, since it gets stuck on switch logo before
  • Entering safe mode -> this is actually possible but it doesn't seem to do anything (the square rotates but the progress bar stays empty for hours)
(Hardware)
  • Opening it up and checking for shorts on some of the capacitors (especially charging ICs) -> nothing
(Software)

Note that I only starting messing with the software after it bricked to diagnose and fix the issue.

  • RCM mode, payloads, and custom bootloader work fine.
  • Full NAND backup/restore works.
  • CFWs do not boot! They are stuck at the same place as the OFW.
  • Linux with Retroarch boots and works flawlessly as far as I could tell from a quick test.

At this point I'm thinking the hardware is fine, and it's just the OS that messed itself up somehow and since the CFWs are more like patches than independent firmwares, it makes sense that they would be affected as well. So

  • I flashed two different official firmware versions (6.1 and 5.1) using ChoiDuJour (PC) thinking that would fix it, but neither of them were able to get past the switch logo either.

Sorry for the long post and thanks for reading this far!

Edit: formatting & picture, as per suggestion

Block Image

Contestado! Ver respuesta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 6

Comentarios:

This is 10/10 perfectly formatted question. Good job!

- de

I got the same problem but mine will load just Nintendo screen then goes black i can boot to rcm an run android not any ofw cfw

- de

Agregar un comentario

6 Respuestas

Solución Elegida

I actually have an update on this, and I’m fairly convinced the wifi chip (BCM4356XKUBG) is at fault.

I realized that I couldn’t detect any wifi networks or that straight up no wifi-capable device was recognized in Ubuntu/Lakka/LineageOS. Other users confirmed that the wifi chip could be responsible for preventing the Switch from booting. I think that maybe the solder connections are actually the problem, and not necessarily the chip itself, as many users have reported the problem to be intermittent. So a reflow, reball, or worst-case a replacement, of the chip should fix the issue.

I haven’t actually attempted a fix myself, as after leaving it on the shelf for 2 months or so it now magically started working again! And indeed Linux is now able to detect wifi networks. I’m guessing the SwitchOS attempts to communicate with the chip during bootup, and if that fails gets stuck somehow, while Linux doesn’t do this.

PS: For anyone interested, i actually found a stencil to reball this chip (Wylie WL-50, https://www.aliexpress.com/item/40002277...).

Fue útil esta respuesta?

Puntuación 2

Comentarios:

I wanna ask a cellphone repair shop to do a reball on the wifi chip. Any idea on what they should charge for the service?

- de

Hmm I'm not sure about the pricing, but reballing is quite a tedious process and it's probably cheaper to just ask them to replace the chip, which come pre-balled from the factory and can be had for a couple of dollars.

- de

Thank you for great thread and answers!

- de

Glad this has helped you! Note that new wifi chips apparently do not function with the switch, but salvaged ones do (if a replacement is required).

- de

Good to know.

- de

Mostrar 1 comentario más

Agregar un comentario

I, have the exact same problem, and pass throw the exact same test, Android won't detect any wifi device, after a wifi ic reflow, Android detects wifi and Nintendo switch boot normally!! Also as an extra I add a thermal pad from a dead PS3 to the wifi ic, for extra heat dissipation and pressure

Fue útil esta respuesta?

Puntuación 2
Agregar un comentario

I forgot to tell you:

I reballed and installed the WiFi chip from a donor-board and the switch has worked normally ever since.

Fue útil esta respuesta?

Puntuación 2
Agregar un comentario

Hey David i got the Same Error.

i found a way to get the Switch Back Running by letting the Battery dry and waiting for 1-2 days. Sometimes after that i can use her again but the error comes back after a restart or eventully in the Sleepmode.

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

I have the same problem. I only have to wait about 24 hours, then it will load past the Switch logo and I can play games. I don’t have to let the battery die. I assume the switch must stop trying to use WiFi after something close to the 24-hour mark, but I would get the error and it would freeze up again if I put it to sleep or rebooted it. I finally just put mine in airplane mode and now I don’t have a problem at all (other than I can’t use WiFi). I still get error messages when I boot it up telling me there is a problem (mostly saying the WiFi is off), but I can just skip past them and play a game like normal.

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

Reballed the wifi-chip. Still doesnt work.

Fue útil esta respuesta?

Puntuación 0

Comentarios:

Has anyone tried using LAN cable to solve this issue? Or does LAN use the same chip?

- de

my friend has this broblem with his old switch, if he tries to boot it up even with a lan connection it still doesnt boot up, seams like the switch checks for every component, and if the wifi chip isnt there or not working, it fails to boot up

- de

Agregar un comentario

Añadir tu respuesta

David estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 22

Ultimos 7 días: 172

Ultimos 30 días: 751

Todo El Tiempo: 22,291