Saltar al contenido principal

Engine won't start after camshaft replacement

I had a mower that had a compression release spring problem on the camshaft detailed in the following fixit question:

Craftsman tractor engine compression or timing issue

I had the mower running for a whole season but it got worse so I decided to strip it down and indeed the compression release spring was in pieces inside the engine case. I installed a new camshaft (changed out the oil gov and all seals rebuilt the engine and it started up first time with no compression or turnover issues at all. See Below:

https://youtu.be/DKcggQdvAwc

I then left it for about a month, went back and it started again first time. I let it run for a while and all was good. Then the next time I came to start it I forgot to turn the fuel cut off valve on and so it ran out of gas and stalled after a minute. I turned the valve on, and got it started but then it began to run rough and now won't start at all. I thought it was still fuel starvation but checked the carb and was letting fuel through fine. Checked the spark plug and it works fine - did smell heavily of gas when i removed it. See vids below - any thoughts? Has the timing gone?

https://youtu.be/q_WvfPjqkm4

https://youtu.be/gSHX2qpLcBk

I stripped down the carb, all looks good. Spark plug working good and valve spacing is all good. Here is another video of it trying to start and the good spark plug.

https://youtu.be/8hKMRK0e0QU

Update:

I stripped down the cylinder head - lots of carbon build up. Cleaned that out and piston head, replaced head gasket, checked valve spacing, stripped carb again, checked bulb solenoid, replaced spark plug and checked it is firing from the coil when out of engine, replaced with fresh gas and.....still no luck:

https://youtu.be/ZHnuWQz8IhY

I’m lost for ideas unless something has failed inside the case somehow, but can’t think what....

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 0

Comentarios:

So I took of the carb and tried to at least get the engine to fire by squirting some starter fluid into the intake - still just spins and kicks the fluid back out of the intake. Any ideas?

por

Agregar un comentario

Kits de Reparación de Batería de MacBook Air

A partir de $69.99

Buy Now

Kits de Reparación de Batería de MacBook Air

A partir de $69.99

Buy Now

2 Respuestas

Have you checked the valve seats when you replaced the head gasket? Also did you reset the spacing of the coil arms using an index card? The timing is usually controlled either by a key on the flywheel or electronic points underr the flywheel. Usually loss of compression could be cause either by blow by on the piston or leaking valve or seat ..

Fue útil esta respuesta?

Calificación 0

Comentarios:

Thanks for your comments! The valve seats were fine, and the engine ran good for a total of about 30 mind over 3 attempts spaced by a month. I never reset the coil position, do you think it could have moved without any interaction with it? Thanks again.

por

It is possible. If the system has a points & condenser, the spark gap could be compromised, the points could also have a problem with the timing cam follower. The armature coils could also be grounding out, look for a disconnected wire. Some coils have this as a safety feature especially if the coil has a middle arm.

por

Try this:

Remove the spark plug & plug it in to the spark plug wire,

Place the spark plug base against the head fins to ground out the plug

Turn over the engine using the electric start & watch plug

If there is a spark, no timing issue or coil problem, maybe a vacuum, carb, compression.

No spark:

remove the armature coil & clean the arms if necessary.

Resetting the coil using an index card:

Turn the flywheel finding the magnets side toward the coil

Place an index card between the coil & magnet

Loosen the armature coil & allowing it to “touch” the magnets

Tighten in place

Turn the flywheel to remove the index card.

Recheck spark plug gap & try above again.

If no spark, then there is a problem with the points & condenser if there is one or the coil maybe bad.

por

Luther thanks for your comments, but as per the last video the spark plug is fine when tested out of the engine. If you know these engines they have a very simple coil and there are no broken wires. I would be surprised if it is a compression issue after replacing the camshaft and it starting and running fine for 3 or for times. Any ideas of how to fault check for that?

por

You said it smelled heavily of gas, and you mentioned it ran till it literally ran out. Have you drained and refilled your engine oil and changed the filter? Also maybe try a hotter plug.

por

Mostrar 3 comentarios más

Agregar un comentario

Without long explanation, try injecting a little like 2 mls motor oil through plug hole spin by hand place plug and see if start. Sometimes oil comes off rings via overfueling, lean burn etc.

Fue útil esta respuesta?

Calificación 0

Comentarios:

Tried it Will, no joy.

por

Agregar un comentario

Añadir tu respuesta

Ryan sandberg estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 0

Últimos 7 Días: 6

Últimos 30 Días: 33

Todo El Tiempo: 528