Saltar al contenido principal

The SwagTron T3, released in 2016, is a self-balancing hoverboard that features LED motion indicator lights, bluetooth speakers, a built-in carrying strap, and a 5-level battery indicator.

Preguntas 12 Ver todo

Won't power on and charger light goes out when plugged in

This is a T6 Swagtron hover board.

It just stopped working while in use. I thought it was a loose wire, since it happened after someone hit something and fell off.

The battery was fully charged before it happened. Now, it won't power on at all. When it is plugged into the charger, the green light on the charger goes off. If I plug in the charger without plugging in the board, the green light on the charger is on. Then when I plug it into the board, I hear a pop sound and the charger light goes off. I'm thinking it is some type of short. Do you think it needs a new circuit board? Is there a way to test?

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 2
5 comentarios

Jeff Johnson, did you ever find out what was wrong?

- de

I also have this same problem ..help

- de

Same here faint poping noise when pluging in to plugged in charger, the thing was brand new less then a mile when it stopped working

- de

@karlmatson does the light on the charger aswell on yours

- de

Yes the light goes out on the charger when I plug the charger cord into the hoverboard

- de

Agregar un comentario

1 Respuesta

Respuesta Más Útil

charger light going out would indicate a shorted component on the circuit board

Fue útil esta respuesta?

Puntuación 1

2 comentarios:

Yeah was thinking this I have it all opened up what should I be looking for on the circuit board, i.e. any sorta indicators

- de

@karlmatson can you post photos of the board

- de

Agregar un comentario

Añadir tu respuesta

Jeff Johnson estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 2

Ultimos 30 días: 8

Todo El Tiempo: 745