2.0GHz, 2.3GHz, or 2.6GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.8GHz) with 6MB shared L3 cache.

Preguntas 311 Ver todo

Fan running high, kernel task taking up 500% cpu - nothing running?

So I recently replaced the battery - and the camera cable connector disconnected from the logic board. Everything else is connected fine. When I powered back up - Kernel Task was up to 500% and fans spinning at 6200rpm.

There was no issue whatsoever before the replacement - and this is the only thing that went wrong during the battery replacement.

I have tried resetting the SMC and the PRAM - still the same thing.

Any thoughts?

Edit: Ran ASD - came back with the camera issue (Which is known)

Also came back with SMC issue (PFM006)

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 1

Comentarios:

Downloaded TG Pro - no unnecessary temperature readings

Downloaded Macs Fan Control - no unnecessary temperature readings - also, I am able to switch the control of the fans from "Auto" to "based on airport card" - and then I can change the Temperature when the fan will start to increase.

Obviously this won't fix the Kernel_Task issue.

Kernel_Task still using 475%

por

Agregar un comentario

¡Envío gratuito para todos los pedidos de más de USD100 o que contengan un Pro Tech Toolkit!

Visita Nuestra Tienda

3 Respuestas

Respuesta Más Útil

You are not going to believe this, but I have had the same exact problem. I replaced the battery and trackpad and it still existed. I then disconnected the camera and bam problem solved. It now runs flawlessly. As a technician, I wish I could give an exclamation for it… But some things just never make any logical sense. Hope this helps.

Fue útil esta respuesta?

Calificación 1
Agregar un comentario

I know it's a bit late but I had a similar problem and this solved my problem (source: https://www.davidschlachter.com/misc/ker...). My kernel task CPU was 300+% all the time and the fan would start whirring seconds after I turn the computer on, and continue the entire time it was on. Everything functioned, but loaded at a snails pace and the computer was essentially almost unusable for anything practical. I hadn't downloaded anything recently or replaced any parts or done anything to trigger any changes at all so I was confused. The article I linked above saved me though, so check it out, maybe it'll help you too.

I'm super bad with computers and honestly don't even know what a hard drive or CPU is, so deciphering that article took a lot of time. So I made a dumbed down version below for anyone like me experiencing the same problem. If you get computers, just read the source article linked above.

Basically what I did is (I have a Yosemite Macbook air, but if you have El Capitan or later version, you need to disable SIP before doing the below steps):

Shut down computer.

Hold down Command-S immediately after pressing the power button when turning the computer back on. Keep holding until a bunch of white text on black background appears.

When the white text finishes scrolling enter:

fsck -y; mount -uw /

then hit return (always hit return after every line of input you make; also make sure everything you input is EXACTLY what's here, including the spaces and stuff)

Second line, enter:

rsync -av /System/Library/Extensions/IOPlatformPluginFamily.kext /Users/Shared/

(That's all one line, no "returns" inside it, only spaces...after inputting this line, a whole bunch of text scrolls past so wait a bit)

Third line, enter:

rm -rf /System/Library/Extensions/IOPlatformPluginFamily.kext;

(That again was one line with no "returns", only spaces to separate the sections of the line)

Last line, enter:

shutdown -r now

After that shutdown line, the computer starts up again and the fan keeps on whirring loudly. But if you go to Activity Monitor (find it using Spotlight) and look at the CPU%, kernel_task should be way down. For me, it was down to 1% within 5 minutes (it was 300%+ before) and the computer works a lot better (fast).

Basically the fan should still be loud but your computer should be much faster.

As noted by the original author of this solution, I don't know if this harms the computer but nothing has happened yet to mine and it's been an hour. The original author even updated his post a few days after he originally did all the above and noted that the fan stopped whirring loudly. He then restored the kext that the above process served to delete and the computer stayed normal (to restore the kext, use rsync -av /Users/Shared/IOPlatformPluginFamily.kext /System/Library/Extensions/ in the same white text black background place). Basically the computer was completely back to normal!

Hopefully this helps somebody out. For me right now, the fan's loud and annoying still but things load fast (I could barely type before) so I'm happy. I'll update if my computer explodes or something.

Fue útil esta respuesta?

Calificación 0

Comentarios:

^ DO NOT DO THIS - you are basically removing the ability for the OS to monitor temps and can cause hardware failures. I know tons of people have said this works, but it is literally working because you are turning off the function of the OS to protect the hardware. I don't have a better answer, but do not do this.

por

Agregar un comentario

Hopefully you have this fixed by now. I ran into almost the exact same problem. I replaced my display which requires disconnecting the camera cable. One of the other responders mentioned that he disconnected the camera cable and the problem went away. I tried the solution and found that by disconnecting the cable my problem also went away. On further examination I realized that I had put the cable in upside down, 180 degrees from what it should have been. I flipped the cable over, plugged it back in and I’m back in business, camera and all. I feel fortunate that I didn’t do damage by incorrectly plugging the cable in.

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

Ryan Brown estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 6

Últimos 7 Días: 55

Últimos 30 Días: 269

Todo El Tiempo: 4,329