Saltar al contenido principal

El Nissan Altima es un automóvil de tamaño mediano fabricado por Nissan, y podría decirse que es una continuación de la línea Nissan Bluebird, que comenzó en 1957.

Preguntas 142 Ver todo

it cranks won't fire or not getting any fuel

2003 nissan atimal it cranks won't fire or not getting any fuel don't hear fuel pump when come on.

Contestado! Ver respuesta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 8

Comentarios:

I also have this problem with my 2006 Nissan Altima. Did you find a solution?

- de

Hi Guys

i have a 2004 Nissan Almera

the vehicle was involved in accident (Front Smash) and Air Bags deployed.

I drove the car home from the accident scene. After returning from the Panel Beater the car refuses to start. It Cranks but wont start as the injectors wont open.

i checked everything, Relays, Wires, Changed the Fuel Pump, Computer Box, Did Key Coding, Changed Spark Plugs, Checked the Harness etc. EVERYTHING.

I Dont know what else to, any advise?

- de

my 2005 Nissan crank wont start changed fuel pump, crank , cam and mass air flow sensor, spark plugs , and coil packs . But still cranks act like it wants to but wont start . Any body hve any suggestions besides trashing it

- de

Scan it for codes

- de

Yep, I also have a similar issue. 06 2.5s Altima. Had missfire issues from blown head gasket. I replaced that myself as the dealer wanted $2000(14 hours) for the job that took me.... maybe 8 hours of total worktime to complete. Prior to replacing the head gasket we replaced the injectors, coil packs, spark plugs, o2 sensors, cam sensor. After replacing the gasket I tested compression and had no issues there. Didnt want to start at all. However it started after unpluging the cam sensor and ran perfect unless you gunned it (I thought maybe the vvt solenoid wasnt getting oil pressure). Sure enough, we were missing the O ring that goes there. Now we have no spark. And its also not starting with cam sensor unplugged. Ive checked the timing and had my father double check all work (20+ year mechanic) He confirmed that I was on the money. Coil packs have power and ground but not seeing anything from ecu triggering the coils. Ecu does connect and communicate perfect. If I anyone has any ideas let me know.

- de

Mostrar 7 comentarios más

Agregar un comentario

15 Respuestas

Solución Elegida

mitchell1 you are not telling us what you have checked regarding the fuel situation. Now here is how it all works according to the SM:"

The ECM activates the fuel pump for several seconds after the ignition switch is turned on to improve engine startability. If the ECM receives a engine speed signal from the crankshaft position sensor (POS) and camshaft position sensor (PHASE), it knows that the engine is rotating, and causes the pump to operate. If the engine speed signal is not received when the ignition switch is ON, the engine stalls. The ECM stops pump operation and prevents battery discharging, thereby improving safety. The ECM does not directly drive the fuel pump. It controls the ON/OFF fuel pump relay, which in turn controls the fuel pump." So what the means is that you need to check your pump, the relay after that the POS and the camshaft position sensor as well as all the wiring in between. Then if still no error found you need to check the ECM.

Without sending you on a wild goose chase I recommend that you check the fuel pump fuse (see image for loaction)

Block Image

Next is the fuel pump relay

TEST ITEM

FUEL PUMP RELAY

CONDITION

Ignition switch: ON (Engine stopped)

Turn the fuel pump relay “ON” and “OFF” using CONSULT-II and listen to operating sound

JUDGEMENT

Fuel pump relay makes the operating sound.

CHECK ITEM (REMEDY

Harness and connectors

Fuel pump relay

The relay is built into IPDM E/R

Block Image

Fue útil esta respuesta?

Puntuación 5

Comentarios:

Checked fuse it's good changed relay nothing changed pump nothing was getting code 0702 and 1574 but car was still running. When I shut it off and then back in again the 1574 problem would go away do u think those codes have anything to do with no fuel cause it starts if I spray starting fluid

- de

@edwad same car? Same problem? Same engine? Give us a bit more information.

- de

Oldturkey,

I have the same problem with a 2006 Nissan Altima 2.5 S except that it is intermittent. Sometimes it starts sometimes it doesn't. I am leaning toward replacing the Crank & CAM sensors after reading what you wrote.

- de

I'd say crank angle sensor.

- de

I have a similar issue on a 2004 nissan sentra 1.8L car will crank but wont start, throw a little starting fluid at it and it starts sometimes but not always. Pulled fuel line of at fire wall and fuel pours out but seems weak. I've tried 2 fuel pumps, fuel pump relay, plugs, coils, crank and camshaft sensors all out of another running sentra and even an ecm, and still nothing?

- de

Mostrar 3 comentarios más

Agregar un comentario

There are so many people helping with their experiences and throwing parts at their cars, lets start with a real world back yard mechanic diagnosis without a scan tool and no experience. Can you run power, 12 volts to the connector back at the fuel pump (correct wire of course) and see if it will work and start the car. We will work our way back to the fuel pump relay as the computer controls the input to the relay as the computer also needs to see certain items working prior to letting the car start, you say if you spray in some form of fuel, the engine will start, this does point to a fuel related problem. Do you have a volt meter to check for power and grounds at the fuel pump connector while trying to start the car?

Fue útil esta respuesta?

Puntuación 4

Comentarios:

Hey my altima when i purchased it was doin same thing . the fuel injector fuse under the dash was blown .started right up after replacing fuse ..the car was at a shop for over a year they could not start it..they said fuel pump bad lol i started 2nd day after i got it home

- de

Agregar un comentario

OK easiest answer is if you don't hear the fuel pump prime. Then suspect bad fuse or pump. Check fuse box either in car or under bonnet (hood). If fuse is good, chance are your pump is bad.

It can only be one of 3 things, fuel, air or spark!

Air isn't the issue, spark probably isn't the issue. If it is a fuel injected car, turn key on as you would to prime it, then turn off. crack the nut on the fuel hose to the fuel rail, start undoing it, if no fuel comes out. Bad pump, if fuel dribbles out but not under pressure as it should be, bad pump. Change out pump. If fuel comes out under pressure, tighten nut. Turn ignition on, as you would to prime pump, then off again.

Wait ten to 15 minutes. Then crack that nut again, should still be pressurised, if not bad pump.

If pressurised, then your pump is prob on the way out or just silent. Check fuel filter, could be clogged, change it out and try to start, if starts. I'd order a new pump anyway. If doesn't start, bad pump.

Fue útil esta respuesta?

Puntuación 3

Comentarios:

Ware is full filter located 2000qwest mini van gxe

- de

Put new fuel pump in still no spark

- de

Agregar un comentario

Im not sure if it is the same on the 2002 but on a 1999 there is also a ignition relay that is behind the sterio mounted to floorboard if you lay in pass side and look behind radio you can see it but is pretty hard to get to . Ground a test light and with key in on position probe the 4 pin connectors and one should make the fuel pump run if so change this relay and you should be fine . Ps… this relay controlls fire to the distributor as well as fuel pump so if it has no spark or fuel it would be my first guess.hope this helps

Fue útil esta respuesta?

Puntuación 2

Comentarios:

Wow, I've looked at online Manual's, diagrams,etc and didn't find anything about a relay behind the stereo. That could be the problem on my 04.

- de

Ben rodeheaver, I have a 03 altima, just wondering if your 04 had a relay there or not .might be what's causing me trouble if it has one there

- de

Agregar un comentario

Alright , Ive seen this over and over and over and everyone always throws parts at the problem without knocking wtf is going on really, turn the key to the on position , is the theft light flashing? BINGO!!! IT WILL NOT GET FUEL IN THEFT MODE , WHICH IS WHY YOH GET THE CRANK BUT NO START!!! unfortunately your car either forgot the key , or the key itself took some damage either way just have it relearn the key , put it in the on position , and leave it for 15 mins or so or get a new key and have it programmed , YW

Fue útil esta respuesta?

Puntuación 2

Comentarios:

You're the man. That solved it!

- de

What code would that pull up. I'm just curiouse, and how do you get your car to learn the key again?

- de

Thanks D, I knew it was somewhere in that area because I seen the anti-thief light flashing… you are the man..????

- de

Agregar un comentario

So, my 06 Altima stalled while I was going 50mph & wouldn't restart. Battery, fuel system, alternator & starter all worked fine & no issues with fuses or wiring. Cam & crank sensors in good condition as well… I was ready to just scrap the dang car but decided to do a Google search & voila!! It was the friggin ignition relay switch….less than $10 fix!!

Fue útil esta respuesta?

Puntuación 1

Comentarios:

How did you find the ignition relay?? As stupid as it sounds I have called parts store even the Nissan dealership and I cannot find one. Everyone says they don't have it. My car's doing the same thing I've replaced everything. And an at my Witt's end..

- de

Its in the fuse box under the hood on passenger side front

- de

Agregar un comentario

First, check the battery power for its full potential power. Test, battery. If results from test say battery is:Good, then crank the engine and hold down the gas pedal. If car still does not start, visually inspect the fuses. Focus on the fuel pump areas.

Fue útil esta respuesta?

Puntuación 0

Comentarios:

I'm having issues with my maxima not starting. It cranks and starts after getting a bit and I think holding down or pumping gas pedal helps it start. I noticed you mentioned to hold down gas pedal so I was wondering if you might know where the problem may be coming from if pressing down the pedal helps to start engine?

- de

when i hold down the gas pedal and start the car it takes more pressor and tries to start and after some time it starts then there is no problem came in the car in whole day.

- de

I had my problem with my car Nissan sunny blue bird sylphy no sparks going through spark plugs what's the problem

- de

How did you fix it i have same car and problem

- de

Agregar un comentario

Change the crank sensor

Fue útil esta respuesta?

Puntuación 0

Comentarios:

Crank sensor change it

- de

I changed it nothing

- de

Also cam sensors fuel pump all the ignition coils and plugs

- de

Agregar un comentario

Thank you for your help. I had to replace the fuel pump.

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

I believe it's the fuel pressure regulator, not the pump or relay or fuse…

Fue útil esta respuesta?

Puntuación 0

Comentarios:

I have 1994 Nissan Altima and placed all new parts including new fuel pump and fuel filter and spark plugs and altinatar and it want start HELP.!

- de

Agregar un comentario

Thank you i will let my friend know when he comes back to work on it

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

I'm getting spark and no fuel. Pump and filter are good and I don't have a key light on the dash

Fue útil esta respuesta?

Puntuación 0

Comentarios:

And pressure is good at the fuel rails

- de

Agregar un comentario

I have a 2003 nissan slAtima 3.5 v6 it would loose powerr even after I drive it for couple days it would start with a jump. I cleaned the mass fuel sensor and try to start it but it wouldn't start. It wanted to but didn't.my friend put a of try reader on it it ame back the 02 sensor. Can someone help me out on what I can do.im a women that don't know much. Thank you

Fue útil esta respuesta?

Puntuación 0

Comentarios:

I'm not intimately familiar with this vehicle. Did it say which sensor? Take it to an auto parts store. They'll read the codes for free and help you get the right part. Anyone in the USA who works on their own vehicle... I highly recommend a Chilton or Haynes manual. It'll help you locate parts and replace them.

- de

Agregar un comentario

I have a 2002 Altima it will crank but wouldn’t start my husband took of the serpentine belt and it started and ran put the belt back on and back to crank but won’t start I’m puzzled by this. What is going on here?

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

with the belt off, verify that the components it turns will actually turn. If one is starting to size this could cause the engine to crank at slower speeds which may not let it start. Ac, water pump, tensioner… check them all..

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

Añadir tu respuesta

mitchell1 estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 22

Ultimos 7 días: 118

Ultimos 30 días: 581

Todo El Tiempo: 99,078