Saltar al contenido principal

Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

Preguntas 555 Ver todo

MacBook Pro 17" 2009 doesn't power on even after keyboard replacement

I've just decided to replace my keyboard since some keys don't work anymore. For this, I had to disassemble it. I've spent a long time trying to connect the keyboard flat ribbon and after finished, I'd power it on and it powered on normally. I turn it off in order to replace the back cover. When I've tried to turn it on, it didn't work anymore. No lights, no fans but the battery was still charging. I've decided to use the power pads to power it on and it works. I've then imagined being the new keyboard and I reconnected the old one. Surprisingly, it still didn't work. What could have been happened? Could somebody help me?

Cheers

=== ===

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 0

Comentarios:

@gersoncruz did you ever get this fixed?

- Por

Not yet, but I discovered that the problem is on the mainboard. It works properly when the battery is connected but when I tried to use it only powered by the magsafe, it doesn't works. I don't know what could be happen, maybe some SMC issue.

- Por

Agregar un comentario

3 Respuestas

Solución Elegida

If you are saying the problem is that it won’t boot without the battery, this is very common with the 17” machines. It seems the 17” needs more power to boot than the mag-safe will supply. Now if the machine is warm, it will sometimes boot.

Fue útil esta respuesta?

Puntuación 2
Agregar un comentario

If it works with the battery connected, as you say, but not without the battery connected, then leave the battery connected. I have seen the same issue. But since we want the battery connected anyways, just run it as such.

Fue útil esta respuesta?

Puntuación 1
Agregar un comentario

I don’t agree with statement that 17’’ MacBook Pro won’t boot without battery. I have two 17” and one of them is old Santa Rosa model and I’m using it in my summer house without battery for almost 2 years without any problem, so the booting problem lies somewhere else. My guess is not tight connection with mother board and when you place the battery the connection with motherboard is established. Check the flat connection cable, maybe is damage and replace it.

Fue útil esta respuesta?

Puntuación 1
Agregar un comentario

Añadir tu respuesta

Gerson Bernardo estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 0

Ultimos 30 días: 3

Todo El Tiempo: 105