Released April 2015, also known by model name A10-70F ( 'F' representing that this is a wifi only model)

Preguntas 32 Ver todo

Reboot loop when charger plugged in

Hello!

Since a few months the tablet keeps on rebooting when a charger is connected, it always only reaches the first static splashscreen and then cycles anew.

I tried already replacing the battery with a new one but so far that didn't seem to have fixed the problem.

Since I replaced the battery I can access the desktop of the device, i.e. I can boot it all the way up normally although it will then give the critical battery level error and shutdown automatically after a few moments, when I connect the charger before it shuts down automatically it instantly reboots and loops again.

I also tried doing a hard factory reset using the recovery menu accessible when pressing power + volume up (only accessible if I unplug the device from power, else it will loop again).

Then I tried turning off the feature that it turns itself on when a charger is connected, using fastboot, which didn't help either.

I then tried flashing the factory ROM onto the tablet using SP_flash, that didn't fix anything either sadly but it was worth a shot.

Currently I am trying a script to force the device to charge the battery, or better said give it time to charge it by looping the reboot into fastboot, as it seems for some reason tablets only charge their battery when the screen is turned off on critical battery status, here is the script appended

@echo off

:start

fastboot getvar battery-voltage

fastboot reboot-bootloader

ping /n 6 localhost >nul

goto start

The script by the way has a rather interesting non existing output... it seems like getvar battery-voltage keeps on being empty, I thought at first that maybe the voltage sensor is broken but after some research in google I realized that even working devices seem to have no output there, while others do.

With that last attempt I am trying currently to charge the battery above the 30% mark so it theoretically can boot normally and stay turned on.

Alright, so with that I am at the end of my technical dialect and my ability to search google so I am asking you guys if you have another suggestion which I could try or anything else besides sending it into service, I am a computer technician and usually don't service android devices so I have no clue what else is possible, thanks in advance!

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 2
Agregar un comentario

3 Respuestas

I have the exact issue with my lenovo A3500

Fue útil esta respuesta?

Calificación 0

Comentarios:

Was u able to solve it ?

por

Agregar un comentario

Hello,

I have the same problem and I am a technician too. :)

Did you find any solution for this?

Fue útil esta respuesta?

Calificación 0

Comentarios:

My problem was the battery, I have change that out and now everything fine.

por

Agregar un comentario

I have the same problem in Lenovo A536

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

Daerevardul SIlverblade estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 3

Últimos 7 Días: 22

Últimos 30 Días: 92

Todo El Tiempo: 1,849