Saltar al contenido principal

Pantalla de 24"; Cámara iSight, micrófono y parlantes incorporados; resolución de 1920x1200. Lanzada en octubre de 2008, identificado por el número de modelo A1267.

Preguntas 84 Ver todo

Apple LED Cinema dont work. Please help!

Hello i am new here,

i have a problem:

My Apple Cinema Display won't turn on again.

The USB and iSight Camera does NOT work.

It won't be recognized by my mac (nothing happens at the Mac-side).

It still can charge the Mac.

The fan is spinning.

I measured the voltages on the Logic Board an they are all ok (i use the Apple Technicians Guide for help).

All cables are connected and the boards looks like new.

Can anybody please help me?

Sorry for my bad english, i am from Austria.

PS: ich habe das Display-Kabel (das interne) auf Durchgang überprüft und es passt.

Best regards and thanks for helping!

Mike

Update 21.2: Hello, im tested a few things on the logicboard and found something strange.

When iam unplug the cable which goes from the logicboard top to the Panel, i have 24,3 Volt on TP11 and the fan is spinning.

When i plug in the cable an move it slightly, then the fan stops to spinn and i have only 14,8 Volt.

So it looks like the cable is defect, but how can this happens? The cable was never in motion.

And the Mac still dont find the Display, with or without the cable :(

Thanks for help!

Update (17.3.2017)

I have taken some pictures of the LCD board and the Chips look alright.

Next week i want to measure the voltage with the oscilloscope, maybe the power supply has a defect ELKO which drops the voltage.

Block Image

Block Image

Block Image

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 1
Agregar un comentario

4 Respuestas

Respuesta Más Útil

Hallo Robert,

danke für deine Antwort.

Anbei die Fotos.

Ich werde in 2 Wochen das Netzteil in die Arbeit mitnehmen und testen, ob vielleicht ein ELKO kaputt ist.

Ich hoffe die Fotos helfen!

Danke und lg

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Fue útil esta respuesta?

Puntuación 1

Comentarios:

Did you see my update?

- de

Yes, i write back when i found something.

- de

I think the Logic-Board is defect.

- de

@Mike , Did you find out smth with the ELKOs? I am very curious because at the moment I am suspecting the capacitors at the power source, but I cant find out an explanation to the problem.

- de

@Robert, nope i changed them but it still don't worked.

I still think that the Logic Board is the problem or the cable from rhe display panel.

- de

Agregar un comentario

I still today continue using my Mac display, but I have to occasionally unplug replug the power cable, so the problem still remains. I have ordered two LED strips to replace them when I get time to do it. I realised that adjusting the screen brightness to full before connecting the display to macbook helps for the issue often, but not always.

Fue útil esta respuesta?

Puntuación 1
Agregar un comentario

I just fixed a different issue in my 24" CINEMA displaz so I had to dig pretty deep into the display manuals and IC chips on the logic board. Maybe if you send me the exact details of your display, see

http://www.everymac.com/ultimate-mac-loo...

Then I can get an image what device you exactly have.

Can you also take a high precision image of the IC chip side of your logic board, to verify that no chips are burned.

Then if possible try to connect another cable to the Logic board to rule out the cable fault.

PS: ich kann auch deutsch.

Update (03/08/2017)

So you have exactly the same device as I do. OK. Now,

  1. you say that the Fan spins
  2. the monitor is not recognized by the system, no iSight and no USB hub
  3. The test voltages are ok, according to the service manual.
  4. The charging is still working

Check if you have a faint image on the LCD, no backlight?

Did the display work before? or was it dead already when you got it?

Try to lay it horizontal and see if it works.

It sounds little bit like a logic board problem. OR possibly a LCD problem.

So please before anything, inspect the LCD panel PCB board, sometimes the IC there burns.

Block Image

Block Image

Fue útil esta respuesta?

Puntuación 0

Comentarios:

Ich musste leider selber eine Antwort schreiben, weil man bei einem Kommentar keine Fotos anhängen kann, lg

- de

Hello Robert, do you have any idea?

Today I measured the Voltage of TP11, when i stick in the cable which goes from the logicboard to the display (on the top) the voltage drops from 24.3 to 15 Volts. Is this same by you? And wenn i bend the cable or put something on the fourth pin of the connector (from the left side), the voltage goes down to 0 Volt. I read that you changed the capacitors and then the display worked again. Did you noticed anything at your capacitors, that they are looked defect? Because mine looks very good and they have the right values says my measure device.

- de

The voltage drop sounds like a shortcut somewhere. When you connect the cable the logicboard detects a short/ ground loop somewhere and switches off the 24,3V voltage. I am only guessing I dont know how the logic works but this could be the case.

I havent noticed anything like that in mine, I ll give it a try in a week when I have time to open the monitor again. I changed the capacitors allthough they appeared perfectly fine. My Idea was to cahnge all the big capacitors, because in 8 years time they often cause problems. I d like to note that I also resoldered the LED stripe.

- de

Ok than it looks like, that i need a new logicboard.

Thank you for your help Robert!

- de

Agregar un comentario

The power supply is the problem with the LED Cinema Display 24. It should deliver 90 watts. The electrolytic capacitors lose their power after years and then the power supplies only 88 Wat or less. Therefore, the monitor remains black.

Fue útil esta respuesta?

Puntuación 0

Comentarios:

Whyd you answer and then put a comment with the same thing?

- de

Pull the mini-display port plug out and back in again. Do it a couple of times. Can be that he then runs again. Unfortunately only for a short time. Have the tested. It is connected to the capacitors.

- de

Excuse me. That should not be so. Am new here. My English is not that good.

- de

Hello Tom, if the power supply is defect, why do the Mac not flash his screen when i stick it in?

- de

I can confirm the action that Tom describes. When I conenct&deconnect the display port several times the display work sometimes. I am about to continue changing the capacitors in the power source to find out the culprit.

- de

Mostrar 1 comentario más

Agregar un comentario

Añadir tu respuesta

Mike estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 5

Ultimos 30 días: 26

Todo El Tiempo: 2,210