Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

Preguntas 275 Ver todo

No video on internal nor external display

A few days ago I started up my iMac (21.5" / Mid-2010) I felt the fans running, heard the boot chime and everything seemed fine except there was no video, no backlight, nothing at all on the display. I pressed the play button on the keyboard and iTunes started and played a song.

So I restarted the computer, did the SMC reset, connected it to an external display but still no video.

I checked the diagnostic LEDs and found that the first two are on, but LED #3 is off. So I reseated the video card (as the technician guide suggests) and retested. But still nothing.

My question is, how do I know for sure whether I need a new video card or a new logic board?

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 2
Agregar un comentario

1 Respuesta

Solución Elegida

If your system is able to play a song that isolates the issue to the video.

You stated you also plugged in an external monitor and nothing was seen on it. That isolates the issue down to the video card as the GPU card feeds both the internal & external displays data signals.

Follow this IFIXIT guide: iMac Intel 21.5" EMC 2389 GPU Card Replacement

Fue útil esta respuesta?

Calificación 3
Agregar un comentario

Añadir tu respuesta

U53i2 estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 0

Últimos 7 Días: 0

Últimos 30 Días: 9

Todo El Tiempo: 295