MacBook Pro doesn't recognize replacement hard drive.

Hello everybody,

I am having a very weird problem with my MacBook Pro 15'' Mid 2009 model.

I recently damaged my hard drive, so I decided to buy a new one, which is exactly the same model as the one that I had. A Seagate ST9500420AS 500 GB 7,200 rpm.

Now the thing is that, although my previous drive is damaged, it can still be recognized by the disk utility when I boot from the Snow Leopard Installation DVD. On the other hand, for some reason, the new one is not recognized by the Disk Utility! What's more, I connected an older hard drive that I had, with Leopard installed in it and still it doesn't recognize it. But If I connect it to the USB, it recognizes it and it can boot normally to MacOS....

Isn't it weird? To recognize only the damaged hard drive?

Does anyone have any suggestions? I am dying to get my laptop working because I have many things to do this period. I appreciate your help.

John

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 2

Comentarios:

+1 for interesting issue and well formulated question. Unfortunately I'm clueless about what could be wrong.. If I had the problem my gut would tell me to inspect the connectors closely..

por

When you say "recognized" or "not recognized" do you mean mounted, or, just listed in the left hand column?

por

+ for the good question. How did you damage the old hard drive? Where did the new hard drive come from? What was, and how did you hook up the "older drive" and what had it been in. I get the feeling that we don't have the full story here because this is not supposed to happen.

por

Agregar un comentario

2 Respuestas

Solución Elegida

So, to recap, USB works, but internal doesn't? It may be the Hard Drive Cable thats doing that... If not, its the logic board and it'll need to be replaced so lets hope its the cable.

Fue útil esta respuesta?

Calificación 4

Comentarios:

I agree. It is most likely the cable.

por

+ research

por

Agregar un comentario

Downgrade to EFI 1.6 instead of 1.7.

In 1.7 Apple has removed support for many 3rd party HDD and SSD drives.

Had same problem with OCZ Vertex 4 SSD, and found this solution in forums there.

Fue útil esta respuesta?

Calificación 0

Comentarios:

The difference between 1.6 & 1.7 was SATA versions of drives that could be used. So if you have an newer drive you needed to upgrade the firmware or jumper the drive down for the older I/O standard, review Apple T/N: http://support.apple.com/kb/DL853?viewlo... Apple did not remove any support of HD or SSD drives the standard changed! And you need to adjust for it depending on the system or drive.

por

Agregar un comentario

Añadir tu respuesta

jops estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 1

Últimos 7 Días: 4

Últimos 30 Días: 17

Todo El Tiempo: 7,261