Saltar al contenido principal

Modelo A1286. Lanzado en febrero de 2011 / 2.0, 2.2 o 2.3 GHz Procesador Intel Core i7 de cuatro núcleos

Preguntas 569 Ver todo
Pregunta Cerrada

No visible airport card

Can anyone recommend a source for replacement airport card for early 2011 15.4" macbook pro?

I have updated the questions to reflect some recent updates, I now just need to find a quality replacement card and was hoping someone here could recommend one.

:: Issue stated below solved::

Hello. I recently picked up a problem MacBook pro (early 2011 2.0ghz (base model)) from a friend. We are both experienced technicians in the IT field and neither have really been able to figure out a solution to the issue. I haven't tried a third card yet, however the previous owner installed a new airport card and the OS still does not show the existence of an airport card. I have also reseated the card, and cables, reinstalled OS X Mtn lion, and thoroughly inspected the logic board for liquid damage. I have seen this issue after spills but never in a notebook in mint condition. Lastly I will add that all other aspects of the mac are working correctly. I own a second MB early 2011" 15" with the 1gb gpu, so I do have plenty of parts to swap around if anyone has any suggestions. I've googled the problem thoroughly, but I thought i'd ask for opinions before I install a usb wireless dongle. Anyone have any ideas? Thanks!

Update

Thanks machead! So on a whim today I pulled the airport from my personal computer (the same macbook pro just with the upgraded gpu/cpu) and low and behold it works. The only thing I could figure is the replacement airport card board was either bad or has the wrong firmware or something. The card has a sticker on it that simply says "SKY"... followed by the words warranty void if removed, I'm going to try and track down the company and a warranty replacement or try another airport card altogether.

Contestado! Ver respuesta Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 0
Agregar un comentario

1 Respuesta

Solución Elegida

All the OS / EFI updates done?

If the card does not show up in the system information (profiler) then I suspect connector, or nearby component is bad (aka logic board damage).

I have no way (other than looking with the mark one eyeball & a magnifier) for burnt, damaged, swollen components to suggest where or what that "other damage" might be.

Of course you can replace the logic board (that's probably not the answer you're looking for).

Some others here may be of more help.

If this answer is acceptable please remember to return and mark it.

Fue útil esta respuesta?

Puntuación 1

Comentarios:

Sorry this is belated but it was indeed the connector that had failed. I replaced the airport card as we'll to be on the safe side but it's running strong!

- de

Agregar un comentario
Ver Estadísticas:

Ultimas 24 horas: 0

Ultimos 7 días: 0

Ultimos 30 días: 0

Todo El Tiempo: 154