Saltar al contenido principal

Repara tus cosas

Derecho a reparar

Tienda

Guías paso a paso para la reparación de aspiradoras de trineo, robóticas y verticales.

Preguntas 897 Ver todo

won't suck the water up out of the carpet

My hoover steam cleaner just stopped sucking the water back up out of the carpet. the return bin is empty

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Puntuación 16

Comentarios:

It would be nice to see a photo of where the ball is and how to get to the hoses to check them.

I did check the intake chute and it was 90 percent clean. Checked the gasket. It looked fine.

Don't want to go any further here in my bathroom. Will take it in for service.

It is about 10 years old, but not used a lot till recently. Works good when it did work.

- de

It worked correctly first time I used it but this time no water at all in dirty water bin....so that mean it is in my carpet?? What the heck! I tried the fix utube but still nothing. I may need to return this as it is not working!

- de

I have the same issue its spitting out the solution water but not picking it up i checked everything and nothing other than a very wet carpet

- de

My problem turned out to be that the water diverter panel had slipped into the hand tool position. It was a quick and easy fix and I was back to work in no time.

- de

Thank you Kim Parkin that worked for me!!

- de

Mostrar 12 comentarios más

Agregar un comentario

SALTEA LA ACTUALIZACIÓN

Ahorra reparando con un kit todo en uno.

Compra Kits de Reparación

SALTEA LA ACTUALIZACIÓN

Ahorra reparando con un kit todo en uno.

Compra Kits de Reparación

6 Respuestas

Solución Elegida

I would check for a break in the vacuum lines, hoses and clamps.

Fue útil esta respuesta?

Puntuación 5

Comentarios:

I have a blue hoover spinscrub 50 three years old or so and mine does that unless I remove the in-tank filter.yes,it's clean.

There is a valve that the filter goes on that's supposed to close when it gets full..it closes way to early with the filter in place with barely any water in the bottom of the tank.

Works fine without it,I just have to be careful to clean the valve of debris and keep an eye on the water level.

- de

what valve are you talking about

- de

Mine is in the dirty tank inflow opening.its yellow. Yours may be different. Examine your dirty water tank. And all entrances to it.then look insude the tank for a float of any type .

Every machine has something tha cuts off the suction once the dirty tank is full. If its stuck from gunk it can close way to early

- de

IT WORKED!!!!!! It was the filter onn the float! I removed it and it worked! Thank you ociecompton

- de

I had the same problem & after trying all the suggestions & nothing helping, I finally took the filter off the floater and it worked!!! But will it do harm to not use the filter?

- de

Mostrar 12 comentarios más

Agregar un comentario
Respuesta Más Útil

Try cleaning the return canister float ball. If it is stuck in the up position the machine will not make vacuum.

Fue útil esta respuesta?

Puntuación 12

Comentarios:

I like this +

- de

I liked both of those answers, thank you!

- de

In my case, the float is not a blue ball. It’s a yellow flat sided cylinder. Looks kind of like a biscuit. It was easy to fix once I finally figured out the problem with the help of this site. I would like to see a video about this problem and solution. It would help a lot of people, apparently. The trouble shooting “tips” in the factory instructions — like other videos I’ve seen — belabor the obvious and offer “duh” “solutions” to non-problems. (My machine won’t run. Solution: Make sure it’s plugged in. Duh!) my machine, btw, is a SteamVac carpet cleaner.

- de

I have the same kind the flat biscuit looking yellow so what was your problem and how did you fix it you don't say this

- de

Thank god! I spent hours unscrewing parts, cleaning filters & tightening hoses, but this was clearly the real issue to fix!

- de

Mostrar 2 comentarios más

Agregar un comentario

Check the gasket under the dirty water tank. If there's not a good seal/broken gasket, it won't have good suction.

Fue útil esta respuesta?

Puntuación 2
Agregar un comentario

Check the dirty tank, the back flap that you attach the hose too. Mine flipped out when I dumped the dirty water tank, pull it up , then back down, make sure you can't pull it forward, that should do the trick.

Fue útil esta respuesta?

Puntuación 1
Agregar un comentario

I had this problem and I didn’t have the clear front piece latched underneath properly.

Fue útil esta respuesta?

Puntuación 1

Comentarios:

Is the float ball suppose to be up when sucking up the dirty water? Mine stays down, could that be why it isn`t sucking up the dirty water?

- de

Agregar un comentario

My spinbrush 50 worked fine for about 5 minutes out of the box. After the first dirty water dump it stopped sucking because the yellow float “ball” would immediately go up and stop the flow. I found that the sleeve filter over the yellow float was indeed the culprit (as stated in a previous post). It restricted the airflow just enough to cause the problem. I tried rinsing the filter really well but even a little bit of air constriction was too much. I took it off completely and that did the trick. I don’t know what long term effect this might have on the machine, but it’s a good short term fix. Btw, if you have a lot of foam in the dirty water it will cause the same problem - the yellow float will stay in the up position and stop the suction. In this case dumping the dirty tank and rinsing out the foam will fix the problem.

Fue útil esta respuesta?

Puntuación 0
Agregar un comentario

Añadir tu respuesta

Jane Ampe estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 horas: 166

Ultimos 7 días: 1,097

Ultimos 30 días: 4,265

Todo El Tiempo: 152,625