Saltar al contenido principal

Unveiled at the 2000 North American International Auto Show on January 10, 2000, the redesigned 2001 Dodge Caravan and 2001 Chrysler Town & Country were released for sale in August 2000.

Preguntas 176 Ver todo

speed odm aan other gauges are not working

The lights and meter gauges on my dash board does not come on when car starts

. what could be the problem? I have a Dodge Grand Caravan 2001

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 5

Comentarios:

On my 2001 Chrysler T&C my turn signal when activated aside from not working at all, it shuts off all my gages but nothing else, do you know why? Can you point me to someone who can tell me why?

por

2007 problem showed up today. Trip reset didn't work. Battery disconnect didn't work. Hazard fuse BINGO!

Many thanks. Saved a bundle.

por

Agregar un comentario

Kits de Reparación de Android

A new screen or battery is one kit away.

Comprar Ahora

Kits de Reparación de Android

A new screen or battery is one kit away.

Comprar Ahora

10 Respuestas

Solución Elegida

Brother Perry, try this first:"

DIAGNOSIS AND TESTING - SELF-DIAGNOSTICS

The instrument clusters are equipped with a self diagnostic test feature to help identify electronic problems. Prior to any test, perform the Self-Diagnostic Test. The self diagnostic system displays instrument cluster stored fault codes in the odometer display, sweeps the gauges to the calibration points, and bulb checks the warning indicators. When the key is in the ON position with the engine not running, the MIL will remain illuminated for regulatory purposes.

To activate the Self-Diagnostic program:

With the ignition switch in the OFF position, depress the TRIP ODOMETER RESET button.

Continue to hold the TRIP ODOMETER RESET button until "Sof" and a number (software version number appears briefly in the odometer window, then release the button. If a fault code is present, the cluster will display it in the odometer display. When all fault codes have been displayed, the cluster will display “end” or "E" for end in the odometer display.

You can also try a reset by disconnected the negative battery cable and leave it over for about 1/2 hour. This should reset most of the codes on your Dodge (just remember that it will also reset the codes on your radio:-)"

Fue útil esta respuesta?

Calificación 15

Comentarios:

Wow!! Thank you so much! I did the soft reset and it worked perfectly!

Diana

por

Your answer was spot on!!! Thank you so very much!! Never would have thought that holding the trip button in for several seconds would have the vehicle go through a self diagnosis. I sat there in awe and watched it cycle through and wallah the instrument panel speedometer and odometer started working again!!! Thank you, Thank you, Thank you!!!

por

You are a genius..I called the dealership and they said it could be the cluster..1800 dollars. I tried the first thing you said...that didn't work but taking the neg off and reconnecting worked. YOUR A GENIUS! You saved me from a blood sucking dealership...Kisses

por

Thanks for your help. That worked on my 2002 dodge neon

por

Thank You the hold trip reset pin in with no key in ignition worked for me 2001 T&C EX 3.8L. my gauges were doing weird things before i cleaned the battery posts, after i cleaned the posts the gauges were dead totally until i did the reset

por

Mostrar 10 comentarios más

Agregar un comentario

I know this is an older post but I had just problems with my instrument cluster in my 2002 Dodge grand caravan eL 3.3L . No blinkers, no Od , no speedo, all dead, there was only illumination with head lights on cluster was dimmable ,

Answer / Solve ; Smaller wire, red, with fusible link 3" from battery positive that goes from battery positive to the power distribution center.

Fue útil esta respuesta?

Calificación 6

Comentarios:

Same symptoms as above after killing my battery overnight. This is the simplest solution I've seen suggested and it worked (indirectly) on my '01 caravan. After trying the " do this....it's this $50 part or that $600 part , it was the act of isolating the fusible link that fixed the cluster circuit it in my case. Clean the battery terminals and circuit connectors when checking power circuits!

Thank you Sir!

por

I had the same problem as this, the hazard light fuse wasn't blown and I had a good connection at the battery terminal. Followed the brown\red wire from the battery to the underside of the fuse box, which connects to the hazard light and sure enough the cable had corroded completely away from the connector. Replaced the cable and soldered it into what was left of the connector, and I was back in business.

Thank you for pointing me in the right direction that ultimately solved my issue!

por

A loose wire going directly to the positive terminal is all mine was thank you for all the info everybody.

por

yes it solved the problem, thank you

por

Awesome tip!!! Worked for me. Thank You!!!

por

Agregar un comentario

My battery died and when I tried to jump it, the instrument panel and turn signals stopped working. I had replaced the batteries, so I checked the battery cables and everything I could think of.

The solution was the FUSE for the HAZARD LIGHTS. How in the world that made the speedometer, odometer, etc. stop working is a complete mystery, but there you go.

Fue útil esta respuesta?

Calificación 4

Comentarios:

Was in the middle of a 5 hrs road trip, tach, odm, gas gauge, brake lights, turn signals, and hazards all stopped working, in the middle of the night. After reading this forum...we found a blown HAZARD LIGHTS fuse. Put a new one in and all is right again. Thanks for posting your fixes!

por

Hazard fuse, saved me pulling them one at a time - thank you

por

where is this fuse??

por

Agregar un comentario

All instruments inop, tach water temp speedometer odometer turn signals rear brake lights seat belt and key in ignition warning inop. Found the fuse marked hazard lights blown. That fixed it

Fue útil esta respuesta?

Calificación 3
Agregar un comentario

2002 Chrysler Town & Country Limited

I found the extra wire going to the positive terminal on the battery came loose so I repositioned it and tightened it down and my dash cluster came back on thank you everyone for your info it really helped.

Fue útil esta respuesta?

Calificación 2

Comentarios:

Hyyggmkj2limwhjbkiomi

por

Agregar un comentario

My 2006 T&C instruments would sometimes go crazy, then turn off, while the radio seemed to continue making a clicking sound like a relay switching on and off. Wednesday, it wouldn't straighten out when I disconnected the battery, like it had before. I checked the fuse box with the ignition off, and the accessory relay was clicking off and on. When I remove the relay, the dash board is fine, but the radio and power windows don't work. When I put it back, the problem comes back. At least we can drive it with the relay out. (Actually, it drove fine even when the instruments weren't working, but it's hard to select the right gear and obey the speed limit.) A new relay did not solve the problem.

My guess, with some help from a friend who is an expert Chrysler mechanic, is that the power cycling is confusing a computer on the accessory circuit, maybe in the radio, and it is transmitting garbage that prevents the instrument panel from knowing what to display. Tomorrow I plan to check the driver's window switches, which stick sometimes. If that's not the cause, I might disconnect the radio, and check whether I can find anything else on that circuit.

Fue útil esta respuesta?

Calificación 1
Agregar un comentario

help in having some of the same problems while driving my radio went out with a tire smile then my doors wont lock and the key wont unlock the door SMH no mechanic would look at it today and I'm definitely limited on funds need some help

Fue útil esta respuesta?

Calificación 1
Agregar un comentario

Omg someone please help me my husband took the battery out of my 2002 dodge van and when he put it back in the dash gauges the turn signals and hazard lights don't work we pulled over he unhooked battery and hooked back up and they worked then I turned on the turn signal and they all went off and haven't worked since… any ideas are appreciated I don't even no where to start and have no idea what I'm doing…

Fue útil esta respuesta?

Calificación 1

Comentarios:

HI, I too have a 2002 dodge grand caravan. Yesterday I went to turn the hazard lights on, soon as i pushed the button the whole instrument cluster went out. No turn signals, milage, gear indicator, tachometer, speedometer. I pulled the battery post off, waited 10min, put it back on and this work for a little while until i hit the turn signal and it went right back out.

The cause of problem: bad connection under fuse box going to hazard circuit. The connection plug pins had some corrosion on them. This allowed voltage to travel through that circuit but not enough current.

The solution: remove both battery post, remove battery, un-clip fuse box, roll fuse box over into battery location, find plug thats under the location of hazard fuse, remove clip and disconnect plug, remove pin guide on end of plug, clean female connections on plug end, clean male pins on underside on fuse box, Reverse these steps to put back together...You're Done!

Easy said than done, but do your best.

Vince B Troubleshooter

por

Agregar un comentario

I have a 2000 dodge dakota 3.9L. The instrument cluster is not working for it. I had replaced the cluster 4 different times. Contacted the dodge dealership and made sure the cluster was the right part number i have. Which it is. I had replaced the fuse for the cluster and cleaned the connections. I cleaned the fusebox under the hood, i unhooked the battery for a half hour. The cluster is having power towards it due to the fact that dash lights light up on it but it doesnt read the mileage. I was at the neighbors and he hooked up his tech obd2 scanner to it to see whats wrong. Hes even stumped. All the computers are saying the cluster isnt in and it is.

I need help! Any ideas!?

Fue útil esta respuesta?

Calificación 1

Comentarios:

So many Dakotas in that year range had really bad corrosion on the lower boarded fuse / relay box under hood, visible by removing bottom cover. May be limited to area living in as I'm in ohio

por

Agregar un comentario

there is no communication between cluster and BCM, it could be a fuse different than the one for lights, or faulty serial communication bus lines

Fue útil esta respuesta?

Calificación 1
Agregar un comentario

Añadir tu respuesta

Brother Perry estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 59

Últimos 7 Días: 329

Últimos 30 Días: 1,438

Todo El Tiempo: 83,839