Saltar al contenido principal
Help

Original post by: Josh Calvetti ,

Texto:

Nope- Snow Leopard requires an Intel processor.  You might be able to install 10.5 (Leopard), but it will be sluggish at best.  I'd recommend sticking with 10.4.

Estado:

open