Saltar al contenido principal
Ayuda

Versión actual por: Jason Bean ,

Título:

After Screen & Flex Cable Replacement Ambient Light Sensor Not Working

Texto:

I recently replaced the screen on my iPhone 7 Plus. During my initial attempt I permanently damaged the (double bonded) flex cable for the speaker, sensors, & camera so I ordered a replacement.
 
I got the replacement for that flex cable a couple days ago and installed it. Everything is working (camera, speaker & proximity sensor) except for the ambient light sensor. On the original screen I noticed that there is a white filter that I did not see an easy way to transfer to the replacement. Is this filter necessary for the ambient light sensor to function properly or do I possibly have a bad sensor and need to seek a replacement for the cable?
 
Not having the ambient light sensor working is not necessarily a show stopper but it would definitely be nice to be back to having a fully functional phone.
Not having the ambient light sensor working is not necessarily a show stopper but it would definitely be nice to be back to having a fully functional phone.
 
=== Update (08/10/2017) ===
 
Well, after transferring the filter over to the new display it still doesn't seem to be working. In fact, it seems to be getting random values from the sensor. If I turn auto-brightness off and then back on it will settle at different brightnesses at different times. Very weird.
 
Anyway, I called the seller and they are sending a replacement. Crossing my fingers that it will work correctly.

=== Update (08/21/2017) ===

I hadn't updated my post. Life has kind of gotten in the way. I received the replacement part and it's actually worse than the original. Not only did the ambient light sensor not work but the front speaker didn't work. I had to change back to the original replacement and just deal with no automatic screen brightness.

Part of me wonders if something got damaged on the board? When I was swapping in the replacement part I noticed that part of the foam surrounding the socket might have been pushed into the socket. My eyes aren't as good as they used to be for focusing on small things and I don't have a microscope to ensure the socket is completely clean of foam or glue but nothing changed after I pushed the foam back. I'm hoping that nothing got fried on the system board. I did make sure to disconnect the battery during my repair. It was always the first and last thing to get disconnected and reconnected.
Anyway, I called the seller and they are sending a replacement. Crossing my fingers that it will work correctly.

=== Update (08/21/2017) ===

I hadn't updated my post. Life has kind of gotten in the way. I received the replacement part and it's actually worse than the original. Not only did the ambient light sensor not work but the front speaker didn't work. I had to change back to the original replacement and just deal with no automatic screen brightness.

Part of me wonders if something got damaged on the board? When I was swapping in the replacement part I noticed that part of the foam surrounding the socket might have been pushed into the socket. My eyes aren't as good as they used to be for focusing on small things and I don't have a microscope to ensure the socket is completely clean of foam or glue but nothing changed after I pushed the foam back. I'm hoping that nothing got fried on the system board. I did make sure to disconnect the battery during my repair. It was always the first and last thing to get disconnected and reconnected.

Dispositivo:

iPhone 7 Plus

Estatus:

open

Editado por: Jason Bean ,

Título:

After Screen & Flex Cable Replacement Ambient Light Sensor Not Working

Texto:

I recently replaced the screen on my iPhone 7 Plus. During my initial attempt I permanently damaged the (double bonded) flex cable for the speaker, sensors, & camera so I ordered a replacement.
 
I got the replacement for that flex cable a couple days ago and installed it. Everything is working (camera, speaker & proximity sensor) except for the ambient light sensor. On the original screen I noticed that there is a white filter that I did not see an easy way to transfer to the replacement. Is this filter necessary for the ambient light sensor to function properly or do I possibly have a bad sensor and need to seek a replacement for the cable?
 
Not having the ambient light sensor working is not necessarily a show stopper but it would definitely be nice to be back to having a fully functional phone.

=== Update (08/10/2017) ===

Well, after transferring the filter over to the new display it still doesn't seem to be working. In fact, it seems to be getting random values from the sensor. If I turn auto-brightness off and then back on it will settle at different brightnesses at different times. Very weird.

Anyway, I called the seller and they are sending a replacement. Crossing my fingers that it will work correctly.
Not having the ambient light sensor working is not necessarily a show stopper but it would definitely be nice to be back to having a fully functional phone.

=== Update (08/10/2017) ===

Well, after transferring the filter over to the new display it still doesn't seem to be working. In fact, it seems to be getting random values from the sensor. If I turn auto-brightness off and then back on it will settle at different brightnesses at different times. Very weird.

Anyway, I called the seller and they are sending a replacement. Crossing my fingers that it will work correctly.

Dispositivo:

iPhone 7 Plus

Estatus:

open

Aporte original por: Jason Bean ,

Título:

After Screen & Flex Cable Replacement Ambient Light Sensor Not Working

Texto:

I recently replaced the screen on my iPhone 7 Plus. During my initial attempt I permanently damaged the (double bonded) flex cable for the speaker, sensors, & camera so I ordered a replacement.

I got the replacement for that flex cable a couple days ago and installed it. Everything is working (camera, speaker & proximity sensor) except for the ambient light sensor. On the original screen I noticed that there is a white filter that I did not see an easy way to transfer to the replacement. Is this filter necessary for the ambient light sensor to function properly or do I possibly have a bad sensor and need to seek a replacement for the cable?

Not having the ambient light sensor working is not necessarily a show stopper but it  would definitely be nice to be back to having a fully functional phone.

Dispositivo:

iPhone 7 Plus

Estatus:

open