Saltar al contenido principal
Ayuda

Aporte original por: Timothy Hoppe ,

Texto:

OK, just going to post a full answer because we have a piecemeal selection and it is all partly correct. The first time we ran across the problem was when the phone first came out. We did a screen repair but the tech couldn't get the ear speaker to work. Ordered a new ear speaker and new flex cable but same problem with multiple parts. So we slapped the broken screen back on, had the customer remove the icloud, and drove it up to apple. Well they just swapped the screen out and it worked perfectly. That told us that either apple had put some sort of syncing software like they have with the fingerprint scanner, or it actually was the flex cable. The tech admitted he unplugged the flex before disconnecting the battery, and we spoke to another local store owner who had come across the same problem and reached the same conclusion. So we paid extra attention and didn't have a problem for months. We did come across an issue with a boot loop, and that was fixed when we noticed the square piece of tape was missing. The ear speaker mesh has some metal in it so that accounts for the short that causes the boot loop. Anyway, fast forward to today and I had the same no sound problem with one I repaired. I know that I unplugged the battery first so that was ruled out as a cause. The black adhesive had moved over so that was ruled out as a cause. I tried everything I could think of aside from replacing the flex because I didn't have one. Finally I gave up and decided to disect the flex cable. I heated up the solder and separated the camera side from the prox sensor side. Once I inspected it under the microscope I found that one of the pads from the prox sensor side had torn. The copper in the flex is so microscopic that even a small bend can tear it inside the coating. I think what is confusing people is that they are moving the tape over and when they press it back on it is sticking the circuit back together and it just happens to work (for now). I got a new flex cable from another iphone and put it in and it worked perfectly. The problem is people are getting aftermarket flex cables that aren't soldered together well so sometimes a new flex won't work because it's a faulty flex. We used to have a similar problem with I think the iphone 5 camera flex when it first came out because it was two separate parts soldered together poorly, but eventually they improved and there was no problems after that.

TL;DR version: you damaged the camera flex, dont skimp out on the cheapest replacement part you can get. Buy high quality from a reputable vendor, and if all else fails then just pull one from another iphone.

Estatus:

open