Saltar al contenido principal
Help

Versión actual por: mayer (vote details) ,

Título:

water damage, no sound, very slow, fan keep spinning in high speed

Texto:

MacBook Air 13" Mid 2012

Spilled some water on it, then some keys stopped working, so I replaced the keyboard, the new keyboard works fine, however after the replacement; there is no sound at all (not even the boot up chime) , and it becomes very slow , even just moving the mouse lags; and the fan is always spinning at high speed;

The WIFI also malfunctioned after replacement for some time (no hardware installed), but somehow it is working again.

I tried to reset SMC, doesn't work, the LED on the magnet connector doesn't even light up.

which part might be wrong in such case? logic board or I/O board?

Dispositivo:

MacBook Air 13" Mid 2012

Estado:

open

Respuesta aceptada:

343497

Original post by: Jun Hu ,

Título:

water damage, no sound, very slow, fan keep spinning in high speed

Texto:

MacBook Air 13" Mid 2012

Spilled some water on it, then some keys stopped working, so I replaced the keyboard, the new keyboard works fine, however after the replacement; there is no sound at all (not even the boot up chime) , and it becomes very slow , even just moving the mouse lags; and the fan is always spinning at high speed;

The WIFI also malfunctioned after replacement for some time (no hardware installed), but somehow it is working again.

I tried to reset SMC, doesn't work, the LED on the magnet connector doesn't even light up.

which part might be wrong in such case? logic board or I/O board?

Dispositivo:

MacBook Air 13" Mid 2012

Estado:

open