Saltar al contenido principal

Repara tus cosas

Derecho a reparar

Tienda

Ayuda

Aporte original por: mayer ,

Texto:

No.  The highest system your machine will take is 10.5.8. Leopard.  Anything higher requires an Intel processor.

Estatus:

open