Saltar al contenido principal

Repara tus cosas

Derecho a reparar

Partes y herramientas

Ayuda

Versión actual por: oldturkey03 (detalles del voto) ,

Título:

Why do I have intermittent battery charging?

Texto:

I've had multiple issues with charging this MBA. After replacing the battery, (which checks out okay with Coconut scan) I've had a few different results when connecting the MagSafe (genuine Apple adapter). At first the light on the charger wouldn't come on but the battery would charge fully. The light would occasionally turn Amber but never seemed to stay lit. It would even turn green when fully battery was fully charged. I thought it might be a bad charger but I tested a different charger and got same result.

I swapped out the power board but that gave me a worst result. The battery would not charge but the MBA would run on the charger (no lights). I re-installed the original power board but ended up with the same result as the new power board, not charging the battery but working from the charger. With the battery still holding 70% I shut the MBA down and left it connected to the charger ( no lights on). I came back a few hours later to find a bright green light on the charger and a fully charged battery.

I've tried resetting the SMC and PRAM.

Does this sound like a bad power control module on the motherboard? Could it be a bad flex cable?

Dispositivo:

MacBook Air 11" Mid 2012

Estatus:

open

Respuesta Aceptada:

241700

Aporte original por: TimC ,

Título:

Why do I have intermittent battery charging?

Texto:

I've had multiple issues with charging this MBA. After replacing the battery, (which checks out okay with Coconut scan) I've had a few different results when connecting the MagSafe (genuine Apple adapter). At first the light on the charger wouldn't come on but the battery would charge fully. The light would occasionally turn Amber but never seemed to stay lit. It would even turn green when fully battery was fully charged. I thought it might be a bad charger but I tested a different charger and got same result.

I swapped out the power board but that gave me a worst result. The battery would not charge but the MBA would run on the charger (no lights). I re-installed the original power board but ended up with the same result as the new power board, not charging the battery but working from the charger. With the battery still holding 70% I shut the MBA down and left it connected to the charger ( no lights on). I came back a few hours later to find a bright green light on the charger and a fully charged battery.

I've tried resetting the SMC and PRAM.

Does this sound like a bad power control module on the motherboard? Could it be a bad flex cable?

Dispositivo:

MacBook Air 11" Mid 2012

Estatus:

open