Saltar al contenido principal
Ayuda

Versión actual por: oldturkey03 (detalles del voto) ,

Título:

Won't turn on unless plugged in but shows battery charging?

Texto:

Earlier this year my battery stopped charging (I used a genuine Apple charger then) and I watched the power dwindle to 0% until it died. So I bought a replacement charger which didn't help (60W). The Genius Bar said the left I/O board wasn't picking up a charge from MagSafe connector so they replaced the board. Three months later it died again so I bought a left I/O board and just replaced it myself.

So I plugged it in (60W charger) and powered it on. (Light went green and then orange so it was a good sign that it was charging the battery). The charging icon showed 0% charge time 20:00 and then stayed that way for maybe 20-30 minutes? Then went on to 1% for another 15 minutes or so. This was at midnight last night so I left it plugged in overnight.

This morning I turned it on and was surprised to see it was at 100% battery and then I pressed the indicator button on the bottom of the battery and all of the green lights flashed on confirming that, yes, it did charge.

But as soon as  attempted to disconnect it from the power adapter, the laptop shut off.

I cracked it open again to make sure everything was connected and no parts looked loose and it looks fine.

Not sure why the battery is able to charge and the laptop able to read it's presence/ progress (albeit slow progress), but not collect power from the battery on its own?

Before it died that second time after I'd gotten it fixed I recall seeing some warning on the laptop saying "Replace battery soon" or battery in critical condition or something like that, but I haven't seen that again and it's obviously still alive.

maybe the battery is strong enough to charge but not strong enough to power on the laptop?

Or something is up with the battery connector, but then it wouldn't make sense that its charging.

Or something is up with the logic board, but it seems to be running perfectly fine (using this laptop right now and the power thing is the only issue).

I tried resetting the SMC thing that Apple suggests already. And Imagine the PRAM is fine because the Time/Date display is working fine.

Suggestions? Do I need a new battery... connector... logic board? Or could it be something else?

Thanks in advance!

Dispositivo:

MacBook Pro 15" Core 2 Duo Model A1211

Estatus:

open

Respuesta Aceptada:

188179

Aporte original por: Barb ,

Título:

Won't turn on unless plugged in but shows battery charging?

Texto:

Earlier this year my battery stopped charging (I used a genuine Apple charger then) and I watched the power dwindle to 0% until it died. So I bought a replacement charger which didn't help (60W). The Genius Bar said the left I/O board wasn't picking up a charge from MagSafe connector so they replaced the board. Three months later it died again so I bought a left I/O board and just replaced it myself.

So I plugged it in (60W charger) and powered it on. (Light went green and then orange so it was a good sign that it was charging the battery). The charging icon showed 0% charge time 20:00 and then stayed that way for maybe 20-30 minutes? Then went on to 1% for another 15 minutes or so. This was at midnight last night so I left it plugged in overnight.

This morning I turned it on and was surprised to see it was at 100% battery and then I pressed the indicator button on the bottom of the battery and all of the green lights flashed on confirming that, yes, it did charge.

But as soon as  attempted to disconnect it from the power adapter, the laptop shut off.

I cracked it open again to make sure everything was connected and no parts looked loose and it looks fine.

Not sure why the battery is able to charge and the laptop able to read it's presence/ progress (albeit slow progress), but not collect power from the battery on its own?

Before it died that second time after I'd gotten it fixed I recall seeing some warning on the laptop saying "Replace battery soon" or battery in critical condition or something like that, but I haven't seen that again and it's obviously still alive.

maybe the battery is strong enough to charge but not strong enough to power on the laptop?

Or something is up with the battery connector, but then it wouldn't make sense that its charging.

Or something is up with the logic board, but it seems to be running perfectly fine (using this laptop right now and the power thing is the only issue).

I tried resetting the SMC thing that Apple suggests already. And Imagine the PRAM is fine because the Time/Date display is working fine.

Suggestions? Do I need a new battery... connector... logic board? Or could it be something else?

Thanks in advance!

Dispositivo:

MacBook Pro 15" Core 2 Duo Model A1211

Estatus:

open