Saltar al contenido principal
Ayuda

Versión actual por: mayer (detalles del voto) ,

Título:

How to Disable/Swap faulty Temperature Sensor?

Texto:

Hey there!

My 3,5 year old MacBook  (OSX 10.9.1) stopped working last week.

After watching some videos on youtube the screen just turned gray and all I could do was to force it to shut down.

When I start the device now the screen shows briefly the Apple Logo and then I get the same gray screen.

I tried SMC and PRAM reset, booting in save and recovery mode etc. but I can't launch the OS. All I get is a gray screen. (in save mode it is black)

Only the hardware test worked. It showed this error code after the test:

4SNS/1/C0000008: TsOP--124

After some research I found out, that this refers to a faulty temperature sensor.

'''So I have 2 questions:'''

Can you tell which sensor it is and if I can replace or fix it, OR disable it in software?

Could it be, that the problem is not caused by the faulty heat sensor but something else? Because from what I have read so far, faulty heat sensors usually cause high fan speeds and no gray start screen.

PS: sorry for bad grammar or misspellings, english is not my mother tongue.

Dispositivo:

MacBook Pro 15" Unibody Early 2011

Estatus:

open

Respuesta Aceptada:

180682

Aporte original por: creezebert ,

Título:

How to Disable/Swap faulty Temperature Sensor?

Texto:

Hey there!

My 3,5 year old MacBook  (OSX 10.9.1) stopped working last week.

After watching some videos on youtube the screen just turned gray and all I could do was to force it to shut down.

When I start the device now the screen shows briefly the Apple Logo and then I get the same gray screen.

I tried SMC and PRAM reset, booting in save and recovery mode etc. but I can't launch the OS. All I get is a gray screen. (in save mode it is black)

Only the hardware test worked. It showed this error code after the test:

4SNS/1/C0000008: TsOP--124

After some research I found out, that this refers to a faulty temperature sensor.

'''So I have 2 questions:'''

Can you tell which sensor it is and if I can replace or fix it, OR disable it in software?

Could it be, that the problem is not caused by the faulty heat sensor but something else? Because from what I have read so far, faulty heat sensors usually cause high fan speeds and no gray start screen.

PS: sorry for bad grammar or misspellings, english is not my mother tongue.

Dispositivo:

MacBook Pro 15" Unibody Early 2011

Estatus:

open