Skip to main content
Help

Versión actual por: oldturkey03 (vote details) ,

Título:

How to fix "vertical lines" on my iMac 27 late 2009

Text:

Hi everybody, my name is george and i'm from germany.

i bought a faulty imac 27 2009 i7 with harddrive damage but the seller didnt told me there were these digital vertical stripes all over the whole screen.

so i waited a few weeks to buy another imac 27 2009 i5 with just another cpu and a faulty gpu which i repaired and now its working very well.

so i startet replacing the parts of the imacs to analyse the problem.

i ordered new lvds cable and v.sync cable. replaced them but nothing became better.

i replaced the lcd und nothing was better.

after that i replaced the power board next to the power supply and also i replaced the power supply. still nothing better than before. it cant be the gpu...

i didnt try to change dumb things like the odd, camera, ram or cpu.

maybe i should try that next.

i want to repair that device and i will. but maybe i need some help from someone else. after that we will definitely know what the cause for that apple fault is.

i think its the internal display port or damaged ic's in it or something else on the motherboard.

also very important, i tried the mini displayport to hdmi. perfect screen on my tv, no lines und no problems.

so what is it!!!???

now, a few hours later, graphics card replaced and still nothing.

pluggen everything thats not needed off, but still nothing.

so its definitely the motherboard and something is wrong with the internal display cable port.

but what is it!!!

help!

2 hours later I soldered all the connection points from the lvds port to clear out that there are no dead solder points.

also its not the connector, maybe it is, so i would have to order a new port to solder it.

no one has the solution and i know i am not alone.

please help me to clear that problem.

Dispositivo:

iMac Intel 27" EMC 2309 and 2374

Estado:

open

Respuesta aceptada:

172689

Edit by: Sam Goldheart ,

Título:

How to fix "vertical lines" on my iMac 27 late 2009

Text:

Hi everybody, my name is george and i'm from germany.

i bought a faulty imac 27 2009 i7 with harddrive damage but the seller didnt told me there were these digital vertical stripes all over the whole screen.

so i waited a few weeks to buy another imac 27 2009 i5 with just another cpu and a faulty gpu which i repaired and now its working very well.

so i startet replacing the parts of the imacs to analyse the problem.

i ordered new lvds cable and v.sync cable. replaced them but nothing became better.

i replaced the lcd und nothing was better.

after that i replaced the power board next to the power supply and also i replaced the power supply. still nothing better than before. it cant be the gpu...

i didnt try to change dumb things like the odd, camera, ram or cpu.

maybe i should try that next.

i want to repair that device and i will. but maybe i need some help from someone else. after that we will definitely know what the cause for that apple fault is.

i think its the internal display port or damaged ic's in it or something else on the motherboard.

also very important, i tried the mini displayport to hdmi. perfect screen on my tv, no lines und no problems.

so what is it!!!???

now, a few hours later, graphics card replaced and still nothing.

pluggen everything thats not needed off, but still nothing.

so its definitely the motherboard and something is wrong with the internal display cable port.

but what is it!!!

help!

2 hours later I soldered all the connection points from the lvds port to clear out that there are no dead solder points.

also its not the connector, maybe it is, so i would have to order a new port to solder it.

no one has the solution and i know i am not alone.

please help me to clear that problem.

Dispositivo:

iMac Intel 27" EMC 2309 and 2374 (i5 late 2009)
iMac Intel 27" EMC 2309 and 2374 (i5 late 2009)

Estado:

open

Edit by: originalmachead ,

Título:

How to fix "vertical lines" on my iMac 27 late 2009

Text:

Hi everybody, my name is george and i'm from germany.

i bought a faulty imac 27 2009 i7 with harddrive damage but the seller didnt told me there were these digital vertical stripes all over the whole screen.

so i waited a few weeks to buy another imac 27 2009 i5 with just another cpu and a faulty gpu which i repaired and now its working very well.

so i startet replacing the parts of the imacs to analyse the problem.

i ordered new lvds cable and v.sync cable. replaced them but nothing became better.

i replaced the lcd und nothing was better.

after that i replaced the power board next to the power supply and also i replaced the power supply. still nothing better than before. it cant be the gpu...

i didnt try to change dumb things like the odd, camera, ram or cpu.

maybe i should try that next.

i want to repair that device and i will. but maybe i need some help from someone else. after that we will definitely know what the cause for that apple fault is.

i think its the internal display port or damaged ic's in it or something else on the motherboard.

also very important, i tried the mini displayport to hdmi. perfect screen on my tv, no lines und no problems.

so what is it!!!???

now, a few hours later, graphics card replaced and still nothing.

pluggen everything thats not needed off, but still nothing.

so its definitely the motherboard and something is wrong with the internal display cable port.

but what is it!!!

help!

2 hours later I soldered all the connection points from the lvds port to clear out that there are no dead solder points.

also its not the connector, maybe it is, so i would have to order a new port to solder it.

no one has the solution and i know i am not alone.

please help me to clear that problem.

Dispositivo:

iMac Intel 27" EMC 2309 and 2374 (i5 late 2009)

Estado:

open

Edit by: originalmachead ,

Título:

How to fix "vertical lines" on my iMac 27 late 2009

Text:

Hi everybody, my name is george and i'm from germany.

i bought a faulty imac 27 2009 i7 with harddrive damage but the seller didnt told me there were these digital vertical stripes all over the whole screen.

so i waited a few weeks to buy another imac 27 2009 i5 with just another cpu and a faulty gpu which i repaired and now its working very well.

so i startet replacing the parts of the imacs to analyse the problem.

i ordered new lvds cable and v.sync cable. replaced them but nothing became better.

i replaced the lcd und nothing was better.

after that i replaced the power board next to the power supply and also i replaced the power supply. still nothing better than before. it cant be the gpu...

i didnt try to change dumb things like the odd, camera, ram or cpu.

maybe i should try that next.

i want to repair that device and i will. but maybe i need some help from someone else. after that we will definitely know what the cause for that apple fault is.

i think its the internal display port or damaged ic's in it or something else on the motherboard.

also very important, i tried the mini displayport to hdmi. perfect screen on my tv, no lines und no problems.

so what is it!!!???

now, a few hours later, graphics card replaced and still nothing.

pluggen everything thats not needed off, but still nothing.

so its definitely the motherboard and something is wrong with the internal display cable port.

but what is it!!!

help!

2 hours later I soldered all the connection points from the lvds port to clear out that there are no dead solder points.

also its not the connector, maybe it is, so i would have to order a new port to solder it.

no one has the solution and i know i am not alone.

please help me to clear that problem.

Dispositivo:

iMac Intel 27" EMC 2309 and 2374 (i5 late 2009)

Estado:

open

Original post by: georg ,

Título:

How to fix "vertical lines" on my iMac 27 late 2009

Text:

Hi everybody, my name is george and i'm from germany.

i bought a faulty imac 27 2009 i7 with harddrive damage but the seller didnt told me there were these digital vertical stripes all over the whole screen.

so i waited a few weeks to buy another imac 27 2009 i5 with just another cpu and a faulty gpu which i repaired and now its working very well.

so i startet replacing the parts of the imacs to analyse the problem.

i ordered new lvds cable and v.sync cable. replaced them but nothing became better.

i replaced the lcd und nothing was better.

after that i replaced the power board next to the power supply and also i replaced the power supply. still nothing better than before. it cant be the gpu...

i didnt try to change dumb things like the odd, camera, ram or cpu.

maybe i should try that next.

i want to repair that device and i will. but maybe i need some help from someone else. after that we will definitely know what the cause for that apple fault is.

i think its the internal display port or damaged ic's in it or something else on the motherboard.

also very important, i tried the mini displayport to hdmi. perfect screen on my tv, no lines und no problems.

so what is it!!!???

now, a few hours later, graphics card replaced and still nothing.

pluggen everything thats not needed off, but still nothing.

so its definitely the motherboard and something is wrong with the internal display cable port.

but what is it!!!

help!

2 hours later I soldered all the connection points from the lvds port to clear out that there are no dead solder points.

also its not the connector, maybe it is, so i would have to order a new port to solder it.

no one has the solution and i know i am not alone.

please help me to clear that problem.

Dispositivo:

iMac Intel 27" EMC 2309 and 2374 (i5 late 2009)

Estado:

open