Saltar al contenido principal
Ayuda

Aporte original por: Lenny Grey ,

Texto:

Hi All,

Found this post the other night searching for the answer to this problem I had with my phone, after replacing the whole screen assembly. Sent the first one back to where I bought it and received a replacement with a similar problem.

Symptoms when the phone wasn't totally assembled (just the motherboard attached the the screen chassis frame and all the connectors and a battery inserted) are the phone would boot fine, then when any pressure was applied to the top half of the screen, the screen would go black and not return, but it would be responsive to touch input and the stylus.

I imagine due to having to apply pressure when fitting the back case, after fitting the case and putting in all the screws, the screen would not work at all. I tried the screen off the motherboard (but still in the steel mid frame) and it still had he same issue.

After much swearing and frustration, and emails exchanged between myself and the supplier of the screen - I managed to fix the problem.

The 3.5mm Jack is held in two small phillips head screws, one inside the case, and one that goes through the back case and through.

I removed the first of these two screws (the one that is only accessible when the case if apart), and reassembled the phone without any screw in this hole.

This has fixed my black screen problem. not sure if this will work for anybody else or if this is even the same problem, but I thought I would tell of my findings.

I had this exact same issue when I first got the phone a year ago, though not as bad. The screen would just go black while in use and then it would take a few lock/unlocks and maybe a battery pull to bring it back to life, but it eventually went away.

One thing I did notice was that the screws holding in the 3.5mm jack were -very- loose. Not sure if this is why the issue went away, but you never know

If this fix also works for anybody who tries it. Please us know of your findings!

Estatus:

open