Saltar al contenido principal
Ayuda

Versión actual por: iRobot ,

Título:

MacBook not starting - Battery and MagSafe lights full/green?

Texto:

Hi,

My MacBook is not starting. When I push the power button, there is no chime. Sometimes the screen briefly flickers, other times not. The MagSafe light is showing green, and the battery power indicators show "full" (a  complete line of little green lights when I press the button on the side of the machine).

Original battery and adaptor.

Two complications-

Both indicator lights are erratic. If I pull the battery out and disconnect the MagSafe, sometimes one or the other indicator will not work.

This is not the first time this has happend. For a while the battery warning in OS X was saying I needed to replace the battery, but I was still getting over an hour of battery life. Then the machine stopped turning on for a while. I opened it up and brushed out a bunch of dust off the motherboard and afterwards it turned on fine, and since then has shown battery status as healthy. However it has occasionally not turned on first time, and I've had to either disconnect from power or remove and replace battery and then turn it on again, after which it worked.

Now none of these solutions seem to work.

Do I need to get a new battery? Or is it perhaps a problem with the computer's power management? Any advice? Unfortunately in its current state I can't really run too many tests...

Thanks,

Andrew

Dispositivo:

MacBook Unibody Model A1278

Estatus:

-open
+closed

Aporte original por: Andrew ,

Título:

MacBook not starting - Battery and MagSafe lights full/green?

Texto:

Hi,

My MacBook is not starting. When I push the power button, there is no chime. Sometimes the screen briefly flickers, other times not. The MagSafe light is showing green, and the battery power indicators show "full" (a  complete line of little green lights when I press the button on the side of the machine).

Original battery and adaptor.

Two complications-

Both indicator lights are erratic. If I pull the battery out and disconnect the MagSafe, sometimes one or the other indicator will not work.

This is not the first time this has happend. For a while the battery warning in OS X was saying I needed to replace the battery, but I was still getting over an hour of battery life. Then the machine stopped turning on for a while. I opened it up and brushed out a bunch of dust off the motherboard and afterwards it turned on fine, and since then has shown battery status as healthy. However it has occasionally not turned on first time, and I've had to either disconnect from power or remove and replace battery and then turn it on again, after which it worked.

Now none of these solutions seem to work.

Do I need to get a new battery? Or is it perhaps a problem with the computer's power management? Any advice? Unfortunately in its current state I can't really run too many tests...

Thanks,

Andrew

Dispositivo:

MacBook Unibody Model A1278

Estatus:

open