Saltar al contenido principal

Introducción

El Mac Pro 2009 comparte una placa base idéntica con el modelo 2010. Con una actualización del firmware, puedes usar CPUs más nuevas y actualizar a macOS 10.12 y 10.13.

Es importante tener en cuenta que necesitarás una GPU oficial de Apple instalada al realizar la actualización, así que ve y desentierra el viejo GT120 que vino con el sistema cuando lo compraste si has actualizado a una GPU no oficial desde entonces.

Si optaste por una actualización de GPU de Apple en cualquier momento, es posible que tengas una tarjeta diferente. Esto podría incluir:

• ATI Radeon 4870

• ATI Radeon 5770

• ATI Radeon 5870

Siempre que se trate de tarjetas Apple originales, puedes continuar.

Después de realizar este proceso podrás comenzar añadiendo una RX 580, etc.

  1. Lo primero es lo primero: Debes de actualizar a macOS 10.11, que es la última versión oficial de macOS que soporta el MacPro 4,1 Teniendo al menos la versión 10.6.6, deberías de poder descargar el instalador desde la MacAppStore [http://itmss://apps.apple.com/app/os-x-el-capitan/id1147835434?ls=1&mt=12&ign-mscache=1|siguiendo este link] Si estas en la versión 10.6.5 o anterior, deberás lo primero, actualizar el software a la version de Snow Leopard (10.6.8) para tener acceso a la MacAppStore
    • Lo primero es lo primero: Debes de actualizar a macOS 10.11, que es la última versión oficial de macOS que soporta el MacPro 4,1

    • Teniendo al menos la versión 10.6.6, deberías de poder descargar el instalador desde la MacAppStore [http://itmss://apps.apple.com/app/os-x-el-capitan/id1147835434?ls=1&mt=12&ign-mscache=1|siguiendo este link]

    • Si estas en la versión 10.6.5 o anterior, deberás lo primero, actualizar el software a la version de Snow Leopard (10.6.8) para tener acceso a la MacAppStore

    • Necesitarás descargar dos paquetes distintos para completar la actualización:

    • Mac Pro EFI Update

    • Herramienta de actualización de firmware (ubicada en Netkas en el final del primer post)

    Is there another place to download the tool? I can’t seem to connect to Netkas.

    Jacob Osier - Contestar

    I had to change the above URL to that to make it work:

    https://web.archive.org/web/201901232023...

    This might work as a direct download too (from the linked forum page):

    http://forum.netkas.org/index.php?action...

    Chris

    Christian Krupa - Contestar

    Therefore thisupgrade whant happen with a different card?

    Is there a way to work around it?

    I nolonger have the original

    d1nchiana@gmx.com - Contestar

    you just need to have a card with the original EFI from Apple- there’s some other cards around, like the Radeon 4870 for example. It may work with newer “compatible” cards like those from Macvidcards.com, but I’m not sure.

    Josh Calvetti -

    I no longer have the original Apple GPU. Instead, there is an ATI Radeon HD 4870 512 MB installed in my Mac Pro 4,1 (early 2009). I do get the startup and sign-in screens as the system boots. Is it safe to try the 5,1 firmware update?

    Ronald Koontz - Contestar

    the Mac Pro EFI update is not working on my MacPro 4,1 2009.

    OSX El Capitan 10.11.6

    error:

    “This software is not supported on your system”

    Who can help me?

    Mark - Contestar

    Mark, I have the same issue “This software is not supported on your system”. You found a fix?

    john - Contestar

    Mark, just got it sorted and flashed to 5.1. You must 1. put the “MacProEFIUpdate.dmg” on your desk top. 2. Unpack the “MacProEFIUpdate.dmg” by double clicking but DO NOT RUN the “MacProEFIUpdate.pkg”, leave it open on your desktop 3. The MacProEFIUpdate.pkg will be read by the “Mac Pro 2009-2010 Firmware Tool.app” when you run that. 4. Run the “Mac Pro 2009-2010 Firmware Tool.app” and follow the instructions, easy. Good luck.

    john - Contestar

    The link to the installer in step 1 is not working.

    Can someone provide an active link!

    G Graff - Contestar

    Which installer? macOS or the utility? All the links are still working for me.

    Josh Calvetti -

    • Necesitarás desactivar el Sistema de Protección Integrado (SIP) para poder actualizar al nuevo firmware.

    • Reinicia tu Mac Pro presionando cmd+r para iniciar la particion de recuperación en tu disco de inicio.

    • Una vez en "Recovery Mode", dirígete al menú de Utilidades en la parte superior de la pantalla y haz click sobre Terminal

    • Introduce el siguiente comando:

    • csrutil disable

    • Presiona volver y reinicia tu Mac Pro como normalmente harías.

    This step only pertains to OS El Capitan and later

    bm_dong - Contestar

    What if I’m on Yosemite. Do I need to turn off SIP another way?

    roryoneders -

    Hi

    I got issue i was just trying to do this but the tool give me error

    “the program has encountered an error: 5570

    Sandip Tailor - Contestar

    I’m so grateful to have found this information, but it just doesn’t work for me. I get as far as typing csrutil disable then hitting return and I get something like ‘bad command’ or some such. I’ve tried this over and over – same every time.

    If anyone can help. I’d be most grateful. Computer specs below:

    Mac OS 10.7.5 (and desperately keen to upgrade)

    Hardware Overview:

      Model Name: Mac Pro

      Model Identifier: MacPro1,1

      Processor Name: Dual-Core Intel Xeon

      Processor Speed: 2.66 GHz

      Number of Processors: 2

      Total Number of Cores: 4

      L2 Cache (per Processor): 4 MB

      Memory: 8 GB

      Bus Speed: 1.33 GHz

      Boot ROM Version: MP11.005D.B00

      SMC Version (system): 1.7f10

      Serial Number (system): CK7220N1UPZ

      Hardware UUID: 00000000-0000-1000-8000-0017F200F892

    Nick - Contestar

    @josh is correct above that it’s a different procedure for your Mac Pro 1,1. Specifically to answer your question—if you’re still wondering, or for anyone else looking at this—System Integrity Protection was introduced in OS X 10.11 El Capitan. The csrutil command is meaningless for earlier versions, hence your “bad command” error. This can be checked without recovery mode by running csrutil status in Terminal.

    Richard Graham -

    Hi Nick,

    Based on your hardware profile, you have the very first Mac Pro, which I believe can be flashed from a 1,1 to a 2,1 - but I have not done that process myself so I am afraid I can’t speak to how it works. I believe this forum thread (also on Netkas) may have the information you need.

    Josh Calvetti - Contestar

    Please help me,

    I've got an Mac Pro 4,1 with the first os on it. So I tried to update it. But now after the Apple logo my screen turns black everytime.

    Mark - Contestar

    I have a Mac Pro 4,1 running El Capitan. I followed the instruction in Step 2 to disable SIP but at the end, when I reboot the machine, it got stuck at the boot screen (Apple logo and progress bar). The only way out is physically powering down the machine, do a NVRAM reset and only then it can reboot back to El Capitan. But the SIP is enabled again by the NVRAM reset! :-( . I tried a dozen times or so. but no joy. Advice from any one?

    Hal Nguyen - Contestar

    Running 10.11.6 on a Mac Pro (Early 2009) and cmd+r does not go into recovery mode. Any tips to disable SIP? I was able to download the two files but if I can’t disable the SIP, I don’t want to waste time moving forward. Thanks in advance!

    Tobias - Contestar

    I just ordered a new Backplane Board Mac Pro Early 2009 Not thinking about the firmware update ? Will the Mac Pro run with the 6 cores processors before I can flash the board the board to 5.1 ??? Ho gee wiz. I don’t have the old processors I bought it flashed and upgraded.

    I just hoping I might prepare everything prior to switching the board and then restart holding the power button ? Would that even work ?

    This board works Im typing on it. Its just that it had two voltage sensor that I just count fix is I decided to get a new 4.1 board cheap cheap ?

    This is a 2009 flashed Mac Pro…

    Model Name: Mac Pro

      Model Identifier: MacPro5,1

      Processor Name: 6-Core Intel Xeon

      Processor Speed: 3.33 GHz

      Number of Processors: 2

      Total Number of Cores: 12

      L2 Cache (per Core): 256 KB

      L3 Cache (per Processor): 12 MB

      Memory: 32 GB

      Boot ROM Version: 138.0.0.0.0

      SMC Version (system): 1.39f5

      SMC Version (processor tray): 1.39f5

    Marc Evo - Contestar

    I have problems installing El Capitan and tried to flash it with 10.8.5 there is no system integrity protection.. it did not work and was back at the old firmware after restart any tips here? Is a super user required? Maybe this can work on older Mac OS…?

    Dominik luedtke - Contestar

    @tobiasfunke, were you able to get into recovery mode using cmd+r? I’m having the same difficulty getting into recovery mode

    Tony - Contestar

    @tony NO. Still trying to get it done. I have 3 other drives in the bays so someone suggested to pull the other drives and leave one drive. I have not taken the time to do so thanks to work, life, family, etc.…. Alternatively, I may try to just put a new drive in and have nothing on it but the OS and then try. My issue is that I need to put my think cap on as how to do this.

    It is is very odd and I do not understand why it is so difficult. I am assuming that if I update the firmware, then switching drives back into the system will not matter as the firmware will not reset. I am a techie but not a superstar (in other words, I know enough to be dangerous and can solve matters but am not in the computer field). We will see. If you find a solution, please post and copy me!!! Good luck!!!

    I found a video on YouTube and the owner of the video was responsive and tried to help me thus the removal of the hard drives was suggested. It is here: https://youtu.be/YU8p86qHnek

    Tobias -

    • Si bien la herramienta se diseñó originalmente para extraer el firmware directamente del sitio web de Apple, un cambio en la ubicación y el nombre del archivo por parte de Apple ha hecho necesario descargar y montar el .dmg antes de ejecutar la herramienta.

    • Haz doble clic en el archivo de firmware que descargaste en el paso uno para montar la imagen del disco en tu escritorio.

    • Haz clic derecho y selecciona "Abrir" en la herramienta de actualización de firmware. Como no está firmado con el certificado adecuado, macOS probablemente se negará a abrirlo simplemente haciendo doble clic en el archivo. Haz clic derecho en el archivo y ábrelo desde el menú para solucionarlo.

    • Deberías tener dos opciones en la ventana: actualizar al firmware 2010 y degradar al firmware 2009. Solo una opción estará disponible en un momento dado, dependiendo del firmware que hayas instalado.

    • Realmente no hay ninguna razón para desactualizar al firmware 2009, ya que ninguna de esas máquinas aún está bajo garantía de Apple y los discos del sistema no son tan importantes ahora que todas las versiones del sistema operativo se ofrecen como descargas de software.

    • No es necesario que actualices tus CPUs si actualizas al firmware 2010; la configuración original del sistema continuará funcionando como siempre.

    • Asegúrate de leer toda la información que pueda aparecer de utilidad.

    • SI TIENES DIFICULTAD: intenta usar esta herramienta alternativa.

    I just tried this on my 2009 Mac Pro. Everthing seems to go according to plan. The helper utility runs, does it’s thing, then tells me to shutdown. But when I hold the power button to start back up and actually run the firmware update…. nothing happens. That is, it boots normally, no updater. I’ve held the button till if flashes, I’ve held the button till I got the tone. But no matter what, it just boots normally. This machine is running 10.9 btw.

    Any suggestions?

    John M - Contestar

    Hi John, I’m not entirely sure - there’s some good discussion in this macrumors thread that may be of assistance. Also feel free to ask a question in the answers forum here- you will likely get some good responses!

    Josh Calvetti -

    Step 2 says to run the firmware tool, but in Step 1 there are TWO firmware tools to download. Which of these do I run?? If both, which one goes first?

    david - Contestar

    Hi David,

    In the first step there is a tool for installing the firmware and the firmware itself- if you download just the .dmg on your 4,1 machine, it will refuse to install. You need the .app from Netkas, which is the second link. Download both, open the disk image from Apple, run the tool from the second download and it should auto detect the package on the desktop. Then it’s off to the races!

    Josh Calvetti -

    Gives error 5570 when running the Mac pro 2009-2010 Firmware tool. Even after performing a PRAM reset.

    Hans - Contestar

    I got the 5570 error as well, did you find a fix for this?

    david -

    @josh I got the 5570 error message when running the Firmware Update Tool. Is there a fix for this?

    david - Contestar

    Colleagues: the patched firmware tool fixed the 5570 error for me. Everything worked correctly, now I have a Mac Pro 2010! :-)

    Important: the EFI Update .dmg should be mounted on the Desktop.

    Marco Andrei Kichalowsky -

    Hi everyone,

    I did a bit of research - it seems like maybe it’s a problem with it looking for the firmware update file that happens to some people. There’s some information and directions on this page, post #964 about half way down the page from user Pigsyn. Give it a shot!

    Josh Calvetti - Contestar

    If I have a bunch of software installed and working on the machine I am about to run this firmware upgrade, will it mess up the apps that are already installed?

    spaddison - Contestar

    NOT necessary to upgrade to macOS 10.11. I’m running 10.10.5 and the firmware upgrade worked fine. See firefly416 post in level 2 of the following : https://www.reddit.com/r/osx/comments/5l...

    N. Thomas Payne - Contestar

    Just acquired a 2009 Mac Pro for free. When I tried to run the Firmware tool as instructed above, I get an error message (after a few seconds), saying “This program requires Internet access. Please connect your Mac Pro to the Internet and try again”, I HAVE internet access (even switched off WiFi and used an Ethernet cable the 3rd & 4th tries). It then quits when I click OK to that error message. Any ideas?

    amiller770 - Contestar

    Hello,

    It looks like I have no recovery disk, Then I am unable to run csrutil disable.

    How can I do ?

    Christian Guitton - Contestar

    For those who also have the 5570 error : you need to open the ‘MacproEFIupdate’ file (just Open in the background but the .pkg file not clicked) and then run the mac pro firmware tool 2009-2010 ;)

    William - Contestar

    Yay followed the above and just managed a successful firmware upgrade in my 2009 mac pro to 5,1

    chris gregory - Contestar

    • Una vez que la herramienta haya terminado su trabajo, te indicará que apagues tu ordenador. Simplemente realiza un procedimiento normal de apagado.

    • Después de apagar tu Mac Pro, mantén presionado el botón de encendido hasta que veas que el LED de encendido parpadea rápidamente o escucha un tono audible. El LED parpadeante precederá al tono.

    • Tu ordenador ahora debería comenzar a actualizar el firmware por su cuenta. Deberías ver una pantalla gris con una barra de progreso en la parte inferior de la pantalla.

    • Esta es una barra diferente de la que normalmente verías con macOS: la barra de actualización del firmware será un rectángulo redondeado hueco que se llena lentamente, en lugar de solo una barra que se alarga lentamente como normalmente verías.

    • Tu ordenador puede reiniciarse por sí solo nuevamente después del flash.

    I just can see the gray screen, there is no progress bar. Let me know the reason why! Thanx

    f22lingu - Contestar

    • Una vez que tu máquina se ha reiniciado en el escritorio, es hora del momento de la verdad.

    • Abre Acerca de este Mac y haz clic en Informe del sistema

    • Vale la pena señalar que Acerca de este Mac aún informará esto como una Mac Pro (2009), incluso después de un flash exitoso.

    • En el Informe del sistema, deberías ver una línea en la primera ventana etiquetada como Identificador del modelo - si la actualización del firmware fue exitosa, deberías ver Mac Pro5,1

    everything went as iterated; system report still shows 4,1.

    I couldn’t mount the updater by double or right clicking, so I moved it physically.

    the system will not allow me to return to reecovery mode.

    Ed Fiala - Contestar

    Everything seems to have worked for me. System report shows 5,1. However, when I launch the installer for high sierra (10.13), the window states that a firmware update is required. Any tips would be appreciated!

    Slowbie - Contestar

    • A menos que tengas una razón convincente de lo contrario, querrás volver a habilitar SIP. Una vez más, deberás ingresar al Modo de recuperación como lo hiciste antes y abrir la Terminal.

    • Escribe el siguiente comando

    • csrutil enable

    • Reinicia la máquina y deja que se cargue en el escritorio. Abre una nueva ventana de terminal y escribe el siguiente comando para verificar el estado de SIP

    • csrutil status

    • Si todo fue exitoso, deberías obtener una línea que diga:

    • Estado de protección de integridad del sistema: habilitado.

    • Y eso es todo lo que hay. Ahora deberías de poder actualizar los procesadores a una gama mucho más amplia de opciones.

    Gone through all the steps and it appears to have worked. Says finished and tells me to power off then hold power button… etc

    However it doesn’t run the flash update, just restarts in OS.

    Problem I have is different SMC for System and tray, System is 1.39F5 & processor tray is 1.39F11 and identifier at 4.1.

    Any ideas ?

    Norman - Contestar

    Bei mir hat alles geklappt, doch als ich High Sierra installieren wollte meinte das Installtionsprogramm es müsste die Firmware updaten. Kann ich das ohne Bedenken machen ohne den geflashten MacPro unbrauchbar zu machen?

    roman.franz - Contestar

    Hello, thank you Mr. Calvetti for the time you have dedicated to this guide, and I wanted to ask you a couple of questions about a strange behavior of the updater, that maybe you have already experienced and maybe you can give me an explanation.

    I follow the procedure step by step, I mount the pakage firmware, I launch the upgrade tool, it creates the ramdisc, it performs the patches, it updates the target folders, I turn off the mac, I turn it on again following the procedure, the led blinks, the tone is heard, it performs the particular boot, the update procedure starts, but it immediately performs a reboot, and does not perform any update, can you give me some suggestions.

    Thank you in advance

    alex andrei - Contestar

    Hi, I followed the Steps but when I reboot and hold down the power button after blinking light. the computer flashes the firmware update screen for a second and then reboots with normal start up. The firmware never get updated.

    What am I doing wrong ?

    Alex Hernandez - Contestar

Linea de Meta

125 personas más completaron esta guía.

Un agradecimiento especial a estos traductores:

en es

100%

Estos traductores nos están ayudando a reparar el mundo! ¿Quieres contribuir?
Empezar a traducir ›

Josh Calvetti

Miembro Desde 04/12/09

8,684 Reputación

2 Guías creadas

93 comentarios

once installed the firmware 5.1 can be updated in the installation of the new OS?

infoalessio100 - Contestar

Do you mean to update to 10.13? Yes, you can do that firmware update as well. It should work automatically.

Josh Calvetti -

Can you use a processor tray designed for a 2010-2012 model after the firmware update? Not inclined to actually replace the CPU chips.

BradMacPro - Contestar

I’ve heard conflicting reports- at the very least, if it does boot with a 2010 tray, my understanding is the fans will go crazy. I don’t think it’s recommended to swap trays between versions as they have a slightly different firmware and construction. Replacing the chips is pretty easy though, and we have a guide for that as well!

Josh Calvetti -

Fans go crazy, There are two SMC chips on MacPro. One of them is on the backplate and the other one is on the cpu tray. In order to run MacPro smoothly, SMC chips needs to be synced upon boot. If they can not sync then the fans go crazy. You need to swap the TC4424P SMC chip on the 2009 cpu tray with the TC4424P SMC chip on the 2010-2012 cpu tray. This job needs top soldering skills!!. If you manage to do that then the SMC chips will be in sync and the MacPro will run smoothly. I did it with my 2009 MacPro 4.1 with 2009 4 core cpu and upgraded it to a 2009 MacPro 5.1 with 2012 12 core cpu. Also after the job done, I soldered remaining SMC from the 2012 cpu tray to my 2009 cpu tray with no SMC on it. After that it was a perfectly working 2012 cpu tray. Gave the tray to a friend who needs a 2012 cpu tray for his 2012 MacPro. He still uses that and I still use mine. You just need to find someone with top soldering skills if you don’t have any.

Anil -

What restrictions are there if you no longer have an original Apple GPU? My MacPro has an ATI Radeon HD 4870 512 MB to drive my 30” Apple monitor.

Ronald Koontz - Contestar

We’re in a similar boat: I’ve got a Radeon HD 5770, purchased from Apple, driving a 30-inch Cinema Display. I got through both BIOS upgrades fine. Perhaps display adapters with non-Apple firmware cause problems.

Tom Yager -

A quick note that might save someone trouble: Following these well-crafted instructions, my Mac Pro kept booting to my OS (10.11) instead of the firmware updater. Starting over from a Lion (10.7) startup partition worked, and then I was able to return to 10.11 to do an in-place upgrade to High Sierra from the App Store. The second firmware update from the OS installer ran without issue.

Tom Yager -

Hi Ron, thanks for the info! You should still be okay with upgrading if your GPU is one of the upgrade picks Apple offered. I have amended the introduction to reflect this as well.

If memory serves, there were 3 other GPUs Apple offered as upgrades for the 09/10 model Mac Pro. These are the

• ATI Radeon 4870

• Radeon 5770

• Radeon 5870

Provided they’re all still official Apple cards, you should be okay to proceed.

Josh Calvetti -

It is safe to upgrade my MacPro4,1 with an NVIDIA GeForce GTX 680? Thanks.

suzzz -

You have a 4870 that doesn't have the Apple EFI? If it is a reference model card, it can be pretty easily flashed with Mac EFI (Apple boot screen). I have flashed these for 4 of my friends with good success.

Benjamin Dittman -

It is because if you have a non mac gpu as your primary card none of the mac os startup screen will be displayed. You would have no idea what the mac was doing while the firmware was installing (if it even was) and just have to sit looking at a black screen and hope that it completed correctly.

hpesoj11 - Contestar

Is it safe to swap back in a non-Apple GPU once FW update is complete?

anonymous 5344 - Contestar

Yep, you can swap back to the non-Apple GPU after the update is complete.

Josh Calvetti -

Awesome! Now I can install High Sierra and hopefully Mojave later this year.

Thanks!

Milan Meiland - Contestar

I followed the instructions. I have an early 2009 MacPro 4,1 firmware. the Mac Pro 2009-2010 Firmware Tool.app would not open from the desktop of from the drop down menu. Prompt stated that the “…Fiirmware Tool.app could not be opened because it is from an unidentified developer.” Any suggestions on how to overcome this?

Kenneth J. Filarski

Kenneth J. Filarski - Contestar

Hi Kenneth,

Sounds like that’s Gatekeeper at work. If you right click on the application and click open in that menu, it should give you an option to proceed when that dialog box pops up.

Josh Calvetti -

Thank you so much for this amazing guide. Followed it exactly and had no problems upgrading the firmware of my Mac Pro 4,1 to 5,1. Now I can happily update my OS past El Capitan 10.11….

anonymous 5344 - Contestar

i am having problems doing this my Mac is a 4,1 and when i download to update tool and software to do the update i keep getting an error saying the software is not compatable or something like that i followed everything and it don’t work for me here is the specs on my mac early 2009

Processor 2x2.26 GHZ Quad-Core intel Xenon Serial Number is H0014TB4PD any help would be great thanks

Shiva Parasram - Contestar

I completed the firmware upgrade successfully. Then installed High Sierra successfully. Now my AirPort card is not recognized!

I had installed a AP card I had laying around from another Mac laptop (I think) that I had scrapped. So, I think that since the High Sierra software is assuming that this is a 2010 Mac Pro that it would also only have the AP card that came with the 2010 models.

My theory is that it will need a newer AP card than what I have. I’m honestly not sure what year my current AP card is from. Is anyone else having this problem or figured out a solution. If not, I will probably try ordering a newer AP card to stick in it or run an ethernet cable to it.

Daniel - Contestar

Hi- my mac pro died in the middle of the “flashing” section. Won’t turn on and I get 0 power to the unit whatsoever…Could it be a dead power supply or the motherboard? I’m worried…

m.zayas89 - Contestar

Danke für diese tolle ANleitung, hat prima funktioniert!! Hj

Hj Widmer - Contestar

I did this and it worked perfectly except I now have no sound. Any ideas?

The Zig - Contestar

So I’ve already updated my early 2009 Mac Pro running El Capitan to Mojave using a patch tool before I found this site and instructions. Put a new videocard in and – with the exception of not being able to use my second monitor for some reason (next fix to search) – is running beautifully. Curious if I would still be able to update the firmware to 5, 1 from 4, 1 even though Mojave is already installed and running? Wish I had found this earlier - would have saved time! Thank you in advance for your response.

Stu - Contestar

Hi @stu,

Hmm, I assume that’s dosdude’s patch tool? I’m not entirely sure though, I haven’t heard of anyone going to Mojave without flashing first. I’m not 100% sure if you can flash, but you should be able to in theory at least. The tricky bit is you’ll need the original GPU still installed to do the flash.

What firmware is your mac on at present? You can find it in System Information under the hardware overview- it’s labeled Boot ROM Version.

Josh Calvetti - Contestar

Hi Josh! It was dosdude’s patch tool that was used to install Mojave without flashing. Everything is running smoothly since installing a new video card - Radeon RX 570 - and even figured out the issue as to why the monitors were not working when using a displayport cable. Exactly what I was thinking, that in theory it should work and there’s no reason it should not but I have not found anyone who has attempted this.

I still have my original GPU which was an upgrade via Apple. It’s an ATI Radeon HD 4870. Trying to do as much research as possible before contemplating the firmware upgrade. I use this computer quite a bit for work so don’t want to end up with a very large cheese grater that does nothing.

My Boot ROM version is MP41.0081.B07. Thanks for responding and any insight/advice is welcome and much appreciated! Happy Friday!

Stu -

ive tried it over 10 times. but nothing’s changed…. ㅜㅜ i have G120 but wired original apple keyboard. Do i need original apple keyboard to succeed this procedure?!?!?!??! thanx.

f22lingu - Contestar

Anyone know if the AMD Radeon HD 7950 is compatible with this approach?

chris - Contestar

I have the same problem as mented before, I followed the instructions. I have an early 2009 MacPro. Firmware Tool.app would not open from the desktop of from the drop down menu. Prompt stated that the “…Fiirmware Tool.app could not be opened because it is from an unidentified developer.” Any suggestions on how to overcome this? Rightclick does the same,: refuse to open

Jan Schoen - Contestar

This worked for me on El Capitan:

1, Apple Menu > System Preferences > Security & Privacy >

2. under “Allow apps downloaded from:” select “Anywhere” (**you may need to click the lock at the bottom left and enter your admin password to change these settings**)

3. at the prompt, click “Allow From Anywhere” to confirm your choice

The application should open now without much resistance. I made sure to change this setting back after I was done doing what I needed to do.

USDA Certified Lean -

A couple years ago I bought what I thought was a 2012 5,1 machine, but it’s apparently a flashed 2009 model (About this Mac says mid 2009, and system information lists the Model Identifier as MacPro5,1, Boot ROM MP51.007F.B03). The machine will not upgrade past OS 10.10, or at least the App Store won’t serve me the upgrade files). I’m wondering if there’s any benefit to trying this procedure. Any other suggestions?

Thanks in advance

David - Contestar

Ihr seid die Besten!!!

Apple würde ohne euch nur halb soviel Spaß machen.

Alex - Contestar

I have a PCI-E card for Apogee audio that worked before and now doesn’t. Also noticed that 2 of the ram slots stopped working.? do I need to go back, remove the cards, re upgrade, then put back everything,, also a 5 terabyte drive won’t reinitialize? Thanks

Scot Reynolds - Contestar

I’m having an issue that I don’t see mentioned. I have an ‘09 I’ve tried this process several times and it doesn’t seems to want to work. I downloaded the EFI update and the firmware tool. I have followed all the instructions every time but I still have a 4,1 computer. I get to the restart after the blinking power light and tone. It seems like the grey screen flashes for just a second but then stops then restarts and when the computer is back on fully it’s still a 4,1. Anyone have an ideas?

Tyler Hoover - Contestar

Okay so I got no answers but I ended up figuring out myself. I realized that my computer needed the 1.4 EFI update before it could get the 1.5 EFI update provided here for the tool to work and everything to switch over to the 5,1

Tyler Hoover -

I’ve upgraded. Few important things.

1) It must be latest EFI 1.4 on Mac Pro 4.1. Was 1.3. Have to upgrade first.

2) Literaly no cards (PCI) and devices other than Apple common. USB 3.0 card from Unitek forced upgrade to fail. Unmounted, no problem.

3) After procedure have to reset PRAM (cmd+alt+P+R on restart). Without this 1333 MHz RAM modules are recognized as 1066 MHz

woody - Contestar

if you have third party memory (i have 3x16GB 1066 DIMMs from OWC) will this still work?

steven.shaefer -

Excellent work! I read through other instructions for upgrading the firmware, none were anywhere near this good. Thank you!

Derek R Orrell - Contestar

Thanks for the Tutorial. 2 Things:

You MUST update to El Capitan, else you don’t get csrutil!

Second: i had my user on a second hard disk mounted as /Users/myuser. That won’t work too. You need a User Account on the main / OS HD.

j.weber - Contestar

I use a NVIDIA GeForce GTX 680 2048 MB, I understand that with this GPU i wont be able to upgrade the firmware of my mac pro 4.1 that was upgraded to 5.1, right now my SMC Version is the 1.39f5 that don’t allow me to install high sierra.

I have a old Apple ATI Radeon HD 2600 XT, can I use this GPU to upgrade my firmware?

izidrew - Contestar

Great job Bro. I have the video card: Quadro 4000 2GB GDDR5 for mac. Can I upgrade my Mac Pro 4.1 to 5.1???? Will the video card work after installing the Sierra or High Sierra? Thanks

DinDin na Net - Contestar

I just completed the firmware upgrade from 4,1 to 5,1 can I upgrade to a higher OS than 10.11.6?

Are there other firmware upgrades that my MacPro early 2009 3.33MHz can successfully do?

Tyrone Blair - Contestar

Hallo!

Ich habe ein Mac Pro 5.1 2,8 Ghz

Aty 5770 und Nvidia GTX 660.

Als ich Mojave installieren wollte, hatte ich ein Firmware Update gemacht. Statt 140.0.0, steht dort noch immer 138.0.0. Wie komme ich auf 140.0.0?

music-production - Contestar

hi there please guys a little help here. i have that mac pro 2009 with original graphics card and every thing running os x 10.6.0 (snow leopard)

i have tried almost all the youtube tutorials on how to upgrade and flash firmware 4.1 to 5.1 but so far its been impossible.

one thing i have not been able to do on this mac is disable ISP, i have tried all the commands that may take me to the utility boot up screen by pressing command R and other combinations but nothing.

Then i heard a guy on YT that says before os x el capitan you dont need to do this, but i have a feeling he is wrong. still tried that way but nothing.

other guy said the command R combination on 10.6.0 is differerent back then if you want to get into the utility window up on boot up!, but could not fine a command combination before 10.6.0 to bring the utility window.

PLEASE I NEED TO DISABLE ISP BUT CANT HELPPPPP!!!!!!! .

I WILL really appreciate any help or ideas guys thank you very much. from London

Frank - Contestar

Hi Frank,

The guy on YouTube is correct, System Integrity Protection (SIP) was a feature introduced in 2015 with El Capitan (v 10.11). I don’t remember exactly when the recovery partition came into existence, but I know that 10.6 definitely does not have it. What I would recommend is upgrading via Software Update to 10.6.8, and then once you have access the Mac App Store you should be able to get the last “supported” version of macOS, which would be El Capitan. [http://Get El Capitan|This link here] should let you download it from the Mac App Store.

Once you have El Capitan installed you should be able to follow the tutorial.

Josh Calvetti -

thank you #Josh Calvetti i will try your suggestion will try to download El capitan via software update ( i hOpe its still available for download , if not i will have to find it somewhere else ) and i guess once i install it, recovery partition will come into existence allowing me to disable ISP , fingers crossed cheers.

Frank -

Hi Josh

I’ve read that the firmware upgrade can’t be done in El Capitan, and that the os needs to be dropped to a previous version. Is that the case? If so , why is that?

Mahombi

Terry Lott - Contestar

No, it can definitely be done in El Capitan - that’s how I’ve done it a few times now. You just have to disable SIP with El Capitan, but the directions for that are in the first few steps. Hope it helps!

Josh Calvetti -

hi terry, I have seen a guy on YT do the firmware upgrade on Yosemite beacuse he could not do it on El capitan he said and worked ( will pass u the link should i find it ) i guess you should give it a go and see what happends, you have nothing to lose. ( Am not saying Josh is wrong by any means )

Now I have hit another wall, if u guys can help me…. am upgrading to El capitan from snow leopard to disable ISP to then again upgrade to sierra o mojave but when am installing el capitan i get a message saying ( THIS INSTALL COPY OF EL CAPITAN CANT BE VERIFIED, IT MAY BE CORRUPTED OR TAMPARED WITH DURING DOWNLOAD) . I HAVE DOWNloaded El capitan from www.appledollars.com and did a bootable usb drive TO load from but keep getting that message! HELPPPPP

Frank -

hello guys : is it possible to clone my SSD running on el capitan on a macbook pro mid 2010 13 inch to install it on my 2009 mac pro 4,1 ??? the reason is that i would like to upgrade my graphics card , processor and ram???? instead of going hitting a wall every time i try to do it manually like in this tuttorial which i cant ( something always goes wrong and not able to install ) and then throw in the compatible components i have just mention thank you !!!!!

Frank - Contestar

You should be able to clone that, yeah. I’ve done it going the opposite way before with no real issues.

Josh Calvetti -

I just recently bought 128GB of DDR3 ECC 1066 MHz RAM, if I update the firmware to 5.1 will I have any issue with the RAM? Also, if I update the CPU will I be able to still use the RAM?

eeanwei - Contestar

Confused: I Flashed Mac Pro (Early 2009) 4,1 and looked successful, upgraded to High Sierra 10.13.6, but System Report Hardware Overview still shows as 4,1 instead of 5,1. And I am running High Sierra 10.13.6 successfully. How is this possible?

David W. 8/23/2019

dwalker - Contestar

Hi, thank you so much for these simple instructions. They allowed me to upgrade to high Sierra and possibly squeeze another few years from my Mac Pro!

Kristian Simsarian - Contestar

The link to the netkas forum was dead for me. The alternate tool at GitHub worked great though!

Braden Smith - Contestar

Great write-up!

Can this method be adapted for use on a 2008 Macbook Pro 4.1?

USDA Certified Lean - Contestar

Hi there! Unfortunately, no- this is limited just to the Mac Pro, which has a very different architecture.

Josh Calvetti -

Hi everybody! I've installed dosdude patched High Sierra in my Mac Pro 4.1 (Early 2009), Logic Pro and many plugins with libraries installed in a secondary HDD. Now I would upgrade to firmware 5.1 and install new cpu to add cores to my machine. Two options:

1. new HDD with El Captain to run Firmware Upgrade tool and update at 5.1. Then a fresh install with a big work to reinstall system and all plugins !

2. After the firmware update with El Captain (installed in a EFI partition of HDD), can I restore my Time Machine backup with the dosdude High Sierra and then uninstall the dosdude patch with uninstall tool? Can this patched High Sierra recognize and run the new firmware to install new cpu?

Any advice... is welcome ! Thank you for support !

ghiglino.luca - Contestar

Hi I got my MacPro updated from 4,1 to 5,1 successfully. Can I upgrade to Mojave or High Sierra now before adding a new CPU processor? I also bought a MSI Radeon RX560 video card. I have a MacPro 2009 Quad Core 3.33Ghz Intel XEON 32 GB 1066 MHz DDR3 ECC Graphics: NVIDIA GeForce GT 120 512 MB, ITB SSD OWC Mercury EXTREME Pro 6G SSD.

Tyrone Blair - Contestar

I am missing something with these instructions. After disabling SIP it request in STEP 3 that you run the Firmware tool and I presume that this is is the Firmware UpdateTool that you downloaded. What about the MacPro EFI update, what happens with this since there appears to be no mention of it in these instructions?

David Evans - Contestar

I did this years ago. Now have a dead logic (mother) board (for sure) and can’t find the Netkas firmware update etc to redo replacement 4.1 logic board and get back to 5.1. Have maxed out 5.1 tray in for dual processors etc. Please, any help

James Veenstra - Contestar

Need help please. Did this upgrade years ago for Mac Pro 4.1 to 5.1 and upgraded the tray (memory and processors) to be compatible with 5.1. Now logic board (Mother board) for sure. Can’t find the resources to do all for replacement logic board. Do have “twin” Mac Pro working yet for downloads etc. Netkas site won’t open anymore. Any help would be greatly appreciated.

James Veenstra - Contestar

Hi and thanks for the tutorial!

As someone who is not experienced at all, I have to ask about the Apple GPUs. I don’t have the original graphics card available, installed is a NVIDIA Quadro FX4800 for Mac. Alternatively I have a ATI Radeon HD3870 from an old 3,1 available.

Would those cards be working as well or should I try to get my hands on a GT120 or one of the newer Radeon models mentioned in the article?

Thanks again!

Rob Mp - Contestar

Many thanks for this tutorial ;)

I just upgraded my early 2009 MacPro and this worked flawlessly.

One note for the wireless keyboard users out there with problems entering recovery - just wait until you see the grey screen after the startup chime, count to 3 and then press CMD(Win on Windows keyboards)+R.

I found out there is a delay for USB keyboard activation while using a wired keyboard with background lightning. As soon as the light turned on, I could press the keys and they got recognized. Then I used the same delay with a wireless usb keyboard and - tadaa - it worked like a charm.

Peter Klein - Contestar

Hello, the update was execute perfectly.

I have tried to download mac osx high sierra, and if I try to lunch it , advise me that a firmware upgrade will be necessary..

Anyone have tried to upgrade the 2009 mac pro series to other higher osx ?

thank you.

Giuseppe Setteducati Jasango - Contestar

Hello, I have successfully done the firmware update, but a system update does not want to succeed. When I want to start the installation file 10.13.2, I get the hint: "This update requires macOS 10.13." An installation file "10.13.0" is not available in the App Store. 10.13.2 is the oldest version of High Sierra. What to do?

Jürgen Salzmann - Contestar

Addendum: My operating system is 10.11.6. my processor is a 2.93 GHz Quad-Core Intel Xeon Early 2009.

Jürgen Salzmann - Contestar

Just thank you for the excellent detail information that made my life so easy . truly appreciate.

Demetrios Vavvas - Contestar

It seems to be that is working after everything failed. Good work. thanks

Sergio Nery - Contestar

Hi Josh

Under OSX 10.11.6

When I launch the program I get this message:

This program requires internet access. Please connect your Mac Pro to the internet and try again.

While I am well connected to the internet!

So I can't click on "Upgrade to 2010 Firmware".

Do you have an idea?

Thank you

Eric Bene - Contestar

This totally worked, really appreciate all of this info! Only thing I had to do was update my Blackmagic desktop video after I installed 10.13.6, everything else is dialed in. Will recommend this page to any friends looking to upgrade their 4,1 machines..

steven.shaefer - Contestar

Did all this, added 3.06 6 core processor, now messages and FaceTime don’t work, more does the App Store download anything…

John Faitakes - Contestar

Hi all,

I have successfully updated the Firmware of my 2009 Mac Pro from 4,1 to 5,1 using the step-by-step instructions above.

After enabling csrutil I rebooted my Mac and found all email passwords gone as well as access to my iCloud account.

This was unexpected. I could restore access to my email accounts, but now I would like t know:

- has anyone out there seen this happen too ?

- should I be worried by the deleting of my Mail accounts passwords in this process ?

- if this can happen, should a warning this is possible be necessary

MacRuud - Contestar

I have an ESATA card installed. I read that I need to remove that prior to upgrading. True?

Shaun Kennedy - Contestar

Hi… great tutorial… thanks!! I’ve got an early 2009 quad core 2.66 running El Cap. Original GPU, CPU, etc. .. I’ve only upgraded to 20 gigs of ram. I’ve disabled SIP, mounted the dmg and ran the tool. I constantly get the dreaded 5530 error. I’ve reset PRAM (NVRAM), and SMC… still get the error. Help!!!! I also tried ejecting my back up interval 1TB disc. Everything is pretty much stock. Not sure what else to do!

Chuck

Charles Bumcrot - Contestar

Herzlichen Dank, Firmware Update war in 5 Minuten erledigt!!!! :))

roman.franz - Contestar

I can’t go to recovery mode on 4.1 Mac Pro tower 2009, it has os Sierra on it, and it will boot normally after holding option plus R after restart need help

michael niedzwiadek - Contestar

hello there is no sleep mode after installing Mojave , please help why? I am tired of turning it off every time

Michael Niedzwiadek - Contestar

I tried all google search but could not find answer why after trying to put Mac to sleep that function does not work need help really appreciated

Michael Niedzwiadek - Contestar

2009 Nehalem Mac Pro users, know this! (comment 1)

This upgrade to 5,1 model firmware causes an audio playback problem that involves Line Out. (other outputs not tested but likely the same)

For those like myself that are recording studios that record directly to uncompressed audio files (AIFF) as do most studios, the playback on a 2009 Mac Pro is failed with a twist.

The twist is… all plays back perfectly until you go past Mojave 10.14.3.

Mojave 10.14.4 and above including Catalina patches all fail to “properly” playback AIFF files.

Perhaps a simple statement helps more, if you buy a standard factory CD (not mp3) at Walmart and try to play it on your firmware modified 2009 Mac Pro running the latest version of Mojave, it will “sound like” a dirty cd, a failing optical drive or some other typical problem, it’s not typical at all and nothing is wrong.

ALL…. AIFF files tested fail to play back properly with Quick View, Quicktime 7 Pro, iTunes, Apple DVD Player, and Quicktime 10 although QT10 is 99% useable.

Robert Boyle - Contestar

2009 Nehalem Mac Pro users, know this! (comment 2)

It sounds like a disk skip even if the AIFF file is on a drive.

Before the arguments begin… this has been verified on two entirely separate different 2009 Macs with “every possible” means of verification available.

It is 100% verified, the problem is the firmware.

Just to make certain, a “beyond extensive test” was also performed.

A version of Mojave 10.14.6 on a HFS+/GUID drive was created and booted on a totally unmodified 2009 Mac Pro. (works very well by the way)

Both 2010 and 2012 Mac Pro were also tested using the HFS+/GUID Mojave drive.

Those Mac Pros with no firmware modifications played back AIFF files without flaw.

Then…. 2010 and 2012 and 2013 Mac Pros were tested also without firmware modification, (because they don’t need any), and had no trouble with AIFF file playback using any version of Mojave on APFS drives. (still waiting to test Catalina and Big Sur)

Robert Boyle - Contestar

2009 Nehalem Mac Pro users, know this! (comment 3)

Nobody noticed this because most people do not own recording studios and all their music is bandwidth limited compressed garbage, and very few use or buy CD’s anymore.

Bottom line, 2009 Mac Pros using the updated 2010 firmware will have uncompressed audio file (AIFF) playback problems if using anything past Mojave 10.14.3. (read that again and let it sink in)

Compressed audio files play back just fine.

The only solution to this problem is to update to Mojave using the firmware modifications, then create an HFS+ GUID version of Mojave, then return the firmware back to 2009 / 4,1 and run the HFs+/GUID Mojave drive. (NOTE: Software Update will not update a HFS+/GUID version of Mojave)

PS

Knowledge of Mojave requirements is assumed.

I tried dosdude Mojave legacy audio patches but did not test dosdude full Mojave patched installs because those require that firmware not be modified.

Robert Boyle - Contestar

Please Help! part 1

I ‘ve a Mac Pro 2009 4,1 dual processor, upgraded to 5,1 and got two x5680, I’ve done everything by the book and a clean reinstall of High Sierra. Problem is both processors - mac will start but I get nothing, no chime, no signal, only fans, one processor in CPU A machine will start and fan fans will go full blast. Diag led lights, all good, no blinking, no red.

I ‘ve tried (I think) everything possible, reinstalled both old processors and same thing, two processors i get nothing, one processor fans full blast but the rest ok. I have tried pram, smc, nvram and all resets. I have taken the whole mac apart, cleaned it, checked for damaged chips, components and such, and still nothing. I think it is a processor board/socket issue but i want to make sure before I spend money on that.

Jorge - Contestar

Superb. Now I have High Sierra.

versatile.ico - Contestar

Firmware von 2009 Mac Pro Anfang 2009 4,1 auf 5.1

Hi, ich habe Schwierigkeiten, das update zu machen. Ich habe den Mac Pro mit cmd+r so gestartet wie beschrieben und im Terminal csrutil disable eingegeben. Dann neu gestartet. Dann bauten sich alle Grafiken langsam auf. Also in irgend einem Modus war ich. Ich startete den Firmwareupdater. Nach ein paar Sekunden kam die Fehlermeldung 5570.

Dann öffnete ich wiederrum das Terminal, um zu sehen, ob wirklich SIP deaktiviert ist. Mit csrutil status bekam ich enable. Ich nehme an, wenn SIP wirklich deaktiviert gewesen wäre, würde dort disabled stehen.

Ich vermute, dies ist das Problem, dass ich beim Firmwareupdate immer diese Fehlermeldung bekomme.

Grafikkarte habe ich auch die alte eingebaut: ATI Radeon 4870

Speicher sind 128 GB drin. Das sollte ja vermutlich keine Rolle spielen. Als Festplatte habe ich 4 x 1TB SSDs im Raid0, um 4k Videos zu schneiden.

Hatte jemand das gleiche Problem und kann mir helfen, wie ich das Firmupdate machen kann?

Beste Dank, Andreas

Andreas K - Contestar

Hi, I followed the Steps but when I reboot and hold down the power button after blinking light. the computer flashes the firmware update screen for a second and then reboots with normal start up. The firmware never get updated.

What am I doing wrong ?

Alex Hernandez - Contestar

When do you use the Mac Pro EFI Update ?

Steve wallace - Contestar

Will this work for a MacBook Pro 5,3 Mid 2009? Im stuck on El Capitan and things are starting to not be supported.

Shake - Contestar

Will this work on this computer, or do you have a way of upgrading firmware for this computer please ? Things are getting out dated fast please help.

MacBook Pro (15-inch, Mid 2009)

Model Name: MacBook Pro

  Model Identifier: MacBookPro5,3

  Processor Name: Intel Core 2 Duo

  Processor Speed: 2.8 GHz

  Number of Processors: 1

  Total Number of Cores: 2

  L2 Cache: 6 MB

  Memory: 8 GB

  Bus Speed: 1.07 GHz

  Boot ROM Version: MBP53.00AC.B03

  SMC Version (system): 1.48f2

  Serial Number (system): W894417B64C

Shake - Contestar

@figone1995 Nope, sorry- this is only for the towers, as they have a very different architecture than the laptops.

Josh Calvetti -

Maybe are you doing a confusion between upgrading hardware firmware and upgrading operating system.

Like explained earlier, MacBook Pro 15” Mid 2009 is a laptop, while Mac Pro 2009 is a tower Mac.

OS X 10.11.6 El Capitan is the latest OS X supported on this model officially.

You have 2 solutions :

- Purchase a new Mac, or

- Install a patched system for an unsupported Mac, if you have an adventurer. ;-)

A large enthusiasts community developed patchers for many OS X versions past El Capitan.

But the best range of unsupported system patcher affordable for your MacBook Pro model is from 10.12 Sierra to 10.14 Mojave.

Search for "unsupported Mac patchers" with your favorite search engine.

Last advice: do your first install trials on an external drive in order to learn how it works, An 16GB USB thumb drive is required to create the installer patcher, whatever the system chosen.

Good luck, if you choose the follow the adventure track. Do it at your own risk…

RamOS28 -

Thanks man I really appreciate you shedding some light on this situation for me

Shake - Contestar

I just tried both upgrade tools and neither one of them worked because I'm still at 4,1. What could I be doing wrong and what do I do next?

Luigi Provencher - Contestar

Agregar Comentario

Ver Estadísticas:

Ultimas 24 horas: 93

Ultimos 7 días: 562

Ultimos 30 días: 2,187

Todo El Tiempo: 211,209