Repair guides and support for cars and trucks by Toyota Motor Corporation.

Preguntas 493 Ver todo

1994 Toyota PU speedometer not working

i changed the part on the transmission, took the dash off checked the speedometer, looks ok but speedometer still not working,

1994 Toyota pic-up

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 1

Comentarios:

Which Toyota P.U. is it? What engine size and what transmission do you have?

por

This question was migrated from http://meta.ifixit.com/Answers.

por

speedometer cable not working

por

oscar figueroa, give us more information if you need help. what vehicle? What engine size, what transmission? what have you tried so far? The more information you can give us the better of an answer you can expect. A one sentence question will get you most likely no answer at all.

por

I have same problem and i m sure the problem is the cluster speedometer. Do any one know what is the common fault or from where i could buy one

por

Mostrar 2 comentarios más

Agregar un comentario

2 Respuestas

Solución Elegida

RUDY, the part in your transmission was hopefully the Vehicle speed sensor. From what I understand, most of the failure on the Toyota's is actually the instrument cluster itself. Do go ahead and check your connector. That way at lest you know that the sensor and the harness are okay.\:" INSPECT VEHICLE SPEED SENSOR

(a) Connect the positive (+) lead from battery to terminal 1 and

negative (–) lead to terminal 2.

(b) Connect the positive (+) lead from tester to terminal 3 and

negative (–) lead to terminal 2.

(c) Revolve shaft.

(d) Check that there is voltage change from approx. 0 V to 11 V

or more between terminal 3 and 2.

HINT: The voltage change should be 4 times per each revolution

of the speed sensor shaft.

Block Image

If operation is not as specified, replace the sensor.

If that should check out, you know it is not the sensor. then go ahead and check the connector to your instrument cluster

Block Image

or the harness, you can check the instrument cluster using the wiring diagram.

Block Image

If all those points check out okay, I definitely would repair or replace the instrument cluster. Hope this helps, good luck

Fue útil esta respuesta?

Calificación 2
Agregar un comentario

I am having the same issue, accept my temperature gauge isn’t working also. I replaced the temp senso and tested the connectors. That all checked out, so I replaced the cluster and the same two gauges still don’t work. Any ideas?

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

RUDY estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 26

Últimos 7 Días: 206

Últimos 30 Días: 956

Todo El Tiempo: 22,964