MacBook Pro won't stay on. Turns itself on and off

I recently had an issue where I was getting no response when using the power button. Not even a fan moved. This happened because I was stupidly using a shorted charger. The charger has since been fixed. I concluded that it was my logic board, so I ordered one from eBay. It is apparently in "perfect working condition".

After installing the new board, as soon as I plugged my laptop in to power, the computer turned itself on. I was all excited that it was working, then it powered off. Then about 3 seconds later it powered itself on again, then off. The only way to break the cycle was to pull the battery or the power cable. I figured it may be the video chip problem that is common with this model, but I am able to get to the screen with the question mark folder (hard drive unplugged), so doesn't that mean that the video is fine?

Well then I tried resetting the PRAM. This made it so that the computer was able to power on long enough for the back lights to come on and so did the gray screen, except there was no apple logo. The hard drive I was using has Windows and Linux on it and it skipped the Apple logo and wend directly to the Windows loading screen right before shutting down again. It's like every few tries, I am able to boot at least until I see the Windows or apple logo, but most of the time it shuts down within a second. I have a higher success rate keeping it on for longer when the hard drive or CD drive or both are unplugged, or when certain key combos are held, such as the PRAM reset. The computer doesn't actually restart like it is supposed to with the PRAM reset, though.

If I'm able to get it booted and I plug in a USB hard drive, it instantly dies. Without the battery installed and the power plugged in, I get absolutely no response. The magsafe light stays either green or very dim green with the battery installed and the charger plugged in. The battery's built-in battery life gauge seems to be stuck at 3 dots out of 5. The battery has not been charged for a couple months so I believe this may be innacurate. This still does not explain why the battery must be installed to get a response when I press the power button. Could this possibly be a result of a bad I/O board? I hope this made sense. I seem to be having issues with wording sentences at the moment. Thanks everyone

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 1

Comentarios:

Does anybody have any input? I just swapped out the PRAM battery and I'm still having the same problems. When I do get it to boot, it shuts down as soon as it starts loading the OS. Can a bad I/O board cause these symptoms? It's almost like it's not getting the power it needs when it needs it.

por

Agregar un comentario

1 Respuesta

did you try to reset SMC ? https://support.apple.com/en-us/HT201295

Also try booting with "shift" key pressed (boots without extensions i.e safe mode).

Fue útil esta respuesta?

Calificación 0

Comentarios:

could also be the internal SATA cabel, in a way shorting the machine.

por

you could test the "SATA cabel fault" by removing the HD and the SATA cabel inside the computer and then try to boot it from an external drive (even your original drive, if you have a USB to SATA converter) sorry for "spewing" a lot of different theories out here :-) just thought you would like som input.

por

Thank you but I've already tried resetting the SMC and the PRAM. I've also tried unplugging the SATA devices and booting from a usb 2.0 SATA adapter. Nothing I did really changed anything. I even baked the logic board in the oven as a last resort and it's still doing the same exact thing. Only thing I haven't tried yet is disconnecting the display, but booting to an external monitor yielded the same result. The strangest thing is how I'm getting the gray screen but with no apple logo. Then it proceeds to try booting to Windows even though both OS's are installed on both drives I tried. Most of the time though, it just dies after a second or two. There is another replacement logic board on the way from the ebay seller. I will update with results when the time comes.

por

did you try to completely remove the internal sata cabel ? i had machine once and the sata cabel was shorted so even when I tried to boot from external drive, it couldn't before I removes the cabel.

por

Bump bump bump

por

Agregar un comentario

Añadir tu respuesta

nmckay420 estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 10

Últimos 7 Días: 50

Últimos 30 Días: 250

Todo El Tiempo: 899