Why does my MacBook Pro (early 08 or late 07) have the black screen?

I have a Macbook Pro 15" non unibody (either late 07 or early 08) and it was working just fine, I had closed it and when I returned (about 2 mins later) I connected the charger and when I opened it, it no longer showed anything on screen. I thought the light was dim, so i tried to raise the brightness but nothing happened. I shut it down through the power button and when it booted the same thing happened - a black screen. I have done research on this topic and found a couple things.

-It could possibly be stuck in "clamshell mode"

-Possibly stuck in sleep mode

The fix for this is to reset the SMC and PRAM by pressing and holding a combination of keys on boot up. However, the keyboard doesnt work (caps lock light doesnt light up) only the power button works. The treackpad and button dont work either, and I had a mouse connected which also doesnt work because it doesnt get power. When I connect it the light at the bottom of the mouse lights up for a split second then turns off.

I dont think its the screen and have read that it may be the

-logic board or

-the graphic chip?

Is there any way to fix this?

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 1

Comentarios:

Are you getting a POST tone (the ding) when you try to start up? Do you have access to an external monitor. If you shine a flashlight at the screen at an angle can you discern the desktop when it is on?

por

@mayer no post tone only the DVD sound? but sometimes I have the volume off and I didnt get the post tone anyway when it was working properly. I did the flashlight trick, which is why I think Its not the screen as I couldnt see anything. Yes i have acces to a monitor but I dont have the cable to do it, is the problem.

por

Agregar un comentario
MacBook Battery Fix Kits
Fix Kits Starting at $69.99
MacBook Battery Fix Kits
Starting at $69.99

2 Respuestas

Solución Elegida

So the problem was the logic board or the graphics chip, I flowed it according to this video and the problem has been "resolved".

https://www.youtube.com/watch?v=S0J6bTwO...

I know its not a permanent fix and I will have to replace eventually. As long as people understand that, know that this method has worked for me.

Fue útil esta respuesta?

Calificación 1
Agregar un comentario
Respuesta Más Útil

I need to know if it will POST. Do a PRAM reset on startup by pressing the power button and immediately hold down the P, R, command and option keys (keep them depressed). Let it do this three times. You should get a tone on the second time. Let us know your results. Your sound setting do not matter when doing this.

Fue útil esta respuesta?

Calificación 1

Comentarios:

I couldnt do that because the keyboard was not working - Its okay though because i found the issue, it was the logic board or the graphics chip. I "Fixed" it already. I know ill havce to replace though. Thanks for answering my question though

por

Agregar un comentario

Añadir tu respuesta

Sammy estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 0

Últimos 7 Días: 0

Últimos 30 Días: 4

Todo El Tiempo: 52